Page 1 of 1

Problem Installing RTL8821CE [Solved]

Posted: Thu Jan 10, 2019 21:17
by valdrio
Hi, hope to be in the right section :)
I'm tryng to install the drivers for the wifi bluetooth combo RTL8821CE.
I enter the directory with the make file and then launch make, it stops with the following message:

Code: Select all

CC [M]  /home/valdrio/asus/rtl8821ce/os_dep/linux/os_intfs.o
/home/valdrio/asus/rtl8821ce/os_dep/linux/os_intfs.c:1325:22: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
  .ndo_select_queue = rtw_select_queue,
/home/valdrio/asus/rtl8821ce/os_dep/linux/os_intfs.c:1325:22: note: (near initialization for ‘rtw_netdev_ops.ndo_select_queue’)
cc1: some warnings being treated as errors
make[2]: *** [scripts/ /home/valdrio/asus/rtl8821ce/os_dep/linux/os_intfs.o] Error 1
make[1]: *** [Makefile:1505: _module_/home/valdrio/asus/rtl8821ce] Error 2
make[1]: uscita dalla directory "/usr/src/linux-4.18.0-sabayon"
make: *** [Makefile:1902: modules] Error 2
Does someone have any idea on how to resolve?
Thanks in advance

Re: Problem Installing RTL8821CE

Posted: Tue Jan 15, 2019 13:31
by Alexander88207
I think you do it like i would do it?

Code: Select all

sudo equo i sys-kernel/sabayon-sources:4.18 --ask
git clone
cd rtl8821ce
sudo make install

Re: Problem Installing RTL8821CE

Posted: Tue Jan 15, 2019 20:09
by valdrio
now it works, you trust me if i tell you that the only difference was that i downloaded it manually? Meaning with firefox and the extraxted the zip

Thank you very much

Edit: A last question if I update the kernel do i need to reinstall the drivers? thanks again

Re: Problem Installing RTL8821CE

Posted: Tue Jan 15, 2019 22:37
by Alexander88207
nice to hear it works now & yes if you update the kernel you need to rebuild & install the driver :)

Re: Problem Installing RTL8821CE [Solved]

Posted: Fri May 31, 2019 17:52
by GranMain
Hi...I am wondering if anyone has an idea of how to get the RTL8821CE Bluetooth module working on Manjaro? It works fine in Windows 10, I got the Wifi part working on Manjaro by getting the source code for the driver on github and make/make install/modprobe it with each kernel update. If I don’t do this, I have no WiFi either. I ask, because Bluetooth is the only part of the laptop that does ot work at all in Linux. And I want to use a bluetooth mouse to not use one of the precious USB po.

pcb assembly toronto