Grub install failure on MacbookPro [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Grub install failure on MacbookPro [Solved]

Postby shaytaan » Mon Feb 20, 2017 22:25

Hi all,

I am trying to install Sabayon 16.11 on am 2010 MacbookPro. All goes well until the final grub installation, where it fails. I tried installing it manually, but i keep getting the same error: grub2-install: error: cannot find efi directory
My partition setup is using LVM, but I have the volumes active and mounted before chrooting into the installed env.
From there I tried running grub2-install with the various options, specifying the efi directory, the target arch etc... But no hope, I keep getting the same message: grub2-install error cannot find efi directory
I have installed openSuse and CentOS on the same machine successfully, so I am pretty sure it has to be a setting somewhere which is failing, not incompatibility.
Can any one help with some advice, please?
Last edited by shaytaan on Tue Feb 21, 2017 14:22, edited 1 time in total.
shaytaan
Baby Hen
 
Posts: 2
Joined: Thu Jul 26, 2012 14:54

Re: Grub install failure on MacbookPro

Postby shaytaan » Tue Feb 21, 2017 14:21

Ok, I managed to figure it out and install grub.
The issue is better explained here: https://bugzilla.redhat.com/show_bug.cgi?id=1114808
Seems the grub2-install script copies the core.efi file to the wrong location.
I copied the file manually and generated the grub config and it worked, system boots.
Hope this will help anyone else in this situation or encounters the same error.
shaytaan
Baby Hen
 
Posts: 2
Joined: Thu Jul 26, 2012 14:54


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron