sound went totally crazy

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
denijane
Growing Hen
Posts: 168
Joined: Tue Feb 13, 2007 19:54
Location: Sofia
Contact:

sound went totally crazy

Post by denijane » Mon May 09, 2016 22:01

After working very happily for almost a year, last week, my mic stopped working. To be precisely alsa and pulseaudio currently are behaving totally strange. Pulseaudio is constantly switching between my HDMI card (incorrectly) and my PCI sound card and also between Headphone and Speakers. I have a laptop so obviously the priority should be headphones->speakers.
The thing is according to pulseaudio I have constantly plugged in headphones (even though I don't) and my speakers are oddly unavailable even though they are internal. The same with the mic - the internal mic is unavailable, obviously I have invisible mic plugged in.

While the mess with the speakers is bearable, because after :
$sudo alsactl restore
pulseaudio suddenly finds my internal speakers, or it works fine when I plug external speakers, the mic situation is very bad. Thus far I managed to record from my internal mic only once and the volume of the mic is obviously very low, even though all the controls in alsamixer and pavucontrol say 100% and "on". I tried with external mic but I couldn't record a thing, presumably the volume is also set to the lowest somewhere.

So basically right now I can't use skype which is very bad.

The whole thing happened suddenly on a trip to Turkey so rightfully or no, I think they may be result of external interference. Or pulseaudio just went crazy on its own, I have no idea.

My question:
1) Any ideas of the config files where the volume of the mic may be set. From my experiments, the microphone is working, it's just recording with a very low volume for no obvious reason.
2) The more realistic option: any idea how to purge all the configs of alsa and pulseaudio and to reinstall them.
I tried equo remove --nodeps alsa-core pulseaudio
and then I reinstalled them, but nothing changed. If I remove the --nodeps option, equo tries to uninstall my whole kde, which obviously is not cool.
I removed /etc/pulse/default.pa and ~/.config/pulse/*
but it didn't help.
I tried setting up a default source and sink in both pactl and /etc/modprobe.d/alsa.conf but either I don't do that correctly or it didn't help.
3) Any ideas how to find out what is messing pulseaudio. I tried with pulseaudio -vvvvv but I don't know for what to watch in the log.

Actually, any ideas how to fix the problem without making a clean install of Sabayon would be very appreciated. Because after days of messing up with alsa and pactl, I'm running out of options. And I'd really prefer to avoid reinstalling Sabayon. Way too much things to reinstall afterwards...

Post Reply