Very disappointed (laptop)

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
papin1
Baby Hen
Posts: 1
Joined: Sun Apr 10, 2016 14:50

Very disappointed (laptop)

Post by papin1 » Sun Apr 10, 2016 15:43

Hi,

I am very disappointed with the Sabayon amd64 Gnome 16.03 version. I ran it live before install, lucky me.

I have an old Asus laptop (around 2008/2009) with a P8400 processor, a Synaptics touchpad and a Nvdia 9300 GS M graphic card (only 512 MB ram) and 4 GB ram.

None of these hardware work out of the box. I have installed Sabayon 2.8, 3.4 successfuly before on almost the same laptop (Asus with T9300 and a Radeon 3650 with 1 GB memory).

Now, and first, while I'm typing this, the TTY #1 is constantly looping saying cannot find the Nvidia card. And I cannot access to any other TTY.

Second, the touchpad is not working, and I cannot the tap so I can use it at minimum (anyway, Synaptics is working poor in almost ALL Linux -- I have currently installed Linux Mint 17.3, PCLOS 2016; I am not new to Linux since my first install in 2000 with Red Hat 6.0). Luckily I've got a wired mouse, but I prefer the touchpad.

Third, ACPI is not working. As I'am typing, the fan is almost full speed. Not good for my PC. I already have a major complain with Flash on Windows --I can get along with badly written software (e.g. chrome + Flash (try Opera, you'll understand).

Four. I launch Calamares, and I don't see where is the setting for the boot loader. I already have a boot loader, I don't want it to be overwritten. Furthermore, in a recent post here, somebody already complain about the lack of customizing the bootloader. To me, this is a MAJOR drawback.

Five. I don't know why all modern Linux distros automatically set the wifi on, and do not use the wire. I had to manually disconnect the wifi, and goto inside the settings to enable ethernet.

I might have a sixth complain with the keyboard but it's not Sabayon's culprit, so forget it.

The only setup that has it right is the Elementary OS' one, especially on the partitioning part (to compare with the last OpenSuse Leap, which is a total failure for me). For the record, Anaconda in 2000 was doing not less bad than in 2016, if not better considering the so-called progress in Linux in the last 15 years.

I don't get it. Any Knoppix, among many other distros as well, is able to find the correct hardware, connect to Internet without fiddling with the settings. Why Sabayon fails here?

And now, there is this Dock thing, which I don't know how to disable because I want access to the standard menu. (OK, it's not part of the hardware problem, but since I'm here...)

I'm sorry, but because of the heat problem (remember ACPI no working?), I have to shutdown this box the hardest way (power button), and come back here from another one.

And no, I won't install Sabayon as it is. (And if it stays like this, this will be my last attempt for this distro. Too bad, the last one I tried was very good and I liked it very much, and I was about to make the 2016 version my main Linux box.)

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Very disappointed (laptop)

Post by wolfden » Sun Apr 10, 2016 21:52

Have you tried a different desktop environment? Try 16.04? Did live run ok? Did you use USB or DVD? USB is way more reliable for media.

Gnome really isn't stable imho, it's gotten better since the new gnome has come out, but I see users having issues with gnome all the time. Maybe try Mate or XFCE for something easier on older hardware. Keep in mind we are running "bleeding edge" stuff here. Knoppix supports older computers better.

I have an older laptop similiar to yours and had no issues, but it was just getting so slow that I finally updated to a newer laptop. Have you tried nouveau drivers instead of nvidia? Have you tied passing parameters to the boot? https://wiki.sabayon.org/index.php?titl ... c_Hardware

I find touchpads annoying in any OS. It's like it has a mind of it's own and just does whatever.

Calamares development is coming along, yes it has it's drawbacks at the moment. I haven't tried the latest 2.0 version yet, but a bit more patients and hopefully Calamares will soon support more features. Anaconda is just evil, I don't miss it one bit.

wifi/wired is personal choice opinion, not really an issue. I would rather have wifi default for a laptop.

Anyway, I suggest you use what distro works best on your laptop. Sabayon isn't going to work for everyone. There are distros out there that specifically target older machines and they work great.

BradHeff
Baby Hen
Posts: 17
Joined: Thu Apr 07, 2016 1:21
Location: Cleve, South Australia

Re: Very disappointed (laptop)

Post by BradHeff » Mon Apr 11, 2016 6:53

i have a similar laptop and sabayon works well for me. mind you i run the MATE edition.
my laptop is Asus M50V,

intel core(TM)2 Duo T9400 processor,
i also have the Synaptics touchpad and a Nvdia Geforce 9600M GS.

only thing i can relate to your problem is the graphics drivers. on live CD *MATE Edition* it looped a few pages with the cant find Nvidia adapter error stuff then loaded into the live session. same after i installed does same thing. i just uninstall the nvidia drivers and nvidia userspace and unblocked nouveau.

steps i take after fresh install

remove the drivers.

Code: Select all

sudo equo rm nvidia-drivers nvidia-userspace
then unblock nouveau

Code: Select all

sudo nano /etc/modprobe.d/blacklist.conf
Find

Code: Select all

blacklist nouveau
replace

Code: Select all

#blacklist nouveau
check opengl. you want xorg-x11 to have the *

Code: Select all

[email protected] ~ $ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
if its not selected simply

Code: Select all

sudo eselect opengl set 2
Then reboot and all is sweet :)

My touchpad is working also, out of the box tap to click was disabled just had to enable it manually.

Having run older versions you most likley already knew this just wanted to make sure. im a new linux user only been running linux distro's 5 years and this the first gentoo based distro ive ran and think its fantastic. mind you i dont have previous versions to compare too.
Hope you get it worked out.
Image

Post Reply