X crashes with xf86-video-intel-2.99.914

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

X crashes with xf86-video-intel-2.99.914

Postby ElDuderino » Sun Aug 03, 2014 18:50

Hi,

with latest intel driver from limbo, my KDE desktop becomes very unstable, only updates parts of the screen, and crashes after 1-2 minutes.

Anyone else experiencing that?

Best,
the dude
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: X crashes with xf86-video-intel-2.99.914

Postby wolfden » Wed Aug 06, 2014 8:38

I'm not on KDE, but working fine on Razor-qt
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: X crashes with xf86-video-intel-2.99.914

Postby ElDuderino » Fri Aug 08, 2014 19:15

Strange. Xorg.log shows me no errors. I don't think it has anything to do with DE, but with the driver. 912 doesn't crash, but seems more slow / sloppy, esp. with dropdown menus, where only every second entry is highlighted. I used portage to downgrade to 911-r1, this is the last version that works fine for me.

Google finds no similar reports. What could be wrong?
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: X crashes with xf86-video-intel-2.99.914

Postby maidmantis » Fri Aug 15, 2014 10:12

Hi gents,

Have the same issue. But X crashes when I run Chromium/Google Chrome and try to open some site.
Some info from /var/log/Xorg.0.log.old:

Code: Select all
[    61.428] (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1398 1430 1486  768 770 774 782 -hsync -vsync (46.6 kHz eP)
[   241.693] (EE)
[   241.693] (EE) Backtrace:
[   241.772] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58c156]
[   241.773] (EE) 1: /usr/bin/X (0x400000+0x18fe19) [0x58fe19]
[   241.773] (EE) 2: /lib64/libpthread.so.0 (0x7f38f0d7e000+0x10b10) [0x7f38f0d8eb10]
[   241.773] (EE) 3: /usr/bin/X (AttendClient+0x17) [0x58e167]
[   241.773] (EE) 4: /usr/bin/X (DRI2SwapComplete+0x135) [0x55e355]
[   241.773] (EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f38ee09f000+0xf3785) [0x7f38ee192785]
[   241.773] (EE) 6: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f38ee09f000+0xf5d6d) [0x7f38ee194d6d]
[   241.773] (EE) 7: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f38ee09f000+0xf654c) [0x7f38ee19554c]
[   241.773] (EE) 8: /usr/bin/X (DRI2SwapBuffers+0x254) [0x55e6c4]
[   241.773] (EE) 9: /usr/bin/X (0x400000+0x15fa90) [0x55fa90]
[   241.773] (EE) 10: /usr/bin/X (0x400000+0x3b4e6) [0x43b4e6]
[   241.773] (EE) 11: /usr/bin/X (0x400000+0x29eea) [0x429eea]
[   241.773] (EE) 12: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f38efc02c45]
[   241.773] (EE) 13: /usr/bin/X (0x400000+0x2a231) [0x42a231]
[   241.773] (EE)
[   241.773] (EE) Segmentation fault at address 0x0
[   241.773] (EE)
Fatal server error:
[   241.773] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   241.773] (EE)
[   241.773] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   241.773] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   241.773] (EE)
[   241.773] (II) AIGLX: Suspending AIGLX clients for VT switch
[   242.503] (EE) Server terminated with error (1). Closing log file.


HP ProBook 4530s
Code: Select all
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (rev ff)

x11-drivers/xf86-video-intel-2.99.914
x11-base/xorg-server-1.14.7

Thanks!
Alex
maidmantis
Baby Hen
 
Posts: 1
Joined: Wed Jan 08, 2014 10:33
Location: Ukraine

Re: X crashes with xf86-video-intel-2.99.914

Postby Fitzcarraldo » Sun Aug 17, 2014 10:23

Probably a bug in xf86-video-intel-2.99.914. The driver maintainer has made several fixes to xf86-video-intel since 2.99.914 was released on 23 July 2014. See: http://cgit.freedesktop.org/xorg/driver ... intel/log/ for list of changes. You'll need to wait until the next version of xf86-video-intel is released by X.Org, then gets into Gentoo and from there into SL.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: X crashes with xf86-video-intel-2.99.914

Postby ElDuderino » Sun Sep 14, 2014 15:10

It still persists with 2.99.916 from portage. Here is a picture of what it looks like after login (it will crash soon after):

Image
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: X crashes with xf86-video-intel-2.99.914

Postby tomekwalowski » Thu Oct 02, 2014 17:22

I have problems too. I reinstal this driver, but now xbmc not working, when i try play movie on vlc - after when I press play vlc crashed and close :( xmbc not working too. What they doing in intel or sabayon - I dont know :(
tomekwalowski
Simple Hen
 
Posts: 60
Joined: Fri Mar 20, 2009 2:20

Re: X crashes with xf86-video-intel-2.99.914

Postby Fitzcarraldo » Thu Oct 02, 2014 19:12

Try the tips given in the following section of the Arch Linux Wiki article on the Intel driver: https://wiki.archlinux.org/index.php/In ... tel_driver
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: X crashes with xf86-video-intel-2.99.914

Postby ElDuderino » Sat Oct 04, 2014 15:33

Haven't tried turning off DRI / Acceleration, yet. This would only be a temporary workaround, since it was working before. Using i915.semaphores=1 did not help. I'll just stay on 911 and see if it gets fixed in the future.

Maybe is has something to do with having hybrid graphics (Intel/AMD)? I don't have the problem on my Netbook, which also has Intel graphics (and nothing else).
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: X crashes with xf86-video-intel-2.99.914

Postby Fitzcarraldo » Sat Oct 25, 2014 8:30

Do you still experience the problem with xf86-video-intel-2.99.916, the current version in the SL Weekly repository?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron