System ask about keymap on every boot. [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

totrash
Baby Hen
Posts: 5
Joined: Mon Jun 24, 2013 20:19

System ask about keymap on every boot. [Solved]

Post by totrash » Mon May 26, 2014 22:37

Hi

After big update (include switching to systemd) I have some problems.
The most frustrating is that systems ask me about keymap on every boot.
How to set it permanently ????
Here are some cfg`s

Code: Select all

cat /etc/vconsole.conf 
KEYMAP=pl2
FONT=lat2-16

Code: Select all

Command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.14.0-sabayon root=/dev/mapper/vg_oberfirer-lv_root ro init=/linuxrc splash=silent,theme:sabayon video=vesafb:ywrap,mtrr:3 vga=791 gfxpayload=1024x768x16 console=tty1 quiet dokeymap keymap=pl domdadm resume=swap:/dev/mapper/vg_oberfirer-lv_swap real_resume=/dev/mapper/vg_oberfirer-lv_swap dolvm root=/dev/mapper/vg_oberfirer-lv_root docrypt
Ok so I investigate a little more and:

there is 2 interesting parameters in my grub.cfg BOOT_IMAGE line

Code: Select all

dokeymap
and

Code: Select all

keymap=pl
So the file grub.cfg is auto-generated and there is a comment about that file inside it:

Code: Select all

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#
So the

Code: Select all

keymap=pl
option is probably generated from my /etc/vconsole.conf
But what about dokeymap why is it there ?
It is probably the reason of tty1 ask me about keymap on boot

But If I shouldn`t edit this file how to get rid of this.
Last edited by totrash on Sun Jun 08, 2014 16:06, edited 1 time in total.

Frank1965
Baby Hen
Posts: 7
Joined: Wed May 28, 2014 8:49

Re: System ask about keymap on every boot.

Post by Frank1965 » Wed May 28, 2014 9:13

This very annoying thing happens to me too after upgrade from 3.14.0 to 3.14.2. In /etc/vconsole.conf i see:

Code: Select all

FONT=LatArCyrHeb-16
KEYMAP=it
and i see in grub.cfg the two params:

Code: Select all

dokeymap keymap=it
still at bootup the system requests to me the keycode

any hint?

svantoviit
Old Dear Hen
Posts: 750
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: System ask about keymap on every boot.

Post by svantoviit » Wed May 28, 2014 9:56

Just press Enter or wait a second and the default keymap layout will be used.

Frank1965
Baby Hen
Posts: 7
Joined: Wed May 28, 2014 8:49

Re: System ask about keymap on every boot.

Post by Frank1965 » Wed May 28, 2014 15:00

I already now that, but how can i get rid of the request at bootup? And why the request shows as default value us/41 while in /etc/vconsole.conf and in grub.cfg i got KEYMAP=it? Where is set the default value?

User avatar
albfneto
Sagely Hen
Posts: 1911
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: System ask about keymap on every boot.

Post by albfneto » Wed May 28, 2014 21:12

I have the same issue, bu in the boot of the Sabayon's Live DVD, then the boot not continue,
the message asking for the new keymap is recharged, and all tried keymaps received messages of "invalid keymap"
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

Frank1965
Baby Hen
Posts: 7
Joined: Wed May 28, 2014 8:49

Re: System ask about keymap on every boot.

Post by Frank1965 » Thu May 29, 2014 8:01

It seems a problem related to kernel 3.14 (which version is there in your live-cd?). I still can't find useful documentation about the troublesome setting.

svantoviit
Old Dear Hen
Posts: 750
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: System ask about keymap on every boot.

Post by svantoviit » Thu May 29, 2014 9:17

Try to remove dokeymap from /etc/default/sabayon-grub and regenerate grub config.

Frank1965
Baby Hen
Posts: 7
Joined: Wed May 28, 2014 8:49

Re: System ask about keymap on every boot.

Post by Frank1965 » Thu May 29, 2014 9:28

Removed dokeymap from /etc/default/sabayon-grub and launched

Code: Select all

grub2-mkconfig -o /boot/grub/grub.cfg
but the problem is still there. Thanks anyway.

User avatar
Minda
Baby Hen
Posts: 17
Joined: Sun Jan 26, 2014 17:45

Re: System ask about keymap on every boot.

Post by Minda » Thu May 29, 2014 14:27

I have the same issue... in the boot of the Sabayon's Live DVD, live DVD works normal. After fresh install system ask me about key-map on every boot... I still can't find useful solution for this problem. :cry:
Image

Frank1965
Baby Hen
Posts: 7
Joined: Wed May 28, 2014 8:49

Re: System ask about keymap on every boot.

Post by Frank1965 » Thu May 29, 2014 14:41

Everybody who got this problem runs kernel 3.14? It looks to me a problem reading some config file.

Post Reply