Sabayon on dell inspiron 17, ATI/INTEL issue

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Sabayon on dell inspiron 17, ATI/INTEL issue

Postby fuorviatos » Mon Nov 11, 2013 19:00

First of all a small hello to every Sabayon user :)

I'm trying to get my Sabayon 13.08 live to boot on my laptop. The video hardvare is a hybrid ati/intel chip.
At boot, Xorg hangs with no display (only a blinking cursor)
Neither, I can boot into console mode as it makes the system hangs as well.
This happens before any partition is mounted so no logs get produced.
The only way I've found so far is booting sabayon in normal mode then switching into a virtual console to get to the login shell as root.

Any help is appreciated. I love gentoo/sabayon so it's important for me to have it installed :)
fuorviatos
Baby Hen
 
Posts: 5
Joined: Tue Jan 10, 2012 14:05

Re: Sabayon on dell inspiron 17, ATI/INTEL issue

Postby fuorviatos » Tue Nov 12, 2013 23:05

Anyone? One buddy told me he had a hybrid video too but what he did was removing fglrx driver from console mode.
Sadly, I cannot get even there.

Help pls.
fuorviatos
Baby Hen
 
Posts: 5
Joined: Tue Jan 10, 2012 14:05

Re: Sabayon on dell inspiron 17, ATI/INTEL issue

Postby linuxfluesterer » Thu Nov 14, 2013 10:22

Did you read this?
https://forum.sabayon.org/viewtopic.php?f=50&t=30991#p167385

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 706
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Sabayon on dell inspiron 17, ATI/INTEL issue

Postby fuorviatos » Thu Nov 14, 2013 16:30

Thanks. I will try that solution. Even if, this morning I played with different xdriver parameters in order to force °radeonhd° and °vesa° driver. Again, all I get is a root shell and °no screens found° xorg error.

Playing with kernel mode settings seems interesting, though. I'll update you on the results. :)
fuorviatos
Baby Hen
 
Posts: 5
Joined: Tue Jan 10, 2012 14:05

Re: Sabayon on dell inspiron 17, ATI/INTEL issue

Postby fuorviatos » Thu Nov 14, 2013 22:24

Well, Success; I got it to run after long playing around with kernel prompt.
However, I've observed some interesting things:

1) adding "xdriver=radeonhd,radeon" eliminating vga=771, doesn't really help. (the vga line seems to be an instruction to kernel on the resolution) It''s not likely invoking a proprietary driver, right ?

2) adding nomodeset will end up with Xorg failing to vesa, even if another driver is given.

3) Using "safe mode" with "noproprietary" entry seems to do the trick - here, it boots up on Intel driver directly
So, here is the line:
Code: Select all
aufs cdroot noproprietary pci=routeirq irqpoll  nokvm --

Here comes the question - why is the "xdriver" entry ignored even if "radeon" or "radeonhd" is specified. They are not proprietary drivers at all.

I hope I've made my point, maybe I am a bit confused so sorry for that. This is only basic feedback. I'm gonna look into it better.
fuorviatos
Baby Hen
 
Posts: 5
Joined: Tue Jan 10, 2012 14:05


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest