Over heating ATI GPU [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Over heating ATI GPU [Solved]

Postby rekinchin » Sat Nov 09, 2013 11:24

I have a laptop with HD 5xxxx gpu that I know is switchable but is only used on AC due to a failing battery.

just running firefox my GPU is 164f and when I run a game can reach 220 (before shutdown) I am running Ati Drivers 13.9#3.10.0-sabayon~4 from the distro. Is there a way of running the GPU cooler I have heard that switchable graphics is not supported but I dont need it to switch just run the ATI.

Thanks
Last edited by rekinchin on Tue Nov 26, 2013 22:55, edited 1 time in total.
rekinchin
Young Hen
 
Posts: 30
Joined: Fri Sep 20, 2013 12:51

Re: Over heating ATI GPU

Postby anomaly65 » Wed Nov 13, 2013 1:11

Hi rekinchin,

Are you looking to reduce the GPU speed (result: reduce heat) or increase fan speed perhaps?

Cheers,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Over heating ATI GPU

Postby rekinchin » Thu Nov 14, 2013 0:30

Hi Andy,
Fan speed and efficiency is not too bad if I can run it faster then it would help,but its the heat generated by the GPU that is the problem. Any way to run it cooler would be good if there are any adjustments that can be made to speed etc, it runs much cooler when it uses its original windows driver in windows. Is this a common problem with laptops? Are both GPU's on at the same time? Can I turn the ATI GPU off and use just the inbuilt intel GPU? I may have to stop running (any) linux if I cant reduce the heat which would be a pity.
rekinchin
Young Hen
 
Posts: 30
Joined: Fri Sep 20, 2013 12:51

Re: Over heating ATI GPU

Postby anomaly65 » Thu Nov 14, 2013 3:01

Hi rekinchin,

Yes, laptops with either brand of GPU (or integrated even) have heat and power consumption to deal with when running 3d games. ati-drivers aren't so great (nvidia either) at automatically moderating GPU speed. Think of it as "CPU speed step" in 2003, where CPU's at that time had very coarse, and few options for lowering speed when not needed.

You may wish to try aticonfig (located in /opt/bin -- part of the amdcccle package), while these are intended for overdrive, you can adjust them for lower frequencies of course, which as long as the framerate is ok for you, will reduce the heat, so if you find that you get good framerates at say 50% of max GPU speed, then set the number accordingly (these will reset to default upon reboot each time), the main idea is that you hopefully lower heat a bit, but still get enough performance that your game looks good of course:

I've used the following to both slow and speed up my own desktop setup (2 x 7850 cards in crossover mode) and the commands work as advertised. Mainly I slow things down for less noise, but II also did successfully overclock just for fun once or twice :D

You'll need to adjust your numbers according to what your GPU reports as it's normal speeds and capabilities.

Code: Select all
   
       Get Clocks of GPU0        :  /opt/bin/aticonfig --adapter=0 --od-getclocks
       Set new Clocks for GPU0   :  /opt/bin/aticonfig --adapter=0 --od-setclocks=770,1126
 


Note that on the "setclocks" command, the first number is GPU speed, the second is memory speed,

Here is another/different authors notes from bitcoin mining forum which still apply nicely:

To check the temperature, retrieve the current core/memory clocks and get the current fanspeed:

aticonfig --odgt
aticonfig --odgc
aticonfig --pplib-cmd "get fanspeed 0"

To set the core and memory clocks

aticonfig --odsc 1000,1200

will set the core to 1000Mhz and memory to 1200Mhz.

To set the fanspeed

aticonfig --pplib-cmd "set fanspeed 0 100"

will set the fan to max speed.

aticonfig --pplib-cmd "set fanspeed 0 auto"

will put it back to temperature controlled.

Hope this helps (and I hope it works for you!) 8)

Final suggestion, do use compressed or bottled clean air to get dust out of the laptop, as they always collect no matter how clean the air might seem :mrgreen:

Good luck,
andy

p.s. with dual graphics (cpu-integrated and your external ati GPU) look around for "PowerXpress" as that may let you choose which graphics core works for you. Archlinux seems to have info on that topic in their wiki. I don't have that hardware setup or I would try and be more helpful there :(
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Over heating ATI GPU

Postby rekinchin » Thu Nov 14, 2013 23:06

Thanks Andy,
having a problem running aticonfig
Code: Select all
/opt/bin/aticonfig --adapter=0 --od-getclocks
ERROR - X needs to be running to perform AMD Overdrive(TM) commands

any idea why that would be?
rekinchin
Young Hen
 
Posts: 30
Joined: Fri Sep 20, 2013 12:51

Re: Over heating ATI GPU

Postby anomaly65 » Fri Nov 15, 2013 2:47

run it from an X window (e.g. konsole, xterm, etc) as root, and it should return values correctly. aticonfig except for the initial configuration option expects X windows to be running. Doesn't matter which desktop manager you like (e.g. xfce, kde, gnome), even just having basic X running should do the trick.

Hope that helps :-)
andy

p.s. here's my output (while running a kde environment)
# /opt/bin/aticonfig --adapter=0 --od-getclocks

Adapter 0 - AMD Radeon HD 7800 Series
Core (MHz) Memory (MHz)
Current Clocks : 450 1200
Current Peak : 860 1200
Configurable Peak Range : [300-1050] [150-1450]
GPU load : 17%
as such, it gives some guide as to what range/option is programmed into the "micro-vga-bios" for the video chip. I can set my max GPU clocks as low as 300 to reduce heat, or up to 1.05Ghz for performance boost.
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Over heating ATI GPU

Postby rekinchin » Sat Nov 16, 2013 11:25

Hi Andy,

I was running it in Konsole and as root, tried it in xterm and even startx from kde to get a basic X. It comes up with the same response. (I'm running kde)

Code: Select all
 # /opt/bin/aticonfig --adapter=0 --od-getclocks
ERROR - X needs to be running to perform AMD Overdrive(TM) commands


X is running in the process table

I have googled and it seems to be a common problem with a variety of possible solutions none seeming to work for me. I am getting a feeling that you cant run aticonfig on the same graphics card as you are looking at. I am simplifying here but a number of solutions included remote putty or ssh into the system.
rekinchin
Young Hen
 
Posts: 30
Joined: Fri Sep 20, 2013 12:51

Re: Over heating ATI GPU

Postby anomaly65 » Sat Nov 16, 2013 20:34

Interesting. I too run kde, and just "su" to root in a konsole window then run the command.

Oh, one thought comes to mind. It may be "idle" and running on the "on cpu" graphics mini-core. I'll look up how to switch it on so you can run the command more easily.

Cheers,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Over heating ATI GPU [Solved]

Postby rekinchin » Tue Nov 26, 2013 22:57

Thanks for you help anomaly65 in more ways than you think lol it was you "step-by-step solution for most users with ATI cards [Solved]" post that cured the problem along with my non working driver with the latest Sab release
rekinchin
Young Hen
 
Posts: 30
Joined: Fri Sep 20, 2013 12:51


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests