NVidia Driver [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

NVidia Driver [Solved]

Postby pethor » Mon Sep 02, 2013 16:50

Hey guys!

I've downloaded Sabayon 13.08 x64 today as a replacement for my Linux Mint :D system
I was unable to get the graphics working at all, not even with the nouveau driver ...

Hardware Specs:

Intel Core i7 3630 QM (with integrated Graphics)
NVidia Geforce GTX670MX

Output of /var/log/Xorg.log

Code: Select all
[    45.078]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[    45.078] X Protocol Version 11, Revision 0
[    45.079] Build Operating System: Linux 3.7.0-server x86_64 Gentoo
[    45.080] Current Operating System: Linux localhost 3.10.0-sabayon #1 SMP Wed Jul 24 21:54:12 UTC 2013 x86_64
[    45.080] Kernel command line: initrd=/boot/sabayon.igz aufs cdroot splash vga=791 quiet -- BOOT_IMAGE=/boot/sabayon
[    45.081] Build Date: 18 June 2013  05:34:51AM
[    45.081] 
[    45.081] Current version of pixman: 0.30.0
[    45.082]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    45.082] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    45.084] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep  2 15:02:29 2013
[    45.085] (==) Using config file: "/etc/X11/xorg.conf"
[    45.085] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    45.085] (==) ServerLayout "Main Layout"
[    45.085] (**) |-->Screen "Screen 1" (1)
[    45.085] (**) |   |-->Monitor "Generic Monitor"
[    45.085] (**) |   |-->Device "SabayonVga1"
[    45.085] (**) Option "AllowMouseOpenFail" "true"
[    45.085] (==) Automatically adding devices
[    45.085] (==) Automatically enabling devices
[    45.085] (==) Automatically adding GPU devices
[    45.085] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    45.085]    Entry deleted from font path.
[    45.085] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    45.085]    Entry deleted from font path.
[    45.085] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    45.085]    Entry deleted from font path.
[    45.085] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    45.085]    Entry deleted from font path.
[    45.085]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    45.085] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    45.085]    Entry deleted from font path.
[    45.085]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    45.086] (==) FontPath set to:
   /usr/share/fonts/misc/
[    45.086] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    45.086] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    45.086] (II) Loader magic: 0x7f970d2d6c00
[    45.086] (II) Module ABI versions:
[    45.086]    X.Org ANSI C Emulation: 0.4
[    45.086]    X.Org Video Driver: 13.1
[    45.086]    X.Org XInput driver : 18.0
[    45.086]    X.Org Server Extension : 7.0
[    45.086] (II) config/udev: Adding drm device (/dev/dri/card1)
[    45.086] (II) config/udev: Adding drm device (/dev/dri/card0)
[    45.087] (--) PCI:*(0:0:2:0) 8086:0166:1462:10d9 rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    45.087] (--) PCI: (0:1:0:0) 10de:11a1:1462:10d9 rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    45.087] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    45.087] Initializing built-in extension Generic Event Extension
[    45.088] Initializing built-in extension SHAPE
[    45.088] Initializing built-in extension MIT-SHM
[    45.088] Initializing built-in extension XInputExtension
[    45.089] Initializing built-in extension XTEST
[    45.089] Initializing built-in extension BIG-REQUESTS
[    45.089] Initializing built-in extension SYNC
[    45.090] Initializing built-in extension XKEYBOARD
[    45.090] Initializing built-in extension XC-MISC
[    45.090] Initializing built-in extension XINERAMA
[    45.090] Initializing built-in extension XFIXES
[    45.091] Initializing built-in extension RENDER
[    45.091] Initializing built-in extension RANDR
[    45.091] Initializing built-in extension COMPOSITE
[    45.092] Initializing built-in extension DAMAGE
[    45.092] Initializing built-in extension MIT-SCREEN-SAVER
[    45.092] Initializing built-in extension DOUBLE-BUFFER
[    45.093] Initializing built-in extension RECORD
[    45.093] Initializing built-in extension DPMS
[    45.093] Initializing built-in extension X-Resource
[    45.094] Initializing built-in extension XVideo
[    45.094] Initializing built-in extension XVideo-MotionCompensation
[    45.095] Initializing built-in extension XFree86-VidModeExtension
[    45.095] Initializing built-in extension XFree86-DGA
[    45.095] Initializing built-in extension XFree86-DRI
[    45.095] Initializing built-in extension DRI2
[    45.095] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    45.096] (II) LoadModule: "extmod"
[    45.096] (II) Module "extmod" already built-in
[    45.096] (II) LoadModule: "i2c"
[    45.096] (II) Module "i2c" already built-in
[    45.096] (II) LoadModule: "ddc"
[    45.096] (II) Module "ddc" already built-in
[    45.096] (II) LoadModule: "vbe"
[    45.096] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    45.096] (II) Module vbe: vendor="X.Org Foundation"
[    45.096]    compiled for 1.13.4, module version = 1.1.0
[    45.096]    ABI class: X.Org Video Driver, version 13.1
[    45.096] (II) LoadModule: "dri"
[    45.096] (II) Module "dri" already built-in
[    45.096] (II) LoadModule: "glx"
[    45.096] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    45.102] (II) Module glx: vendor="NVIDIA Corporation"
[    45.102]    compiled for 4.0.2, module version = 1.0.0
[    45.102]    Module class: X.Org Server Extension
[    45.102] (II) NVIDIA GLX Module  319.32  Wed Jun 19 14:55:38 PDT 2013
[    45.103] Loading extension GLX
[    45.103] (II) LoadModule: "synaptics"
[    45.103] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    45.103] (II) Module synaptics: vendor="X.Org Foundation"
[    45.103]    compiled for 1.13.4, module version = 1.7.1
[    45.103]    Module class: X.Org XInput Driver
[    45.103]    ABI class: X.Org XInput driver, version 18.0
[    45.103] (II) LoadModule: "nvidia"
[    45.103] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    45.103] (II) Module nvidia: vendor="NVIDIA Corporation"
[    45.103]    compiled for 4.0.2, module version = 1.0.0
[    45.103]    Module class: X.Org Video Driver
[    45.103] (II) NVIDIA dlloader X Driver  319.32  Wed Jun 19 14:34:12 PDT 2013
[    45.103] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    45.103] (--) using VT number 2

[    45.212] (II) Loading sub module "fb"
[    45.212] (II) LoadModule: "fb"
[    45.213] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    45.213] (II) Module fb: vendor="X.Org Foundation"
[    45.213]    compiled for 1.13.4, module version = 1.0.0
[    45.213]    ABI class: X.Org ANSI C Emulation, version 0.4
[    45.213] (WW) Unresolved symbol: fbGetGCPrivateKey
[    45.213] (II) Loading sub module "wfb"
[    45.213] (II) LoadModule: "wfb"
[    45.213] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    45.213] (II) Module wfb: vendor="X.Org Foundation"
[    45.213]    compiled for 1.13.4, module version = 1.0.0
[    45.213]    ABI class: X.Org ANSI C Emulation, version 0.4
[    45.213] (II) Loading sub module "shadow"
[    45.213] (II) LoadModule: "shadow"
[    45.213] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[    45.213] (II) Module shadow: vendor="X.Org Foundation"
[    45.213]    compiled for 1.13.4, module version = 1.1.0
[    45.213]    ABI class: X.Org ANSI C Emulation, version 0.4
[    45.213] (II) Loading sub module "ramdac"
[    45.213] (II) LoadModule: "ramdac"
[    45.213] (II) Module "ramdac" already built-in
[    45.214] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    45.214] (==) NVIDIA(0): RGB weight 888
[    45.214] (==) NVIDIA(0): Default visual is TrueColor
[    45.214] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    45.214] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1"
[    45.214] (**) NVIDIA(0): Option "AddARGBGLXVisuals" "true"
[    45.214] (**) NVIDIA(0): Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"
[    45.214] (**) NVIDIA(0): Enabling 2D acceleration
[    45.377] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 670MX (GK104) at PCI:1:0:0 (GPU-0)
[    45.377] (--) NVIDIA(0): Memory: 1572864 kBytes
[    45.377] (--) NVIDIA(0): VideoBIOS: 80.04.5b.00.a5
[    45.377] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    45.380] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 670MX at PCI:1:0:0
[    45.380] (--) NVIDIA(0):     DFP-0
[    45.380] (--) NVIDIA(0):     DFP-1
[    45.380] (--) NVIDIA(0):     DFP-2
[    45.380] (--) NVIDIA(0): DFP-0: 165.0 MHz maximum pixel clock
[    45.380] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
[    45.380] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    45.380] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[    45.380] (--) NVIDIA(0): DFP-2: 960.0 MHz maximum pixel clock
[    45.380] (--) NVIDIA(0): DFP-2: Internal DisplayPort
[    45.380] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
[    45.383] (EE) NVIDIA(0): Failing initialization of X screen 0
[    45.394] (II) UnloadModule: "nvidia"
[    45.394] (II) UnloadSubModule: "shadow"
[    45.394] (II) UnloadSubModule: "wfb"
[    45.394] (II) UnloadSubModule: "fb"
[    45.394] (EE) Screen(s) found, but none have a usable configuration.
[    45.394]
Fatal server error:
[    45.394] no screens found
[    45.394] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    45.394] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    45.394] (EE)
[    45.616] Server terminated with error (1). Closing log file.


Code: Select all
eselect opengl list
says

Code: Select all
[1] ati
[2] nvidia *
[3] xorg-x11


I've already searched the web for quite a while, but I'm wondering wheter anyone of you guys here could help me?

Thanks in advance! :)
Last edited by pethor on Tue Sep 03, 2013 21:39, edited 1 time in total.
pethor
Baby Hen
 
Posts: 5
Joined: Mon Sep 02, 2013 16:20

Re: NVidia Driver

Postby pethor » Mon Sep 02, 2013 16:52

Oh, and my xorg.conf

Code: Select all

Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load    "i2c"
    Load    "ddc"
    Load    "vbe"
    Load    "dri"
    Load    "glx"
    Load    "synaptics"
EndSection

Section "ServerFlags"
     Option    "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier  "SabayonVga1"
    Driver      "nvidia"
    BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
    #Option "UseEvents" "True"
    Option "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"

EndSection
   


Section "Screen"

    Identifier    "Screen 1"
    Device        "SabayonVga1"
    Monitor       "Generic Monitor"
    Option       "AddARGBGLXVisuals" "true"
    Option       "RegistryDwords" "EnableBrightnessControl=1"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 1    "Screen 1"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection
pethor
Baby Hen
 
Posts: 5
Joined: Mon Sep 02, 2013 16:20

Re: NVidia Driver

Postby remolek » Mon Sep 02, 2013 22:24

[ 45.380] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
[ 45.383] (EE) NVIDIA(0): Failing initialization of X screen 0

And in xorg.conf :
Section "Screen"
Identifier "Screen 1"
...
Section "ServerLayout"
...
Screen 1 "Screen 1"

I think, you need to make corrections in xorg.conf or try to fully remove it.
remolek
Baby Hen
 
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Re: NVidia Driver

Postby NoSavy » Tue Sep 03, 2013 13:31

Here's my xorg.conf :

Code: Select all
Section "Module"
    SubSection  "extmod"
       Option    "omit xfree86-dga"
    EndSubSection
    Load       "i2c"
    Load       "ddc"
    Load       "vbe"
    Disable       "dri"
    Load       "glx"
    Load       "synaptics"
EndSection

Section "ServerFlags"
     Option       "AllowMouseOpenFail"    "true"
EndSection

Section "Monitor"
    Identifier  "Dell 2007FP"
    VertRefresh    43 - 60
    HorizSync      28 - 80
EndSection


Section "Device"

    Identifier   "SabayonVga0"
    Driver      "nvidia"
#     Driver   "nouveau"
    #BusID    "PCI:01:00"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    # UseEvents is causing segmentation faults with
    # NVIDIA 6xxx, 7xxx and >=275.xx.xx drivers
#########    #Option "UseEvents" "True"sabayonlinux-nvidia.png"

    Option    "LogoPath" "/usr/share/backgrounds/sabayonlinux-nvidia.png"
EndSection
   


Section "Screen"

    Identifier    "Screen 0"
    Device      "SabayonVga0"
    Monitor     "Dell 2007FP"
    Option      "AddARGBGLXVisuals" "true"

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection

EndSection


Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier  "Main Layout"
    Screen 0    "Screen 0"
EndSection

Section "Extensions"
   #Option "Composite" "Enable"
EndSection


Try to see what's different
Asus M4A79XTD EVO motherboard, AMD Phenom II X4 965 CPU, 4 GB ram.
Gigabyte NVIDIA 9800GT Silent graphics card, Dell FP2007 22 Digital Flat panel.
Samsung harddisks 2 x 200gb SP2004S,1 x Hitachi 750gb HDT 72107,Optiarc SATA DVD-RW. Sabayon 64 & 32bit.
NoSavy
Simple Hen
 
Posts: 74
Joined: Tue Aug 24, 2010 8:49
Location: Dorset,UK

Re: NVidia Driver

Postby pethor » Tue Sep 03, 2013 21:39

Seemingly, deleting the xorg.conf at least enables me to get graphics going at all, but just at low-res ...
I'll mark this thread as Solved and I'll dig into the X server config ... maybe that will help somehow ...

Thank you guys for trying to help!
pethor
Baby Hen
 
Posts: 5
Joined: Mon Sep 02, 2013 16:20

Re: NVidia Driver [Solved]

Postby itlarson » Sat Sep 28, 2013 0:54

Have you tried (as root) "nvidia-xconfig"? In Sabayon you should use "su" instead of "sudo", just in case you are new to this distro.
itlarson
Baby Hen
 
Posts: 14
Joined: Fri Jun 15, 2012 20:51

Re: NVidia Driver [Solved]

Postby sigahotcore » Mon Oct 07, 2013 1:59

viewtopic.php?f=56&t=29842

Here is my tread that helped me get nvidia drivers right .
Maybe it helps .
sigahotcore
Young Hen
 
Posts: 30
Joined: Sat May 04, 2013 2:54


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron