UEFI Asus laptop - Cannot boot

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
dudumomo
Growing Hen
Posts: 149
Joined: Tue Nov 16, 2010 14:40
Contact:

UEFI Asus laptop - Cannot boot

Post by dudumomo » Thu Jul 18, 2013 16:39

Hi there,

I've been trying to install Sabayon on my new laptop, an Asus X450JF.
The installation is working well, but when I restart the computer, it directly boot on Windows 8.
There isn't any grub.

I believe it is coming from the UEFI...and something needs to be done haha.... But don't know what?

How does it work?

Thanks for your help !

PS: Actually, it is the same with Ubuntu too :lol:

dudumomo
Growing Hen
Posts: 149
Joined: Tue Nov 16, 2010 14:40
Contact:

Re: UEFI Asus laptop - Cannot boot

Post by dudumomo » Fri Jul 19, 2013 4:30

Okay Solved ! Nice !

I had to disable CSM and Fastboot + boot on the USB key as UEFI in the BIOS.
During installation, I have to make sure the EFI partition is recognized and assigned /boot/efi as mounting point.

Now it works !

But I've lost the Windows 8 entry.... Any idea on how to fix it?

Thanks

lxnay
Land Owner
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy
Contact:

Re: UEFI Asus laptop - Cannot boot

Post by lxnay » Fri Jul 19, 2013 11:13

You should be able to boot Windows 8 from the UEFI boot menu in your "BIOS" (there should be two entries, one for Windows, one for Sabayon) or chainload it from the Sabayon bootloader (GRUB2). Google will tell you more about this last one.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+

dudumomo
Growing Hen
Posts: 149
Joined: Tue Nov 16, 2010 14:40
Contact:

Re: UEFI Asus laptop - Cannot boot

Post by dudumomo » Sat Jul 20, 2013 7:09

Okay, Indeed I can have access to Wn 8 through the BIOS menu.

For Grub modification, any good tuto to share?
I found several but with different methodology....

Thank you !

Post Reply