Cups not opening in browser(13.06) [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Cups not opening in browser(13.06) [Solved]

Postby fbaggins » Mon May 13, 2013 15:53

I've installed 13.04 with all the updates, but I get a 102 error (connection refused ) when trying to configure my printers with CUPS. Hplip crashes at the final page of writing, with no error messages in terminal.
Any help greatly appreciated

Howard
Last edited by fbaggins on Mon May 13, 2013 19:41, edited 1 time in total.
fbaggins
Young Hen
 
Posts: 35
Joined: Thu Feb 15, 2007 9:34

Re: Cups not opening in browser(13.06)

Postby Fitzcarraldo » Mon May 13, 2013 17:46

How are you running the CUPS Printer Manager? Are you using a Web browser and entering the URL http://localhost:631/ into the address bar of the Web browser? If not, try that way rather than using the HPLIP tools.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cups not opening in browser(13.06)

Postby fbaggins » Mon May 13, 2013 18:21

I've tried both ways, chromium says
Error 102 (net::ERR_CONNECTION_REFUSED): The server refused the connection.

thanks for reply
Howard
fbaggins
Young Hen
 
Posts: 35
Joined: Thu Feb 15, 2007 9:34

Re: Cups not opening in browser(13.06)

Postby lxnay » Mon May 13, 2013 18:30

Read the CUPS logs and you will know why you get connection refused.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Cups not opening in browser(13.06)

Postby fbaggins » Mon May 13, 2013 19:09

var/log/cups is empty
fbaggins
Young Hen
 
Posts: 35
Joined: Thu Feb 15, 2007 9:34

Re: Cups not opening in browser(13.06)

Postby lxnay » Mon May 13, 2013 19:12

Then cups is not running
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Cups not opening in browser(13.06)

Postby fbaggins » Mon May 13, 2013 19:29

Tried starting cups

Library howard # /etc/init.d/cupsd start
* WARNING: cupsd is already starting
Library howard # /etc/init.d/cupsd stop
* ERROR: cupsd stopped by something else
Library howard # /etc/init.d/cupsd start
* WARNING: cupsd is already starting
Library howard #

Thanks Howard
fbaggins
Young Hen
 
Posts: 35
Joined: Thu Feb 15, 2007 9:34

Re: Cups not opening in browser(13.06)

Postby lxnay » Mon May 13, 2013 19:31

You are using systemd, so you have to use systemctl and not /etc/init.d/...
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Cups not opening in browser(13.06)

Postby fbaggins » Mon May 13, 2013 19:40

systemctl start cups

Success

Thanks
fbaggins
Young Hen
 
Posts: 35
Joined: Thu Feb 15, 2007 9:34


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests