TP-LINK WiFi adapter failed after kernel upgrade

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Simple Hen
Posts: 89
Joined: Mon Aug 10, 2009 4:02

Re: TP-LINK wireless adapter failed after kernel upgrade

Post by nickdanger » Sat May 11, 2013 3:11

I tried using -Dnl80211 and the initialization completes with no errors.

Code: Select all

tuxbox # /etc/init.d/NetworkManager stop
 * Caching service dependencies ...                                       [ ok ]
 * Unmounting network filesystems ...                                     [ ok ]
 * Stopping NetworkManager ...                                            [ ok ]
tuxbox # wpa_supplicant -B -Dnl80211 -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
The adapter still will not transfer any data to the access point.

Thinking that the Developers had systemd in mind, I switched to systemd and rebooted. Systemd worked well, but the TP-Link adapter still did not. Since I had jumped from kernel 3.7 to 3.9-r3, I decided to try installing 3.8.8 to see if it worked. Using kernel 3.8.8 the TP-Link adapter works very well, so I will stick with that kernel for now. The curious part is when I searched entropy for linux-sabayon, I found the 3.8.8 kernel I am using now, but kernel 3.9-r3 was no longer available. So the mystery is not solved but, the adapter is working. I think it is OK to mark this solved.
Thank You Again!

Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: TP-LINK WiFi adapter failed after kernel upgrade [Solved

Post by Fitzcarraldo » Sat May 11, 2013 12:05

Well, solved until the 3.9-r3 kernel gets pushed to the Sabayon Weekly Entropy Repository, anyway. Perhaps there will be some changes to the 3.9.x kernel configuration or an upgrade to the kernel source code before a 3.9.x version finally gets pushed to the SL weekly repository, in which case you might get lucky. It could be that the firmware installed by the current version of the package linux-firmware is not compatible with the 3.9-r3 kernel. Anyway, all you can do is wait and see what happens.

Simple Hen
Posts: 89
Joined: Mon Aug 10, 2009 4:02

Re: TP-LINK WiFi adapter failed after kernel upgrade

Post by nickdanger » Tue May 14, 2013 16:03

I can now confirm the problem is related to kernel build 3.9-r3. I wiped the hard drive, and did a fresh install from 13.04 Gnome 64-bit from the monthly repository. Normal installation with no issues. Installed all updates and kernel 3.8.8, once again, no problems at all except my usual ATI Radeon open source driver problems, (slow rendering, flashing screen, and no HDMI audio). Switched ATI drivers to fglrx, and all was good. Upgraded to kernel 3.8.10 and associated recent upgrades, which worked perfectly once I eselect OpenGL set ATI. Today, switched the kernel to 3.9-r3, and the TP-Link adapter immediately quit connecting. No modifications to any configuration files except, in /etc/default/grub added "GRUB_CMDLINE_LINUX="nomodeset" .
The web page
lists new firmware only 8 days old, so it is likely that this issue will be resolved in the near future.

Post Reply