Page 2 of 3

Re: Radeon 7500M/7600M Series

Posted: Mon Apr 29, 2013 20:38
by rcorgui
corgui renan # uname -r
3.8.0-sabayon

Re: Radeon 7500M/7600M Series

Posted: Tue Apr 30, 2013 16:50
by nickdanger
I have a Radeon 7850 GDDR5 video card. I got a lot of the same errors you are getting. Something in the process breaks the xorg server. All I did was re-installed Xorg Server using RIGO, and then my card worked (using the steps anomaly65 posted).
I still get the funky multiple graphics if I drop to console, and when I shutdown, but I guess I can live with that for now, because normal usage works fine.

Re: Radeon 7500M/7600M Series

Posted: Wed May 01, 2013 0:37
by rcorgui
I will do the tests until tomorrow morning.
and put what happened.
Thank you.
att
Renan Corgui
made in brasil!

Re: Radeon 7500M/7600M Series

Posted: Thu May 02, 2013 3:37
by anomaly65
I also disabled the consolefont

Code: Select all

rc-update del consolefont boot 
which seemed to clean up the console.

On another system, I brute force reinstalled the majority of they system which helped like so:

Code: Select all

equo install --empty kde-meta linux-sabayon ati-drivers chromium firefox thunderbird --multifetch=10 
Adjust according to the DE you prefer, and add in other programs which draw in dependencies.

During the chromium install, it suggests adding fonts for better looks. Worth it as it makes chrome look better.

Good luck,
andy

Re: Radeon 7500M/7600M Series

Posted: Thu May 02, 2013 18:45
by rcorgui
lords will not believe,
It did not work none of the alternatives they gave me.
= / Sad

Re: Radeon 7500M/7600M Series

Posted: Thu May 02, 2013 22:18
by rcorgui
made and remade!
several times to be sure.
I made a clonezilla image to stay up easier.
unfortunately it did not work yet ...

Re: Radeon 7500M/7600M Series

Posted: Sat May 04, 2013 0:26
by rcorgui
any more tips?
with emerge I can do these steps?
will be what can this be?

Re: Radeon 7500M/7600M Series

Posted: Tue May 07, 2013 4:09
by anomaly65
I did a fresh install. seems this helps solve more problems....

Code: Select all

 equo remove =x11-base/xorg-drivers-1.14 
It pulls in conflicting opensource ati drivers.

good luck;)

Re: Radeon 7500M/7600M Series

Posted: Thu May 09, 2013 0:28
by rcorgui
I'm not using xorg 1:14
but xorg 1:13
opensource does not work on this board or the dual head ati-drivers.
just only works on ubuntu, debian 7 yet.
= /

Re: Radeon 7500M/7600M Series

Posted: Thu May 09, 2013 10:58
by TeeJay76
Ok, I found a solution which works quite well for me. I couldn't test it thoroughly yet but it seems to be stable and working. I am using kernel 3.8.10 with amd-drivers-13.4, x11-drivers/xf86-video-intel-2.21.6 and my GPU is a Radeon HD 7730M

The key seems to lie in the xf86-video-intel driver not having being compiled with UXA support but only the newer SNA which seems to be causing the above problems, so you need to recompile the driver yourself.

Here's a quick step-by-step walkthrough:

equo remove xf86-video-intel
emerge --sync
euse -E uxa
emerge xf86-video-intel

equo install amd-drivers amd-userspace

and then the usual aticonfig procedure....

I hope this helps.