Radeon 7500M/7600M Series

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: Radeon 7500M/7600M Series

Postby rcorgui » Mon Apr 29, 2013 20:38

corgui renan # uname -r
3.8.0-sabayon
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby nickdanger » Tue Apr 30, 2013 16:50

I have a Radeon 7850 GDDR5 video card. I got a lot of the same errors you are getting. Something in the process breaks the xorg server. All I did was re-installed Xorg Server using RIGO, and then my card worked (using the steps anomaly65 posted).
I still get the funky multiple graphics if I drop to console, and when I shutdown, but I guess I can live with that for now, because normal usage works fine.
nickdanger
Simple Hen
 
Posts: 89
Joined: Mon Aug 10, 2009 4:02

Re: Radeon 7500M/7600M Series

Postby rcorgui » Wed May 01, 2013 0:37

I will do the tests until tomorrow morning.
and put what happened.
Thank you.
att
Renan Corgui
made in brasil!
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby anomaly65 » Thu May 02, 2013 3:37

I also disabled the consolefont
Code: Select all
rc-update del consolefont boot
which seemed to clean up the console.

On another system, I brute force reinstalled the majority of they system which helped like so:

Code: Select all
equo install --empty kde-meta linux-sabayon ati-drivers chromium firefox thunderbird --multifetch=10


Adjust according to the DE you prefer, and add in other programs which draw in dependencies.

During the chromium install, it suggests adding fonts for better looks. Worth it as it makes chrome look better.

Good luck,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 298
Joined: Sat Nov 17, 2007 15:37

Re: Radeon 7500M/7600M Series

Postby rcorgui » Thu May 02, 2013 18:45

lords will not believe,
It did not work none of the alternatives they gave me.
= / Sad
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby rcorgui » Thu May 02, 2013 22:18

made and remade!
several times to be sure.
I made a clonezilla image to stay up easier.
unfortunately it did not work yet ...
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby rcorgui » Sat May 04, 2013 0:26

any more tips?
with emerge I can do these steps?
will be what can this be?
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby anomaly65 » Tue May 07, 2013 4:09

I did a fresh install. seems this helps solve more problems....

Code: Select all
 equo remove =x11-base/xorg-drivers-1.14


It pulls in conflicting opensource ati drivers.

good luck;)
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 298
Joined: Sat Nov 17, 2007 15:37

Re: Radeon 7500M/7600M Series

Postby rcorgui » Thu May 09, 2013 0:28

I'm not using xorg 1:14
but xorg 1:13
opensource does not work on this board or the dual head ati-drivers.
just only works on ubuntu, debian 7 yet.
= /
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby TeeJay76 » Thu May 09, 2013 10:58

Ok, I found a solution which works quite well for me. I couldn't test it thoroughly yet but it seems to be stable and working. I am using kernel 3.8.10 with amd-drivers-13.4, x11-drivers/xf86-video-intel-2.21.6 and my GPU is a Radeon HD 7730M

The key seems to lie in the xf86-video-intel driver not having being compiled with UXA support but only the newer SNA which seems to be causing the above problems, so you need to recompile the driver yourself.

Here's a quick step-by-step walkthrough:

equo remove xf86-video-intel
emerge --sync
euse -E uxa
emerge xf86-video-intel

equo install amd-drivers amd-userspace

and then the usual aticonfig procedure....

I hope this helps.
TeeJay76
Baby Hen
 
Posts: 9
Joined: Thu May 09, 2013 10:53

PreviousNext

Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests