Radeon 7500M/7600M Series

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Radeon 7500M/7600M Series

Postby rcorgui » Sat Apr 27, 2013 17:56

Good afternoon everyone,
I have a great difficulty in installing the drivers from ati.
Does not work in any way, follows the log below

[ 1163.425] (II) [KMS] drm report modesetting isn't supported.
[ 1163.425] (EE) Screen 0 deleted because of no matching config section.
[ 1163.425] (II) UnloadModule: "radeon"
[ 1163.425] (EE) Device(s) detected, but none match those in the config file.
[ 1163.425]
Fatal server error:
[ 1163.425] no screens found
[ 1163.425] (EE)
Please consult the The X.Org Foundation support
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby anomaly65 » Sun Apr 28, 2013 7:18

Hi,

please try instructions found in https://forum.sabayon.org/viewtopic.php?f=56&t=28808

These should work find for any recent (HD5000 or newer) ATI/AMD video card.

Good luck!!
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37

Re: Radeon 7500M/7600M Series

Postby rcorgui » Sun Apr 28, 2013 23:43

Hi,
It did not work,
Already tried all the tutorials this forum
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby Provia » Mon Apr 29, 2013 11:32

I'm not an ati owner but the steps are:
-remove radeon opensource driver
-install ati proprietary driver
-edit /etc/default/grub with this line GRUB_CMDLINE_LINUX="nomodeset"
-/opt/bin/aticonfig --initial <--to configure xorg.conf
-sudo eselect opengl set ati <--to set opengl rendering on fglrx

can you post your xorg.conf,/etc/default/grub and the output of eselect opengl list?

Thank you
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Radeon 7500M/7600M Series

Postby rcorgui » Mon Apr 29, 2013 14:09

Xorg.conf

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby Provia » Mon Apr 29, 2013 16:39

ok...but what about other steps? output of 'eselect opengl list' and content of /etc/default/grub ?
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Radeon 7500M/7600M Series

Postby rcorgui » Mon Apr 29, 2013 17:38

Available OpenGL implementations:
[1] xorg-x11 *
[2] ati


corgui renan # eselect opencl set amd
!!! Error: The amd OpenCL implementation doesn't seem to provide
!!! Error: libOpenCL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenCL implementation.
!!! Error: Selected OpenCL implementation incomplete.
exiting
corgui renan # eselect opengl set ati
!!! Error: The ati OpenGL implementation doesn't seem to provide
!!! Error: libGL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenGL implementation.
!!! Error: Selected OpenGL implementation incomplete.
exiting


corgui renan # cat /etc/default/grub
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/files/grub.default-2,v 1.2 2012/06/28 22:36:53 floppym Exp $
#
# To populate all changes in this file you need to regenerate your
# grub configuration file afterwards:
# 'grub2-mkconfig -o /boot/grub2/grub.cfg'
#
# See the grub info page for documentation on possible variables and
# their associated values.

GRUB_DEFAULT=saved
GRUB_DISTRIBUTOR="Sabayon"

GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISABLE_LINUX_UUID=true

GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="nomodeset"
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby rcorgui » Mon Apr 29, 2013 18:07

reinstall drivers

[email protected]:~$ cat Xorg.0.log
[ 10.331]
X.Org X Server 1.13.3
Release Date: 2013-03-07
[ 10.331] X Protocol Version 11, Revision 0
[ 10.331] Build Operating System: Linux 3.7.0-server x86_64 Gentoo
[ 10.331] Current Operating System: Linux corgui 3.8.0-sabayon #1 SMP Sat Apr 27 18:24:29 UTC 2013 x86_64
[ 10.332] Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-3.8.0-sabayon ro nomodeset init=/linuxrc splash=silent,theme:sabayon video=vesafb:ywrap,mtrr:3 vga=791 gfxpayload=1024x768x16 console=tty1 quiet dokeymap keymap=br-a domdadm resume=swap:UUID=6f51c06a-747a-4e4d-aae4-e4e53e9e8d79 real_resume=UUID=6f51c06a-747a-4e4d-aae4-e4e53e9e8d79 root=UUID=4b07401f-bacb-44c2-893b-3daae7e1902c docrypt
[ 10.332] Build Date: 17 March 2013 09:56:56PM
[ 10.332]
[ 10.332] Current version of pixman: 0.29.2
[ 10.332] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 10.332] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 10.332] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 29 13:56:42 2013
[ 10.334] (==) Using config file: "/etc/X11/xorg.conf"
[ 10.334] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 10.334] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 10.334] (==) ServerLayout "aticonfig Layout"
[ 10.334] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[ 10.334] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
[ 10.334] (**) | |-->Device "aticonfig-Device[0]-0"
[ 10.334] (==) Automatically adding devices
[ 10.334] (==) Automatically enabling devices
[ 10.334] (==) Automatically adding GPU devices
[ 10.336] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 10.336] Entry deleted from font path.
[ 10.336] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 10.336] Entry deleted from font path.
[ 10.336] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 10.336] Entry deleted from font path.
[ 10.336] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 10.336] Entry deleted from font path.
[ 10.336] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 10.336] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 10.336] Entry deleted from font path.
[ 10.336] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 10.336] (==) FontPath set to:
/usr/share/fonts/misc/
[ 10.336] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 10.336] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 10.336] (II) Loader magic: 0x808be0
[ 10.336] (II) Module ABI versions:
[ 10.336] X.Org ANSI C Emulation: 0.4
[ 10.336] X.Org Video Driver: 13.1
[ 10.336] X.Org XInput driver : 18.0
[ 10.336] X.Org Server Extension : 7.0
[ 10.338] (--) PCI:*(0:0:2:0) 8086:0166:1028:057f rev 9, Mem @ 0xf7800000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[ 10.338] (--) PCI: (0:2:0:0) 1002:6841:1028:057f rev 0, Mem @ 0xe0000000/268435456, 0xf7e20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[ 10.338] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 10.338] Initializing built-in extension Generic Event Extension
[ 10.338] Initializing built-in extension SHAPE
[ 10.338] Initializing built-in extension MIT-SHM
[ 10.338] Initializing built-in extension XInputExtension
[ 10.338] Initializing built-in extension XTEST
[ 10.338] Initializing built-in extension BIG-REQUESTS
[ 10.338] Initializing built-in extension SYNC
[ 10.338] Initializing built-in extension XKEYBOARD
[ 10.338] Initializing built-in extension XC-MISC
[ 10.338] Initializing built-in extension XINERAMA
[ 10.338] Initializing built-in extension XFIXES
[ 10.338] Initializing built-in extension RENDER
[ 10.338] Initializing built-in extension RANDR
[ 10.338] Initializing built-in extension COMPOSITE
[ 10.338] Initializing built-in extension DAMAGE
[ 10.338] Initializing built-in extension MIT-SCREEN-SAVER
[ 10.338] Initializing built-in extension DOUBLE-BUFFER
[ 10.338] Initializing built-in extension RECORD
[ 10.338] Initializing built-in extension DPMS
[ 10.338] Initializing built-in extension X-Resource
[ 10.338] Initializing built-in extension XVideo
[ 10.338] Initializing built-in extension XVideo-MotionCompensation
[ 10.338] Initializing built-in extension XFree86-VidModeExtension
[ 10.338] Initializing built-in extension XFree86-DGA
[ 10.338] Initializing built-in extension XFree86-DRI
[ 10.338] Initializing built-in extension DRI2
[ 10.338] (II) "glx" will be loaded by default.
[ 10.338] (II) LoadModule: "glx"
[ 10.348] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 10.352] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[ 10.352] compiled for 6.9.0, module version = 1.0.0
[ 10.352] Loading extension GLX
[ 10.352] (II) LoadModule: "fglrx"
[ 10.352] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
[ 10.439] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[ 10.439] compiled for 1.4.99.906, module version = 12.10.5
[ 10.439] Module class: X.Org Video Driver
[ 10.440] (II) Loading sub module "fglrxdrm"
[ 10.440] (II) LoadModule: "fglrxdrm"
[ 10.440] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
[ 10.446] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[ 10.446] compiled for 1.4.99.906, module version = 12.10.5
[ 10.446] (II) AMD Proprietary Linux Driver Version Identifier:12.10.05
[ 10.446] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-12.10.17
[ 10.446] (II) AMD Proprietary Linux Driver Build Date: Mar 14 2013 15:53:12
[ 10.446] (++) using VT number 7

[ 10.472] (WW) Falling back to old probe method for fglrx
[ 10.526] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[ 10.528] ukiDynamicMajor: found major device number 241
[ 10.528] ukiDynamicMajor: found major device number 241
[ 10.528] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[ 10.528] ukiOpenDevice: node name is /dev/ati/card0
[ 10.528] ukiOpenDevice: open result is 9, (OK)
[ 12.068] ukiOpenByBusid: ukiOpenMinor returns 9
[ 12.068] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[ 12.096] (--) Chipset Supported AMD Graphics Processor (0x6841) found
[ 12.096] (II) fglrx: intel VGA device detected, load intel driver.
[ 12.096] (II) LoadModule: "intel"
[ 12.096] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 12.101] (II) Module intel: vendor="X.Org Foundation"
[ 12.101] compiled for 1.13.3, module version = 2.21.6
[ 12.101] Module class: X.Org Video Driver
[ 12.101] ABI class: X.Org Video Driver, version 13.1
[ 12.102] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[ 12.102] (II) AMD Video driver is unsigned
[ 12.102] (II) fglrx(0): pEnt->device->identifier=0x1ef6c70
[ 12.105]
Fatal server error:
[ 12.105] atiddxProbe: fail to probe intel VGA device
[ 12.105] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 12.105] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 12.105] (EE)


does not work
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Re: Radeon 7500M/7600M Series

Postby Provia » Mon Apr 29, 2013 19:43

mmmmmmm.....................i suggest you to try to upgrade your kernel to 3.8.8 and then redo all the steps.
AMD Athlon(tm) II X2 250 Processor
4 GB DDR3 1600 Mhz
Nvidia Geforce 9800 GT
Sabayon Linux x64 KDE Limbo
Provia
Advanced Hen
 
Posts: 209
Joined: Mon Nov 26, 2012 23:15
Location: Italy

Re: Radeon 7500M/7600M Series

Postby rcorgui » Mon Apr 29, 2013 20:30

I'm already using 3.8

:(
rcorgui
Baby Hen
 
Posts: 16
Joined: Sat Apr 27, 2013 17:52

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest