After update opengl stopped working [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

After update opengl stopped working [Solved]

Postby notzippy » Wed Apr 10, 2013 23:04

Hi

I had switched over to the opensource drivers months ago, I am running kernel 3.8 after last weeks update I lost my wobbly windows and 3dcube desktop
Code: Select all
cat /var/log/Xorg.0.log

http://pastebin.sabayon.org/pastie/12443
Code: Select all
# glxinfo -display :0.0 | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on AMD RV770
    GL_NV_conditional_render, GL_AMD_conservative_depth,

# lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4870]



In my modules I have modules="vboxdrv vboxnetflt vboxnetadp radeon"

Any help on how to correct this would be great,
Last edited by notzippy on Mon Apr 15, 2013 16:23, edited 1 time in total.
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: After update opengl stopped working

Postby ElDuderino » Thu Apr 11, 2013 21:13

Did OpenGL really stop working? Your glxinfo indicates otherwise. Check if your desktop effects are still enabled in your DE. What are you using? KDE? Compiz?

What does 'eselect opengl list' say? What happens if you start glxgears or play something like OpenArena?

I'm confused, because your glxinfo output says "direct rendering: yes". Therefore, I would check if your effects preferences got "unset" (I remember that if OpenGL is unavailable for whatevert reason, KDE will disable desktop effects until you re-enable them (so you can fix your OpenGL first).
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: After update opengl stopped working

Postby notzippy » Thu Apr 11, 2013 21:25

Sorry should have said I was using the KDE, Desktop effects are still enabled but if I switch from "No Animation" to "Desktop Cube Animation" the result is the same in both cases when I switch workspaces, it switches like there is no animation.

...~>eselect opengl list
Available OpenGL implementations:
[1] nvidia
[2] xorg-x11 *
...~>

glxgears outputs the following framerates but displays nothing.
...~>glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
294 frames in 5.0 seconds = 58.769 FPS
301 frames in 5.0 seconds = 60.002 FPS
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: After update opengl stopped working [Solved]

Postby notzippy » Mon Apr 15, 2013 16:27

System Settings -> Configure desktop Effects
Activation
Enable Desktop Effects at startup -> Change to checked.

Thanks ElDuderino for pointing this out, I had thought for some reason the config screen would have been disabled if the effects setting was not enabled.

Nz
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34

Re: After update opengl stopped working [Solved]

Postby albfneto » Thu Apr 18, 2013 15:46

your system is "changing" the Kwin settings, effects rastering? in automatic manner? is this?

If yes, see with this command:

Code: Select all
eselect qtgraphicssystem list


for good working, if you use "rastering" in Kwin, change from "native" or "opengl" with this command:

Code: Select all
sudo eselect qtgraphicssystem NUM
NUM is the number corresponding to "raster"
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: After update opengl stopped working [Solved]

Postby notzippy » Thu Apr 18, 2013 17:17

Hi
eselect qtgraphicssystem list shows raster is selected.

thanks
Nz
notzippy
Growing Hen
 
Posts: 115
Joined: Sat Jun 16, 2012 14:34


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest