Missed Keystrokes

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Missed Keystrokes

Postby mahalay » Mon Apr 01, 2013 17:00

I have a cheap laptop with an unknown brand, there seems to be a problem with the way it handles keyboard input.

Here's how it behaves:

When typing it seems to sporadically skip characters. Example, if I type "Hello" there's a chance that the entered text just becomes "Hllo". I tried the following without luck:

* Different distros - I tried SystemRescueCD; Funtoo; Ubuntu; Different flavors of Sabayon
* An external USB keyboard
* Toggling ACPI during boot and some IRQ tricks I found from other forums

Some success:

Few months back, the symptom doesn't seem to exist on 32-bit Sabayon (64-bit versions always have the problem), however after several updates (also updated the kernel), the symptom re-emerged. In windows everything works fine so my guess is that this laptop uses some sort of low quality "keyboard controller" - not sure what's the term. It seems that its "input buffer" is buggy - at least on 64bit Linux.

I hope somebody can point to me which kernel option I should check or experiment with - I am comfortable to compiling the kernel (been doing it for like 10 years already). Probably some kernel options cause this behavior.

Laptop Specs:
Intel Core i7-2630QM
6 MB, 2.0 GHz
Intel HM65
802.11 b/g/n
14.0″ HD (1366×768) LED
Intel HD Graphics 3000
500 GB
DVDRW SuperMulti
10/100/1000 Mbps
2 x USB 2.0
Bluetooth 2.1
1.3 MP Camera
6-cell Smart Li-ion

Thanks in advance
Baby Hen
Posts: 10
Joined: Tue Jul 12, 2011 15:05

Re: Missed Keystrokes

Postby mahalay » Thu May 23, 2013 7:20

Baby Hen
Posts: 10
Joined: Tue Jul 12, 2011 15:05

Re: Missed Keystrokes

Postby anomaly65 » Sun May 26, 2013 23:52

Sorry for your troubles :cry:

You might install "sabayon-sources" for earlier kernels and see if you can determine the differences. you'll find their .config files in /usr/src/linux-3.[version]-sabayon. Not an easy task definitely, but maybe my ideas below might help.....

Another thought....., install an older kernel and keep going. You can always download the older kernel package from the packages location on the sabayon website and "equo install xyz. Standard location is /var/lib/entropy/client/packages/amd64/5/[name of the package.tbz2] if I recall :)

Worst case, enable the Sabayon FROZEN (search the forums) repository and maintain your laptop from that.

You may also try to look at what chip might be the controller with "lspci" and "lsusb" commands which might help you find a better solution.

Hope that helps!!
Good luck,
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
Technological Hen
Posts: 305
Joined: Sat Nov 17, 2007 15:37

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests