problem with ATI card [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: problem with ATI card

Postby anomaly65 » Wed Apr 17, 2013 4:37

Hi VolvoBirkenstock,

Two items. Looks like a recent update eliminated the "nomodeset" in /etc/default/grub so check to see that is correctly set as in the first entry in this thread. As root
Code: Select all
 grub2-mkconfig -o /boot/grub/grub.cfg
will ensure grub is correctly configured.

I simply removed the consolefont from rc startup like so (again, as root in an xterm or konsole window)

Code: Select all
rc-update del consolefont boot


which eliminated it. Everything looks fine on my monitor afterwards in any case :lol:

Hope that helps!
Andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 300
Joined: Sat Nov 17, 2007 15:37

Re: problem with ATI card

Postby VolvoBirkenstock » Wed Apr 17, 2013 6:34

I verified that "nomodeset" was still entered correctly in /etc/default/grub. I also used sudo and saw that "nomodeset" was also in /boot/grub/grub.cfg. I then executed "rc-update del consolefont boot", and then used "rc-update show" to verify that consolefont was removed. (A boot entry for consolekit still exists.) I then rebooted. After reboot, I saw that the problem was still present on the virtual terminals and during shutdown. As you mentioned earlier I now suspect that the problem also lies in the /etc/ati directory.

Thanks very much for trying, Andy!
VolvoBirkenstock
Growing Hen
 
Posts: 153
Joined: Sun Mar 31, 2013 5:34

Re: problem with ATI card

Postby VolvoBirkenstock » Wed Apr 17, 2013 18:35

Just a stray thought, Andy. If the problem is contained within /etc/ati and you no longer have the problem, then perhaps we could compare contents. What follows is the output of "cd /etc/ati;ls -al":
Code: Select all
total 252
drwxr-xr-x   2 root root  4096 Apr  9 19:55 .
drwxr-xr-x 151 root root  8192 Apr 17 12:24 ..
-rw-r--r--   1 root root 44324 Apr 17 12:24 amdpcsdb
-rw-r--r--   1 root root 67456 Mar 23 14:28 amdpcsdb.default
-rw-r--r--   1 root root 41845 Mar 23 14:28 atiogl.xml
-rwxr-xr-x   1 root root  2749 Mar 23 14:28 authatieventsd.sh
-rw-r--r--   1 root root 39288 Mar 23 14:28 control
-rw-r--r--   1 root root 12902 Mar 23 14:28 logo_mask.xbm.example
-rw-r--r--   1 root root 12887 Mar 23 14:28 logo.xbm.example
-rw-r--r--   1 root root     8 Mar 23 14:28 signature

Thanks in advance again!
VolvoBirkenstock
Growing Hen
 
Posts: 153
Joined: Sun Mar 31, 2013 5:34

Re: problem with ATI card

Postby anomaly65 » Sat Apr 20, 2013 5:18

Sorry, thought I posted this one earlier. Perhaps I didn't click "submit" :(

output of ls -l /etc/ati:
Code: Select all
-rw-r--r--   1 root root 29640 Apr 19 20:15 amdpcsdb
-rw-r--r--   1 root root 67456 Mar 23 15:28 amdpcsdb.default
-rw-r--r--   1 root root 41845 Mar 23 15:28 atiogl.xml
-rwxr-xr-x   1 root root  2749 Mar 23 15:28 authatieventsd.sh*
-rw-r--r--   1 root root 39288 Mar 23 15:28 control
-rw-r--r--   1 root root 12902 Mar 23 15:28 logo_mask.xbm.example
-rw-r--r--   1 root root 12887 Mar 23 15:28 logo.xbm.example
-rw-r--r--   1 root root     8 Mar 23 15:28 signature


I disabled consolefont like so.

As root:

Code: Select all
rc-update del consolefont boot


and at next reboot, all seems ok. Apologies I didn't collect more information prior to OS reinstall (it can be done without disturbing your /home partition or others you wish to save :D ).

The only other item was to make sure "nomodeset" is in the option/line in /etc/default/grub like so:

Code: Select all
GRUB_CMDLINE_LINUX="nomodeset"


After that is in place

Code: Select all
grub2-mkconfig -o /boot/grub/grub.cfg


Will configure grub/boot options correctly to include that option, which seems very problematic with the ati-drivers package.

Good luck and I hope that helps!
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 300
Joined: Sat Nov 17, 2007 15:37

Re: problem with ATI card

Postby VolvoBirkenstock » Thu Apr 25, 2013 5:38

Thanks, Andy. I tried what you've written above except for the reinstallation. Th reinstallation work around is unacceptable for me right now. The problem still exists. Maybe the problem will be discovered and addressed in the future. If not, at some future time I will probably do a reinstallation.

Thanks again, Andy.
VolvoBirkenstock
Growing Hen
 
Posts: 153
Joined: Sun Mar 31, 2013 5:34

Re: problem with ATI card

Postby heindsight » Fri Jun 28, 2013 13:38

Hi,

I had the same problem after installing the ATI drivers. I believe the problem is that grub sets the display resolution to 1024x768 (see the GRUB_GFXMODE setting in /etc/default/grub) and the 'nomodeset' kernel option prevents the kernel from changing that. This means that the console framebuffer is stuck at 1024x768 and when X starts up and sets the display to a higher resolution, that messes up the framebuffer.

I managed to solve the problem by editing /etc/default/grub.conf and replacing the line:
Code: Select all
GRUB_GFXMODE=1024x768

with:
Code: Select all
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

This tells grub to set the display to it's preferred resolution and to keep that resolution when it boots the kernel.

I also had to edit /etc/default/sabayon-grub and replace the line:
Code: Select all
GRUB_CMDLINE_LINUX="${GRUB_CMDLINE_LINUX} splash=silent,theme:sabayon video=vesafb:ywrap,mtrr:3 vga=791 gfxpayload=1024x768x16 console=tty1 quiet dokeymap keymap=us domdadm resume=swap:/dev/mapper/vg_shadowfax-Swap real_resume=/dev/mapper/vg_shadowfax-Swap dolvm root=/dev/mapper/vg_shadowfax-Sabayon_Root docrypt"

with:
Code: Select all
GRUB_CMDLINE_LINUX="${GRUB_CMDLINE_LINUX} splash=silent,theme:sabayon console=tty1 quiet dokeymap keymap=us domdadm resume=swap:/dev/mapper/vg_shadowfax-Swap real_resume=/dev/mapper/vg_shadowfax-Swap dolvm root=/dev/mapper/vg_shadowfax-Sabayon_Root docrypt"

In other words, I removed the part that said:
Code: Select all
video=vesafb:ywrap,mtrr:3 vga=791 gfxpayload=1024x768x16


EDIT:
Sorry, I forgot to add. Don't just copy and paste the changes I made to /etc/default/sabayon-grub. Many of the kernel parameters specified there (eg keymap=, resume=, root=, etc.) are specifically tailored to your installation. Rather just remove the video=, vga= and gfxpayload= options.
User avatar
heindsight
Baby Hen
 
Posts: 17
Joined: Wed Jun 19, 2013 16:46
Location: London

Re: problem with ATI card

Postby anomaly65 » Tue Jul 02, 2013 13:37

heindsight, good call! -- confirmed. Hadn't realized I had made similar changes to /etc/default/sabayon-grub to solve the unreadable console on my own ati card setup. works like a charm.

Thanks!!
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 300
Joined: Sat Nov 17, 2007 15:37

Re: problem with ATI card

Postby VolvoBirkenstock » Wed Jul 03, 2013 3:24

I have also performed the modifications suggested by heindsight in addition to the other previous suggestions. The problem is still present after reboot. I may have to reinstall from scratch to defeat this problem.

Thank you for your diligent assistance and expertise.
VolvoBirkenstock
Growing Hen
 
Posts: 153
Joined: Sun Mar 31, 2013 5:34

Re: problem with ATI card

Postby heindsight » Thu Jul 04, 2013 10:50

Hi VolvoBirkenstock,

did you remember to run
Code: Select all
grub2-mkconfig -o /boot/grub/grub.cfg

after editing /etc/default/grub and /etc/default/sabayon-grub?

If you did then
Code: Select all
GRUB_GFXMODE=auto

is probably not the right setting for you. Try replacing that line with:
Code: Select all
GRUB_GFXMODE=1680x1050,auto

This will tell grub to try to set the resolution to 1680x1050 but to fall back to auto if that fails.

I hope that helps, if it doesn't, I'm afraid I'm all out of ideas :(
User avatar
heindsight
Baby Hen
 
Posts: 17
Joined: Wed Jun 19, 2013 16:46
Location: London

Re: problem with ATI card [Solved]

Postby VolvoBirkenstock » Fri Jul 05, 2013 4:45

Heindsight, you are correct. I forgot to execute "grub2-mkconfig -o /boot/grub/grub.cfg". The problem is fixed. I will mark this issue as "Solved".

A big thank you to both heindsight and anomaly65. You are both excellent!
VolvoBirkenstock
Growing Hen
 
Posts: 153
Joined: Sun Mar 31, 2013 5:34

PreviousNext

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest