Downgrade Xorg and use AMD Catalyst 12.6 legacy ? [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Downgrade Xorg and use AMD Catalyst 12.6 legacy ? [Solved]

Postby ElDuderino » Sat Mar 23, 2013 19:37

Hi,

I installed a fresh Sabayon 11 because I poured water over my laptop and had to replace my hdd. I upgraded the whole system right away without masking xorg to <1.13, so now I have Xorg 1.13. I see I can downgrade to 1.12 via portage (still has many older versions of xorg, as well), but there Catalyst Legacy (12.6_beta_pre897) has been removed from portage (and thus from entropy).

But I would like to downgrade to Xorg 1.12 and continue using Catalyst (unless radeon driver ever gets the same 3D capabilities). Why was the 12.6 legacy driver removed entirely? Is anyone going to make an overlay for it?

If there is/will be no overlay, what would be the best way to downgrade, so I can manually install the driver? Do I only need to mask the package xorg-server, or its deps, as well? What would be the safest way to achieve this setup?

Many thanks!

The Dude
Last edited by ElDuderino on Tue Apr 09, 2013 17:44, edited 1 time in total.
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby anomaly65 » Sun Mar 24, 2013 2:43

Hi,

Could you list your video card? AMD/ATI included many prior video cards in the current update, thus the removal of the 12.6 series. Or perhaps specify what issue you might be having 8)

Older packages (I may be incorrect here, but they are there somewhere!) are in the repository tree.

[url]
http://na.mirror.garr.it/mirrors/sabayo ... e/amd64/5/
[/url]

I put a quick-n-dirty path to get ATI cards working ok here:

[url]
http://forum.sabayon.org/viewtopic.php?f=56&t=28808
[/url]

Hope that helps. If not, add more info on your issues/goals and folks will try 8)
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby ElDuderino » Sun Mar 24, 2013 15:41

I have an ATI Radeon HD2400 (laptop), which needs the "legacy" driver, which was abandoned at rev. 12.6, and included in portage as 12.6_beta_pre897, but is now gone from portage. It is only compatible with Xorg <1.13, so 1) I need to downgrade to 1.12 and 2), I need to get an ebuild for 12.6_beta_pre897 or install it manually.

I have no use for any other version of Catalyst, because the r600-series is not supported by any catalyst >12.6 (legacy). The FOSS radeon driver is fine for most things, but has not full 3D support.
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby anomaly65 » Sun Mar 24, 2013 18:16

AMD reversed their earlier decision to "abandon" the 2xxx products (among others) as of the 13.1 drivers, which are in the current repositories. You might give them a try. That's also why the 12.6 legacy drivers were removed (as no longer needed).

[url]
http://support.amd.com/us/gpudownload/l ... linux.aspx
[/url]

To get those working easily, I wrote a quick and dirty how to, which may be of help.

[url]
viewtopic.php?f=56&t=28808
[/url]

Hope that helps.
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby ElDuderino » Sun Mar 24, 2013 21:47

Wow, that's great news, who would have thought that, after all... I will give it a try as soon as I have access to that laptop again.

Doesn't this news render Sabayons latest repo notice (partly) obsolete?

"As it always happens, proprietary video drivers fall short.
This time it's because we are, after one year, upgrading
X.Org to version 1.13. This means that some legacy drivers
have been removed:
- AMD Catalyst 12.6_beta_pre897
- NVIDIA legacy 96.xx
They don't work with the new X.Org, so either you are on your
own or have to switch to open source drivers.
Sorry, it's not our fault."

It presents the situation as though if there was only the FOSS driver available now.

Well, many thanks for your help, again, it's great news, because I like to play some games once in a while, and while I still would like the FOSS driver to be on par with Catalyst in every way, I also want to be able to use my video card to its full potential while waiting for that.

Cheers,
The Dude
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby ElDuderino » Sun Mar 24, 2013 21:53

Hm, I fully read the link to AMD, and at the bottom, it says the following about the 13.1 driver (which indeed includes support for HD2xxx): "Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4."

So, it's being updated again, but still not compatible with newest Xorg and Kernel? Even the "legacy" 12.6 driver could be used with kernel 3.7 and maybe even 3.8 (I don't remember).

Having an ATI card on linux seems to be an emotional rollercoaster...
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby anomaly65 » Mon Mar 25, 2013 0:08

well, one could always do an "equo install ati-drivers" (along with my quick-n-dirty help directions) and see if it works 8)

if it doesn't, "equo remove ati-drivers" and visit the master repo, snag the older blob and install it.

All of the ati-drivers get "tweaked" just a bit to match the current kernel/xorg combo. There's a lag time for either nvidia or ati drivers, but the differences are normally minor validation checks if anything. What's listed in the AMD page is what they performed full regression testing on. the kernel and xorg APIs don't usually suffer massive API changes in minor revisions that render the drivers completely incompatible. So far, that's been my 15+/- years of experience.

Of course, nvidia drove me away with the "blue people" in adobe flash, although simple to fix, friends drove me nuts every time they upgraded their systems :lol: , along with the 50% cut in power consumption on the 7xxx series of ati cards. Wasn't a difficult decision when Linux himself told "nvidia" they were number one, using his middle finger :wink:

I'd give it a try, there's not more than 20 minutes to lose in a good attempt :bom:

Cheers and good luck!
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby ElDuderino » Thu Apr 04, 2013 14:09

Hi,

I didn't get around yet to try ati-drivers 13.1, but it has been removed from entropy, there is only 13.3. now! (13.1 is still in portage, though.)

Why is that so?

Grettings
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby ElDuderino » Fri Apr 05, 2013 15:57

Sorry, it's me again. Since 13.1 is not in entropy anymore, I am trying to emerge. First, I tried =ati-drivers-13.1, but aticonfig --initial said "no adapters found", so I figured I have to use 13.1_pre897, which is slotted as "legacy". But this wants to downgrade Xorg to 1.12.4.

What am i doing wrong?
ElDuderino
Growing Hen
 
Posts: 122
Joined: Fri Jul 20, 2012 23:15

Re: Downgrade/Mask Xorg and use AMD Catalyst 12.6_beta_pre89

Postby anomaly65 » Sat Apr 06, 2013 20:17

ElDuderino,

yes, appears a few "gotchas" in the 13.1 drivers even to "emerge" them from portage. The ones from the ATI site aren't patched, but in portage/equo there are patches that do allow the newer X server and kernels to work. The stop on the legacy driver set since april 1 2013 seems to be a python issue which conflicts with rigo/entropy/equo among other things. I am hopeful those get sorted out soon.

Wish I had better news. But the weekly updates are due out tomorrow, who knows :)

Cheers,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Advanced Hen
 
Posts: 295
Joined: Sat Nov 17, 2007 15:37

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest