Printer driver for Canon Pixma IP1700 [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

remolek
Baby Hen
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Printer driver for Canon Pixma IP1700 [Solved]

Post by remolek » Tue Mar 19, 2013 23:51

Hello!
Today i tried to print on my Canon Pixma IP1700 but page was printed partially.
I have only libpng patch applied to net-print/cnijfilter-2.70-1.
I looked at https://bugs.gentoo.org/show_bug.cgi?id=130645 and http://git.sabayon.org/overlays/for-gen ... /net-print but i don't find drivers for my printer.
Drivers for ip1800 and ip2200 worked good in the past but now i don't know what patchs to apply and how. I use SL11 x86.
Can anybody help me resolve what patchs to apply and how make new ebuild for net-print/cnijfilter-2.70?
Last edited by remolek on Wed May 01, 2013 19:07, edited 1 time in total.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Printer driver for Canon Pixma IP1700

Post by Fitzcarraldo » Wed Mar 20, 2013 10:48

Did you upgrade recently? And did CUPS change from version 1.5.3 to 1.6.1 on your machine when you upgraded? The reason I ask is that there is a bug in CUPS 1.6.1 that affects some USB printers (like my Canon MP560, for example) and results in only part of a page being printed out. It is due to the new CUPS USB backend that was introduced in CUPS 1.5.4, and seems to affect quite a few Canon models, as well as some models of other printer manufacturers. I'm lucky in that my Canon printer supports both USB and WiFi connections, so my work-around is to print via WiFi instead of USB. See my post in the Gentoo Forums with more details, including a link to the CUPS Bugzilla bug report. Hopefully it will be fixed in CUPS 1.7.

tollgate
Growing Hen
Posts: 105
Joined: Thu May 31, 2012 3:57
Location: Jomtien, Thailand
Contact:

Re: Printer driver for Canon Pixma IP1700

Post by tollgate » Thu Mar 21, 2013 10:56

I have a Canon MX366. When I first installed it there was no linux driver that I could find. Then I came across TurboPrint who make Linux printer drivers - have to pay for them though. This worked very well. Then sometime later I installed Sabayon on a new computer and there was a Linux driver in CUPS. But I then had the print problems described above - partially printed pages - so I reinstalled the Turboprint driver and it's working again.

remolek
Baby Hen
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Re: Printer driver for Canon Pixma IP1700

Post by remolek » Sat Mar 23, 2013 16:41

Many thanks for reply!
Today i installed TurboPrint and my printer works good. But i don't understand why TurboPrint works with CUPS 1.6 if you talked about bug in CUPS 1.6.
Before installing TurboPrint i tryed to modify /etc/cups/printers.conf to add
Option usb-unidir true. And before adding this string printer was printed about 10 cm of page and after adding about 3/4 of page. I think that trouble is not in the CUPS but in configuring of the printer or in control command to CUPS or printer.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Printer driver for Canon Pixma IP1700

Post by Fitzcarraldo » Sat Mar 23, 2013 17:13

Did you read the CUPS bug reports (STR #4155, STR #4191, STR #4217)? Follow the link I gave earlier. The commercial TurboPrint driver probably does not use the new (since CUPS 1.5.4) CUPS Backend.

remolek
Baby Hen
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Re: Printer driver for Canon Pixma IP1700

Post by remolek » Sat Mar 23, 2013 18:50

Dear Fitzcarraldo!
Last request for USB backend quirk rule was in Jan 18, 2013.
How do I know whether the bug has been fixed for my printer in CUPS 1.7 ?
Do I need to request additional bug?

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Printer driver for Canon Pixma IP1700

Post by Fitzcarraldo » Sat Mar 23, 2013 19:06

If I were you, I'd file a bug report for your printer model in the CUPS Bugzilla. That's what I did for my printer (Canon MP560) and, as you can see from his comment at end of STR #4155, CUPS developer Till Kamppeter added a quirk for my model to the CUPS development source code repository, so hopefully my printer should work with USB again when CUPS 1.7 comes out.

remolek
Baby Hen
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Re: Printer driver for Canon Pixma IP1700

Post by remolek » Sat Mar 23, 2013 22:11

Thank you. I sent the request.

remolek
Baby Hen
Posts: 10
Joined: Tue Mar 19, 2013 22:04

Re: Printer driver for Canon Pixma IP1700

Post by remolek » Sun Mar 24, 2013 21:37

Today i received answer from http://www.cups.org STR #4303:
"Please try the 1.6.2 release - it contains many USB fixes for Linux."
But equo and emerge show only CUPS 1.6.1 and when i typed equo remove cups --pretend there are very many dependancies. I doubt I'll do it myself. I need a help.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8091
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Printer driver for Canon Pixma IP1700

Post by Fitzcarraldo » Mon Mar 25, 2013 6:07

An ebuild for CUPS 1.6.2 was placed in the Gentoo repositories by a Gentoo developer on Sun Mar 24 2013 at 21:59:55 UTC, so it will eventually be built by the SL Entropy package maintainer and a binary Entropy package will be placed in the Entropy repositories. You'll have to be patient.

Post Reply