Problem with Spanish keyboard [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Problem with Spanish keyboard [Solved]

Postby Tedel » Sun Mar 10, 2013 5:42

Hello,

I just installed Sabayon today, so well, nice to meet you. I have three small issues I need to solve. The first one will go in this thread:

I am from Peru so I use a Spanish (Spain layout) keyboard. In Spanish keyboards, regardless of the layout, you type two keys to write symbols with tilde á, é, í, ó, ú or diéresis ü, but on my keyboard KDE applications are not doing that but this... "´a" or "¨u". As you may understand solving this is crucial to more no less than be able to write properly in my computer :D so I need an urgent help (which preferably doesn't imply reformatting). It seems to be a locale problem, can you help me sort it out?

Note: on GTK applications (like Firefox) the keyboard layout works properly. Only on KDE applications (like K3B) show this problem. Hope this is a hint.

Thanks.
Last edited by Tedel on Mon Mar 11, 2013 5:42, edited 1 time in total.
Tedel
Simple Hen
 
Posts: 89
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Problem with Spanish keyboard

Postby Fitzcarraldo » Sun Mar 10, 2013 6:01

Have you specified to KDE that your keyboard is the Spanish language layout (Kickoff > System Settings > Input Devices > Keyboard | Layouts)? If you have specified multiple keyboard layouts, you can also specify on that tab a shortcut for switching layouts. Furthermore, you can specify in System Tray Settings whether or not the keyboard layout is displayed in the System Tray on the Panel, and whether the language is represented by a flag or by text.

Over and above the keyboard layout settings, to make sure your locale is set up correctly, see the post Re: Keyboard layout doesn't apply to the login screen as an example. If your locale is es_PE instead of es_ES then make the appropriate changes.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Problem with Spanish keyboard

Postby Tedel » Sun Mar 10, 2013 7:43

Hi.

Well, I could not choose my locale when installing, so they were en_US and en_US.UTF-8. I think this is pretty standard in GNU+Linux systems.

I tried to generate the locale following the link you mentioned but I got a "file not found error" for Spanish. My locales are now en_GB and en_GB.UTF-8 and en_US and en_US.UTF-8 now. Those compiled properly.

I changed the KDE system settings locale to Spain Spanish, but still it doesn't solve it. It just opens all the software menus in Spanish now :)

For the locale-gen script or command, I also got error messages. It seems the liveDVD did not install Spanish support despite the fact I clicked on "full language support" when installing. (I am wondering if that caused this situation now, and if I found my first bug :P.)

I also rebooted the computer from the LiveDVD I used to install Sabayon, I did not change the keyboard layout so that it could boot with a US keyboard layout. Once in, I used the flag icon to add the Spanish keyboard layout. It worked. QT applications and KDE itself displayed the tildes and dieresis correctly, even at the command window (alt+F2).

So I guess something went wrong with my installation. If there are no more options to try (or ideas), I will reformat the computer tomorrow as close as the liveDVD as possible and then add the language. It should work.

Ideally, I would like to have a en_GB locale with a full support of the Spanish keyword.
Tedel
Simple Hen
 
Posts: 89
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Problem with Spanish keyboard

Postby Fitzcarraldo » Sun Mar 10, 2013 9:10

Tedel wrote:Ideally, I would like to have a en_GB locale with a full support of the Spanish keyword.

That is what I have (well, to be precise I have Spanish and Portuguese). I have that configured in KDE on my main laptop (A guided tour of my KDE 4.8.4 desktop (Part 1)), but I also have it in Xfce on three other laptops (Selecting different keyboard layouts in Xfce). Watch out for setting up the locale at installation, because the SL Installer does not do it properly (see near the end of Evaluating Sabayon Linux Xfce for the fix, applicable whatever the DE).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Problem with Spanish keyboard

Postby Tedel » Sun Mar 10, 2013 15:57

Hi,

Well, I installed Sabayon from the liveDVD again, and here what happened:

1. the installation finished successfully
2. during the first boot I tried typing in the command line (alt+f2) and the tildes appeared normally
3. a few seconds after there was a bug report in the screen: "executable kwin PID 10192 Signal: Segmentation fault" and a second screen "kwin is unstable. it seems to have crashed several times in a row. you can select another window manager to run".
4. I logged out to prevent problems I don't know how to solve
5. I logged in again
6. the tilde problem reappeared

Suggestions?
Tedel
Simple Hen
 
Posts: 89
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Problem with Spanish keyboard

Postby Tedel » Sun Mar 10, 2013 19:42

Well, so far I could correctly configure the locale to en_GB. I am still having issues with the accents in some applications, though. Could the fact that my keyboard is PS2 and not USB be causing this?
Tedel
Simple Hen
 
Posts: 89
Joined: Sun Mar 10, 2013 5:32
Location: Peru

Re: Problem with Spanish keyboard

Postby Fitzcarraldo » Sun Mar 10, 2013 20:32

No, it's very unlikely. Try uninstalling IBus if it is installed, as I recall it causing some problems to KDE users (not only in SL) using certain keyboard layouts (see e.g. Dead keys not working in several applications [Solved] and kde aplications without accents [Solved]).

As I mentioned in an earlier post, it is possible to set up keyboard shortcuts so that one can switch keyboard layouts quickly, and I have done this in my KDE and Xfce installations as I use several keyboard layouts with the laptops' keyboards and external USB keyboards. For example, I configured X Windows on my machine running Xfce to allow me to use Alt+Shift to toggle between 'English (UK)', 'Portuguese (Brazil)' and 'Spanish (Spain)' keyboard layouts. I did that by creating the file /etc/X11/xorg.conf.d/20-keyboard.conf containing:

Code: Select all
Section "InputClass"
   Identifier "keyboard-all"
   Driver "evdev"
        Option "XkbModel"       "pc105"
   Option "XkbLayout"   "gb,br,es"
   Option "XkbOptions"   "grp:alt_shift_toggle"
   MatchIsKeyboard "on"
EndSection

KDE being more sophisticated than Xfce, I used the KDE GUI to configure my KDE installation to toggle between 'English (UK)', 'English (USA)', 'Portuguese (Brazil)' and 'Spanish (Spain)' keyboard layouts when I press Alt+Shift. Or I can toggle the layout by just clicking on the keyboard layout icon in the KDE System Tray. The reason I included the English (USA) keyboard layout is because in one office I use an external US English keyboard, not my laptop's UK English keyboard, so I can switch easily between layouts.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Problem with Spanish keyboard

Postby Tedel » Mon Mar 11, 2013 5:41

Hello,

Thank you for following up. At the end I found this forum post...

http://foro.el-hacker.com/f18/sabayon-p ... -a-302547/

...which states that the problem is in the .xprofile file. If you rename the file to anything else, the problem is gone instantly.

This is the content of the file. Something in it may be incorrect...

Code: Select all
# IME and non-roman fonts support
# see Sabayon bug #2518
if [ -x "/usr/bin/ibus-setup" ]; then
   export GTK_IM_MODULE=ibus
   export [email protected]=ibus
   export QT_IM_MODULE=xim
fi


...but renaming the file have the system ignore the instructions and works.
Tedel
Simple Hen
 
Posts: 89
Joined: Sun Mar 10, 2013 5:32
Location: Peru


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron