Unable to choose display port in Sound Settings [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Unable to choose display port in Sound Settings [Solved]

Postby Antidieu » Thu Feb 21, 2013 7:27

I recently tested live Sabayon 11G on a Gateway M-6804m laptop and realized I cannot set Profile to Digital Stereo (HDMI) Output in Sound Settings as there is no option to choose from except for Analog Stereo Output.

In Gnome 3.4, I was able to choose HDMI device for sound output by setting the hardware profile, so I'm pretty sure it used to work. Is this some kind of bug on Gnome's side? Is it kernel's fault? Or am I missing something here? This is my soundcard:

Code: Select all
Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

I really like Gnome 3.6 but this is holding me back from installing S11 to my computer. I need a workaround soon, any help would be appreciated.
Last edited by Antidieu on Sat Feb 23, 2013 0:17, edited 1 time in total.
Gateway M-6804m (2 GiB RAM)
Intel Core 2 Duo T5250
Intel GM965/GL960
Antidieu
Simple Hen
 
Posts: 68
Joined: Fri Apr 24, 2009 5:45

Re: Unable to choose display port in Sound Settings

Postby Antidieu » Sat Feb 23, 2013 0:15

Nevermind, I found out the only way to choose the hardware profile is through PulseAudio Volume Control. The new Sound Settings GUI in Gnome 3.6 is really poor, no correct handling of profile and no multichannel support. Having to set audio with two different GUIs is annoying.
Gateway M-6804m (2 GiB RAM)
Intel Core 2 Duo T5250
Intel GM965/GL960
Antidieu
Simple Hen
 
Posts: 68
Joined: Fri Apr 24, 2009 5:45


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests