step-by-step solution for most users with ATI cards [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: step-by-step solution for most users with ATI cards [Sol

Postby bjoernX » Tue Apr 16, 2013 22:04

Thanks. Re-installing fixed the black window for me too (after switching from integrated gpu).

But there were artifacts in kde with compositing enabled, weired visual glitches around menu-popups in gtk-based apps ... anyone seen these?

Image
http://www.pic-upload.de/view-18979071/ ... T.png.html

Second problem: suspend (to ram) does not wake up. With fglrx the pc was hung completely - even cpu cooler did not spin up again.

I dropped to gallium radeon drivers for now, but same here: suspend won't wake up (but the cpu cooler spins up, at least ...). No network too, so no way to shut down nicely via ssh.

GPU is a Radeon 6850, chipset is Intel z68 (Gigabyte z68x-ud3h-b3, Bios F12).

With the integrated intel gpu everything worked smoothly ... :-/
bjoernX
Baby Hen
 
Posts: 9
Joined: Sat Feb 18, 2012 22:38

Re: step-by-step solution for most users with ATI cards [Sol

Postby anomaly65 » Tue Apr 16, 2013 22:24

Might take a look at the "video tearing" options in amdcccle. Worth a try at least.

Have noticed problems enlarging or fullscreen video if browser (e.g. chromium) has pages with video even if said video is not being played.
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37

Re: step-by-step solution for most users with ATI cards [Sol

Postby bjoernX » Fri Apr 26, 2013 15:39

Happy fix on the suspend/thaw issue:

I installed a new Bios (UEFI) for my mobo yesterday and *surprise* -- suspend/hibernate and resume work like a charm now, both with gallium or fglrx (version 13.1 running). :)

GA-Z68X-UD3H-B3 - Bios was F12 (Award), now U1L (UEFI Beta-Bios from AMI)
http://www.gigabyte.de/products/product ... =3853#bios

This update was not recommended in a support-forum I visited - Bios is beta and can bring on many problems, they say. A (Dos)Tool to revert to the old Bios is published there, if anything goes terribly wrong: http://forum.gigabyte.de/index.php?page ... eadID=6420

I can not reproduce on the glitches because my Sabayon became unbootable in the process ... and I switched to a different distro for now (the BIG EVIL U***** - spank me! :D). I shall report how things look, when I'll have a kwin running next time.

So this solution was very specific to my hardware, but maybe it will help others too. Crappy ACPI implementations in mobo-bioses are quite common. Updates are welcome then.
bjoernX
Baby Hen
 
Posts: 9
Joined: Sat Feb 18, 2012 22:38

Re: step-by-step solution for most users with ATI cards [Sol

Postby geeksoldier » Sat Apr 27, 2013 4:58

Great step by step! However, when I try to run
Code: Select all
equo install =sys-kernel/linux-sabayon-3.8.3

it tells me that there are no packages found. Just running
Code: Select all
equo install syskernel/linux-sabayon -p

presents me with 3.8.5. I run an AMD HD4870. Any clues, or did I mess this up somehow?
geeksoldier
Baby Hen
 
Posts: 13
Joined: Thu Nov 22, 2012 20:37

Re: step-by-step solution for most users with ATI cards [Sol

Postby anomaly65 » Sun Apr 28, 2013 7:11

Hi geeksoldier. Sorry, had not updated version numbers. They change as new packages are added :) Will do so now!

Generally, yes, you want the latest of both linux-sabayon (kernel) and ati-drivers (ATI's binary blob).

Cheers,
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37

Re: step-by-step solution for most users with ATI cards [Sol

Postby fkef » Sun Apr 28, 2013 21:24

I did a fresh install of Sabayon 11 a few days ago. After following this guide I managed to get the ATI drivers working correctly, but with one problem.

When I close the lid to the computer (a Sony Vaio) it does not suspend. The screen only gets turned off, but the computer is still on. Also the brightness control does not work. I have checked the settings in dconf and Gnome Tweak and they are set to suspend.

However if I choose Suspend when pressing ALT on the menu, the computer goes to suspend mode correctly.

Ati drivers 13.4 was released the other day and according to Softpedia it has support for Kernel 3.7 and 3.8. Usually how long time does it takes until an update like this gets pushed to the stable repo, and does anyone knows if the new drivers will eliminate all this problems with black screen on newer kernels?
fkef
Baby Hen
 
Posts: 7
Joined: Thu Apr 18, 2013 12:13

Re: step-by-step solution for most users with ATI cards [Sol

Postby anomaly65 » Tue Apr 30, 2013 17:49

I have had similar experiences with both desktop and laptops going into sleep mode poorly. Both nvidia and Ati. I think it is likely due to kernel changes and the minor patches needed to install either vendors' binary blob with a more recent kernel as the regression testing cycle needed is actually more work than a given/random kernel upgrade. The binary blobs both deal with multiple gpu architectures and SDKs and the chips themselves are far more complex than any CPU.

So far on my several systems it seems to work well roughly 1/3 of the upgrades.....and lately a lot of significant kernel updates. Maybe those are occurring faster or I'm just getting older ;-) a lot of work is taking place on being able to use more gpgpu functionality which diverts resources...

Might also check you Desktop environment settings for what happens at lid closing. Once in a while I get lucky and just an unset then reset fixes the problem. More often not :-(


Good luck!!
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37

Re: step-by-step solution for most users with ATI cards [Sol

Postby Sonnersen » Thu May 02, 2013 10:43

Hello,

My issue was with kernel 3.8 and the ati driver upgrade.
Following this step-by-step My notebook work fine, but 3d acceleration is not working:

Code: Select all
@localhost ~ $ glxgears
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13
[email protected] ~ $ ^C


I can see the kernel module for kernel 3.8 is not loaded

Code: Select all
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Park [Mobility Radeon HD 5430/5450/5470] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device 033e
   Flags: bus master, fast devsel, latency 0, IRQ 11
   Memory at d0000000 (64-bit, prefetchable) [size=256M]
   Memory at cfee0000 (64-bit, non-prefetchable) [size=128K]
   I/O ports at 2000 [size=256]
   [virtual] Expansion ROM at cfe00000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>


The module is loaded using kernel 3.7

Code: Select all
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Park [Mobility Radeon HD 5430/5450/5470] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device 033e
   Flags: bus master, fast devsel, latency 0, IRQ 45
   Memory at d0000000 (64-bit, prefetchable) [size=256M]
   Memory at cfee0000 (64-bit, non-prefetchable) [size=128K]
   I/O ports at 2000 [size=256]
   [virtual] Expansion ROM at cfe00000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
   Kernel driver in use: fglrx_pci


How can I fix?

Thank you ;)
Sonnersen
Baby Hen
 
Posts: 19
Joined: Wed Oct 24, 2012 9:03

Re: step-by-step solution for most users with ATI cards [Sol

Postby anomaly65 » Thu May 02, 2013 14:10

Hi Sonnersen,

Looks like you've still got ati-drivers for 3.7 loaded by default. Here's how to correct that, hopefully :)

This sequence of commands sets your default kernel to the 3.8.8 you have installed, removes current "3.7" compatible ati-drivers, installs the correct version, and sets various parameters (opengl, opencl) to utilize ati's 3d acceleration.

Code: Select all
eselect bzimage set kernel-genkernel-x86_64-3.8.0-sabayon
eselect kernel set linux-3.8.0-sabayon
equo remove  xf86-video-ati
equo remove --configfiles xf86-video-ati
equo remove ati-drivers
equo install x11-drivers/ati-drivers-13.3_beta2#3.8.8-sabayon amdcccle
eselect opencl set amd
eselect opengl set ati


Hope that helps.
andy
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 302
Joined: Sat Nov 17, 2007 15:37

Re: step-by-step solution for most users with ATI cards [Sol

Postby Sonnersen » Thu May 02, 2013 15:14

Hi, thank you.

I tried the sequence, but it didn't worked.

This is my output:

Code: Select all
[email protected] ~ $ su
Password:
localhost skywalker # eselect bzimage set kernel-genkernel-x86_64-3.8.0-sabayon
Setting bzImage to kernel-genkernel-x86_64-3.8.0-sabayon
Setting Initrd to initramfs-genkernel-x86_64-3.8.0-sabayon
localhost skywalker # eselect kernel set linux-3.8.0-sabayon
localhost skywalker # equo remove  xf86-video-ati
>> !!!
>> !!! Attenzione: xf86-video-ati non è installato.
>> !!!
>>    ? Quando hai scritto xf86-video-ati Intendevi(tm) uno di questi sotto?
>>     # x11-drivers/xf86-video-apm
>>     # x11-drivers/xf86-video-ark
>>     # x11-drivers/xf86-video-ast
>>     # x11-drivers/xf86-video-cirrus
>>     # x11-drivers/xf86-video-dummy
>>     # x11-drivers/xf86-video-fbdev
>>     # x11-drivers/xf86-video-glint
>>     # x11-drivers/xf86-video-i128
>>     # x11-drivers/xf86-video-i740
>>     # x11-drivers/xf86-video-intel
>>     # x11-drivers/xf86-video-mach64
>>     # x11-drivers/xf86-video-mga
>>     # x11-drivers/xf86-video-neomagic
>>     # x11-drivers/xf86-video-nouveau
>>     # x11-drivers/xf86-video-nv
>>     # x11-drivers/xf86-video-openchrome
>>     # x11-drivers/xf86-video-qxl
>>     # x11-drivers/xf86-video-r128
>>     # x11-drivers/xf86-video-s3
>>     # x11-drivers/xf86-video-s3virge
>>     # x11-drivers/xf86-video-savage
>>     # x11-drivers/xf86-video-siliconmotion
>>     # x11-drivers/xf86-video-sis
>>     # x11-drivers/xf86-video-sisusb
>>     # x11-drivers/xf86-video-tdfx
>>     # x11-drivers/xf86-video-tga
>>     # x11-drivers/xf86-video-trident
>>     # x11-drivers/xf86-video-v4l
>>     # x11-drivers/xf86-video-vesa
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-vmware
>>     # x11-drivers/xf86-video-voodoo
>>     # x11-proto/xf86vidmodeproto
>>     # x11-libs/xvba-video
>> !!!
>> Nessun pacchetto trovato
localhost skywalker # equo remove  xf86-video-ati
>>  @@ Risorse sbloccate, andiamo!
>> !!!
>> !!! Attenzione: xf86-video-ati non è installato.
>> !!!
>>    ? Quando hai scritto xf86-video-ati Intendevi(tm) uno di questi sotto?
>>     # x11-drivers/xf86-video-apm
>>     # x11-drivers/xf86-video-ark
>>     # x11-drivers/xf86-video-ast
>>     # x11-drivers/xf86-video-cirrus
>>     # x11-drivers/xf86-video-dummy
>>     # x11-drivers/xf86-video-fbdev
>>     # x11-drivers/xf86-video-glint
>>     # x11-drivers/xf86-video-i128
>>     # x11-drivers/xf86-video-i740
>>     # x11-drivers/xf86-video-intel
>>     # x11-drivers/xf86-video-mach64
>>     # x11-drivers/xf86-video-mga
>>     # x11-drivers/xf86-video-neomagic
>>     # x11-drivers/xf86-video-nouveau
>>     # x11-drivers/xf86-video-nv
>>     # x11-drivers/xf86-video-openchrome
>>     # x11-drivers/xf86-video-qxl
>>     # x11-drivers/xf86-video-r128
>>     # x11-drivers/xf86-video-s3
>>     # x11-drivers/xf86-video-s3virge
>>     # x11-drivers/xf86-video-savage
>>     # x11-drivers/xf86-video-siliconmotion
>>     # x11-drivers/xf86-video-sis
>>     # x11-drivers/xf86-video-sisusb
>>     # x11-drivers/xf86-video-tdfx
>>     # x11-drivers/xf86-video-tga
>>     # x11-drivers/xf86-video-trident
>>     # x11-drivers/xf86-video-v4l
>>     # x11-drivers/xf86-video-vesa
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-vmware
>>     # x11-drivers/xf86-video-voodoo
>>     # x11-proto/xf86vidmodeproto
>>     # x11-libs/xvba-video
>> !!!
>> Nessun pacchetto trovato
localhost skywalker # equo remove --configfiles xf86-video-ati
>> !!!
>> !!! Attenzione: xf86-video-ati non è installato.
>> !!!
>>    ? Quando hai scritto xf86-video-ati Intendevi(tm) uno di questi sotto?
>>     # x11-drivers/xf86-video-apm
>>     # x11-drivers/xf86-video-ark
>>     # x11-drivers/xf86-video-ast
>>     # x11-drivers/xf86-video-cirrus
>>     # x11-drivers/xf86-video-dummy
>>     # x11-drivers/xf86-video-fbdev
>>     # x11-drivers/xf86-video-glint
>>     # x11-drivers/xf86-video-i128
>>     # x11-drivers/xf86-video-i740
>>     # x11-drivers/xf86-video-intel
>>     # x11-drivers/xf86-video-mach64
>>     # x11-drivers/xf86-video-mga
>>     # x11-drivers/xf86-video-neomagic
>>     # x11-drivers/xf86-video-nouveau
>>     # x11-drivers/xf86-video-nv
>>     # x11-drivers/xf86-video-openchrome
>>     # x11-drivers/xf86-video-qxl
>>     # x11-drivers/xf86-video-r128
>>     # x11-drivers/xf86-video-s3
>>     # x11-drivers/xf86-video-s3virge
>>     # x11-drivers/xf86-video-savage
>>     # x11-drivers/xf86-video-siliconmotion
>>     # x11-drivers/xf86-video-sis
>>     # x11-drivers/xf86-video-sisusb
>>     # x11-drivers/xf86-video-tdfx
>>     # x11-drivers/xf86-video-tga
>>     # x11-drivers/xf86-video-trident
>>     # x11-drivers/xf86-video-v4l
>>     # x11-drivers/xf86-video-vesa
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-vmware
>>     # x11-drivers/xf86-video-voodoo
>>     # x11-proto/xf86vidmodeproto
>>     # x11-libs/xvba-video
>> !!!
>> Nessun pacchetto trovato
localhost skywalker # equo remove --configfiles xf86-video-ati
>> !!!
>> !!! Attenzione: xf86-video-ati non è installato.
>> !!!
>>    ? Quando hai scritto xf86-video-ati Intendevi(tm) uno di questi sotto?
>>     # x11-drivers/xf86-video-apm
>>     # x11-drivers/xf86-video-ark
>>     # x11-drivers/xf86-video-ast
>>     # x11-drivers/xf86-video-cirrus
>>     # x11-drivers/xf86-video-dummy
>>     # x11-drivers/xf86-video-fbdev
>>     # x11-drivers/xf86-video-glint
>>     # x11-drivers/xf86-video-i128
>>     # x11-drivers/xf86-video-i740
>>     # x11-drivers/xf86-video-intel
>>     # x11-drivers/xf86-video-mach64
>>     # x11-drivers/xf86-video-mga
>>     # x11-drivers/xf86-video-neomagic
>>     # x11-drivers/xf86-video-nouveau
>>     # x11-drivers/xf86-video-nv
>>     # x11-drivers/xf86-video-openchrome
>>     # x11-drivers/xf86-video-qxl
>>     # x11-drivers/xf86-video-r128
>>     # x11-drivers/xf86-video-s3
>>     # x11-drivers/xf86-video-s3virge
>>     # x11-drivers/xf86-video-savage
>>     # x11-drivers/xf86-video-siliconmotion
>>     # x11-drivers/xf86-video-sis
>>     # x11-drivers/xf86-video-sisusb
>>     # x11-drivers/xf86-video-tdfx
>>     # x11-drivers/xf86-video-tga
>>     # x11-drivers/xf86-video-trident
>>     # x11-drivers/xf86-video-v4l
>>     # x11-drivers/xf86-video-vesa
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-vmware
>>     # x11-drivers/xf86-video-voodoo
>>     # x11-proto/xf86vidmodeproto
>>     # x11-libs/xvba-video
>> !!!
>> Nessun pacchetto trovato
localhost skywalker # equo remove ati-drivers
>>  @@ Risorse sbloccate, andiamo!
>>  @@ Questi sono i pacchetti scelti:
>>    #  (1/1) [sabayon-weekly] x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon  [6.6MB]
>> / Calcolo delle dipendenze inverse per x11-drivers/ati-drivers-13.3_beta2#3.7>>  @@ Questi sono i pacchetti che vorrebbero essere rimossi:
>>  ## [sabayon-weekly] x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon [6.6MB]
>>  @@ Pacchetti che verrebbero rimossi: 1
>>  @@ Spazio su disco liberato: 6.6MB
>>  @@ Banda totale sprecata: 2.1MB
>>  --- >>>  (1/1) x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon
>>    ## Rimozione dati: x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon
>>    ## Rimozione da Entropy: x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon
>>> Regenerating /etc/ld.so.cache...
>>    ## Package phase: postremove
>>  @@ Tutto fatto.
>>  @@ Nessun file di configurazione da aggiornare.
localhost skywalker # equo install x11-drivers/ati-drivers-13.3_beta2#3.8.8-sabayon amdcccle
>>  !!! Nessun accoppiamento per x11-drivers/ati-drivers-13.3_beta2#3.8.8-sabayon nelle repository.
>>    ? Quando hai scritto x11-drivers/ati-drivers-13.3_beta2#3.8.8-sabayon Intendevi(tm) uno di questi sotto?
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-drivers
>>     # x11-drivers/ati-userspace
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-drivers
>>     # x11-drivers/nvidia-userspace
>>     # x11-drivers/xf86-input-acecad
>>     # x11-drivers/xf86-input-aiptek
>>     # x11-drivers/xf86-input-evdev
>>     # x11-drivers/xf86-input-joystick
>>     # x11-drivers/xf86-input-mtrack
>>     # x11-drivers/xf86-input-mutouch
>>     # x11-drivers/xf86-input-synaptics
>>     # x11-drivers/xf86-input-vmmouse
>>     # x11-drivers/xf86-input-void
>>     # x11-drivers/xf86-input-wacom
>>     # x11-drivers/xf86-video-apm
>>     # x11-drivers/xf86-video-ark
>>     # x11-drivers/xf86-video-ast
>>     # x11-drivers/xf86-video-ati
>>     # x11-drivers/xf86-video-cirrus
>>     # x11-drivers/xf86-video-dummy
>>     # x11-drivers/xf86-video-fbdev
>>     # x11-drivers/xf86-video-glint
>>     # x11-drivers/xf86-video-i128
>>     # x11-drivers/xf86-video-i740
>>     # x11-drivers/xf86-video-intel
>>     # x11-drivers/xf86-video-mach64
>>     # x11-drivers/xf86-video-mga
>>     # x11-drivers/xf86-video-modesetting
>>     # x11-drivers/xf86-video-nouveau
>>     # x11-drivers/xf86-video-nv
>>     # x11-drivers/xf86-video-openchrome
>>     # x11-drivers/xf86-video-qxl
>>     # x11-drivers/xf86-video-r128
>>     # x11-drivers/xf86-video-s3
>>     # x11-drivers/xf86-video-s3virge
>>     # x11-drivers/xf86-video-savage
>>     # x11-drivers/xf86-video-siliconmotion
>>     # x11-drivers/xf86-video-sis
>>     # x11-drivers/xf86-video-sisusb
>>     # x11-drivers/xf86-video-tdfx
>>     # x11-drivers/xf86-video-tga
>>     # x11-drivers/xf86-video-trident
>>     # x11-drivers/xf86-video-v4l
>>     # x11-drivers/xf86-video-vesa
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-virtualbox
>>     # x11-drivers/xf86-video-vmware
>>     # x11-drivers/xf86-video-voodoo
>>  @@ calcolo delle dipendenze...
>>  ## [R] [sabayon-weekly] media-video/amdcccle-13.3_beta2|0   [13.3_beta2|0]
>>  @@ Pacchetti che richiedono di essere installati/aggiornati/retrocessi: 1
>>  @@ Pacchetti da rimuovere: 0
>>  @@ Dimensione download: 0b
>>  @@ Spazio su disco liberato: 0.0b
>>  @@ Hai bisogno di almeno: 10.1MB di spazio libero
>>  ::: >>>  (1/1) 1 pacchetto
>>    ## Firma pacchetto combaciante: media-video:amdcccle-13.3_beta2.f62abfdb2d70e69aaca48d7ee8c930fa55dad7fd~0.tbz2
>>  +++ >>>  (1/1) media-video/amdcccle-13.3_beta2
>>    ## Scompattamento: media-video:amdcccle-13.3_beta2.f62abfdb2d70e69aaca48d7ee8c930fa55dad7fd~0.tbz2
>>    ## Installazione pacchetto: media-video/amdcccle-13.3_beta2
>>    ## [AMD Catalyst Control Center Linux Edition]
>>    ## Aggiornamento database: media-video/amdcccle-13.3_beta2
>>    ## Pulizia dei dati dell'applicazione precedente.
>>    ## Pulizia: media-video/amdcccle-13.3_beta2
>>  @@ Installazione completata.
>>  @@ Nessun file di configurazione da aggiornare.
localhost skywalker # eselect opencl set amd
Switching to amd OpenCL interface... done
localhost skywalker # eselect opengl set ati
Switching to ati OpenGL interface... done
localhost skywalker #


xf86-video-ati is not installed and entropy can't find this package:
x11-drivers/ati-drivers-13.3_beta2#3.8.8-sabayon nelle repository

So:
Code: Select all
[email protected] ~ $ equo search x11-drivers/ati-drivers
>>  @@ Cercando...
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.2.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.2.0-sabayon ~ revisione: 0
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          1,3.2.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.3.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.3.0-sabayon ~ revisione: 0
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          1,3.3.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.4.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.4.0-sabayon ~ revisione: 0
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          1,3.4.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.5.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.5.0-sabayon ~ revisione: 0
>>         Installato:    versione: 13.3_beta2 ~ tag: 3.5.0-sabayon ~ revisione: 0
>>         Slot:          1,3.5.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.6.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.6.0-sabayon ~ revisione: 0
>>         Installato:    versione: 13.3_beta2 ~ tag: 3.6.0-sabayon ~ revisione: 0
>>         Slot:          1,3.6.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.7.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.7.0-sabayon ~ revisione: 1
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          1,3.7.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>      @@ Pacchetto: x11-drivers/ati-drivers-13.3_beta2#3.8.0-sabayon branch: 5, [sabayon-weekly]
>>         Disponibile:   versione: 13.3_beta2 ~ tag: 3.8.0-sabayon ~ revisione: 2
>>         Installato:    versione: Non installato ~ tag: N/A ~ revisione: N/A
>>         Slot:          1,3.8.0-sabayon
>>         Homepage:      http://www.amd.com
>>         Descrizione:   Ati precompiled drivers for Radeon
>>                        Evergreen (HD5000 Series) and
>>                        newer chipsets
>>         Licenza:       AMD GPL-2 QPL-1.0
>>  Keyword:  x11-drivers/ati-drivers
>>  Trovati:  7 voci
[email protected] ~ $


Look like I can't just intall the package: x11-drivers/ati-drivers-13.3_beta2#3.8.0-sabayon branch

Should I try the above sequence with drivers-13.3.beta2#3.8.0 instead off 3.8.8?

Thank you again
Sonnersen
Baby Hen
 
Posts: 19
Joined: Wed Oct 24, 2012 9:03

PreviousNext

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest