Nvidia 6150se now "unsupported"

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
flytheflag
Baby Hen
Posts: 3
Joined: Thu Dec 27, 2012 3:04

Nvidia 6150se now "unsupported"

Post by flytheflag » Thu Dec 27, 2012 3:16

Hello. Came across a problem involving the latest Nvidia 310 binary blob driver.

With a recent update (must been a few weeks ago now), after upgrading software and rebooting i couldn't get X to load... dmesg stated something along the lines of "Nvidia 6150se is no longer supported". It appears Nvidia has classed my integrated card as unsupported in their latest driver.

I haven't updated anything for the past 2 weeks because of the Nvidia driver problem, I can stay on the 304 branch and my computer is still able to work.

The problem is, that when i remove the related sabayon packages (nvidia, 310 version) and after reinstalling the 304 version through the package manager... it keeps trying to update to 310.

How to fix this?

nachoig
Simple Hen
Posts: 68
Joined: Thu Oct 04, 2012 20:19

Re: Nvidia 6150se now "unsupported"

Post by nachoig » Thu Dec 27, 2012 4:26

Try this before updating:

Code: Select all

equo mask nvidia-userspace-304.64 nvidia-drivers-304.64

flytheflag
Baby Hen
Posts: 3
Joined: Thu Dec 27, 2012 3:04

Re: Nvidia 6150se now "unsupported"

Post by flytheflag » Thu Dec 27, 2012 8:38

Thanks.
One question about that...

What exactly will happen when (for example) 304.70 is released? Would i have to re-mask the newer version of the 304.x driver in future?


EDIT:
Also i'm not sure if your suggestion is working, when i upgrade it shows:

Code: Select all

...
>>  ## [U] [sabayon-weekly] x11-drivers/nvidia-userspace-310.19|0   [304.64|1]
>>  ## [U] [sabayon-weekly] x11-drivers/nvidia-drivers-310.19#3.6.0-sabayon|0   [304.64|0]
...


Also tried "equo update --force sync" beforehand.

:|

svantoviit
Old Dear Hen
Posts: 716
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: Nvidia 6150se now "unsupported"

Post by svantoviit » Thu Dec 27, 2012 10:17

Of course nachoig's suggestion did not work, because you have masked the packages you want to keep.
You need to mask everything higher than 304.64 or 310 and higher, if you want to get updates for 304.

Edit the /etc/entropy/packages/package.mask file.

Add these lines:

Code: Select all

>x11-drivers/nvidia-drivers-304.64
>x11-drivers/nvidia-userspace-304.64

or

Code: Select all

>=x11-drivers/nvidia-drivers-310.19
>=x11-drivers/nvidia-userspace-310.19

That should work.

Another option would be probably to move to the open driver x11-drivers/xf86-video-nouveau.

flytheflag
Baby Hen
Posts: 3
Joined: Thu Dec 27, 2012 3:04

Re: Nvidia 6150se now "unsupported"

Post by flytheflag » Thu Dec 27, 2012 12:17

Thankyou both, that works.

I would have moved to the nouveau driver a long time ago, but unfortunately it is terrible for anything graphical. Even small games like assaultcube will not achieve a framerate higher than 1fps with it.

I guess this is solved, thanks.

svantoviit
Old Dear Hen
Posts: 716
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: Nvidia 6150se now "unsupported"

Post by svantoviit » Sat Dec 29, 2012 0:44

flytheflag wrote:I guess this is solved, thanks.

You are welcome.

Consider to mark the topic as [Solved].

Post Reply