Page 2 of 2

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Sun Jan 20, 2013 12:52
by DanySK
afaik you may also need to add "nomodeset" to your boot line in order to enable 3d acceleration.

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Sun Jan 20, 2013 13:08
by amandus
And install the ati driver for the kernel 3.7?

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Sun Jan 20, 2013 14:09
by amandus
Thank you very much I finely got it to work with kernel 3.7 and ATI driver:-)

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Sun Jan 20, 2013 14:19
by DanySK
amandus wrote:And install the ati driver for the kernel 3.7?
well of course!

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Sun Jan 20, 2013 19:01
by anomaly65
amandus,

read a few posts up in this thread, and apply the "nomodeset" in the grub configuration, then

Code: Select all

grub-mkconfig -o /boot/grub/grub.cfg


that's the other key as I recall.

good luck!
andy

Re: ati 7750 works w/ 3.5 & ati-drivers, not 3.6/3.7 [Solved

Posted: Fri Jan 25, 2013 3:19
by DanAlucard
What I did:

Code: Select all

equo remove xf86-video-ati
equo remove x11-drivers/ati-drivers-12.10#3.7.0-sabayon
equo install sys-kernel/sabayon-sources-3.7-r3
equo install x11-drivers/ati-drivers-12.10#3.7.0-sabayon
reboot and done :D

no need to add nomodeset to grub or do something else. Removal of xf86-video-ati may be unnecessary but is the first thing I did :mrgreen: