Cannot start X window after update

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Cannot start X window after update

Postby liyuyao001 » Wed Dec 05, 2012 16:23

I was using sabayon 9 before, and after i clicked the "update all", the system updated to Sabayon X, with a linux kernel of version 3.3.
But, after reboot, i cannot start X window,no matter which kernel i choose to boot, i can log in using command line, but X server seems to be down.
My laptop uses a Intel i3 gen2 CPU, i saw there is a problem with Radeon HD 4000 series, so i tried to remove the boot parameter "vga=791 ", but problem remains.
i dont know much about linux, so please anyone help me.
i got the /var/log/Xorg.o.log file, and its content is as follows:

Code: Select all
[    47.496]
X.Org X Server 1.12.4
Release Date: 2012-08-27
[    47.496] X Protocol Version 11, Revision 0
[    47.496] Build Operating System: Linux 3.2.0-server i686 Gentoo
[    47.496] Current Operating System: Linux sabayon 3.3.0-sabayon #1 SMP Thu May 24 14:57:56 UTC 2012 i686
[    47.496] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86-3.3.0-sabayon ro init=/linuxrc splash=silent,theme:sabayon console=tty1 quiet dokeymap keymap=us domdadm resume=swap:UUID=f6720ed0-35f2-4eea-b72e-446607ff28fc real_resume=UUID=f6720ed0-35f2-4eea-b72e-446607ff28fc root=UUID=996d950e-8d53-443b-b6d9-0575264cce24 docrypt
[    47.496] Build Date: 08 September 2012  02:42:30PM
[    47.496] 
[    47.496] Current version of pixman: 0.27.2
[    47.496]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    47.496] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    47.496] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec  5 22:35:10 2012
[    47.496] (==) Using config file: "/etc/X11/xorg.conf"
[    47.496] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    47.496] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    47.497] (==) ServerLayout "Main Layout"
[    47.497] (**) |-->Screen "Screen 0" (0)
[    47.497] (**) |   |-->Monitor "Generic Monitor"
[    47.497] (**) |   |-->Device "SabayonVga0"
[    47.497] (**) |-->Screen "Screen 1" (1)
[    47.497] (**) |   |-->Monitor "Generic Monitor"
[    47.497] (**) |   |-->Device "SabayonVga1"
[    47.497] (**) Option "AllowMouseOpenFail" "true"
[    47.497] (==) Automatically adding devices
[    47.497] (==) Automatically enabling devices
[    47.497] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    47.497]    Entry deleted from font path.
[    47.497] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    47.497]    Entry deleted from font path.
[    47.497] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    47.497]    Entry deleted from font path.
[    47.497] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    47.497]    Entry deleted from font path.
[    47.497]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    47.497] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    47.497]    Entry deleted from font path.
[    47.497]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    47.497] (==) FontPath set to:
   /usr/share/fonts/misc/
[    47.497] (==) ModulePath set to "/usr/lib/xorg/modules"
[    47.497] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    47.497] (II) Loader magic: 0x822e580
[    47.497] (II) Module ABI versions:
[    47.497]    X.Org ANSI C Emulation: 0.4
[    47.497]    X.Org Video Driver: 12.1
[    47.497]    X.Org XInput driver : 16.0
[    47.497]    X.Org Server Extension : 6.0
[    47.498] (--) PCI:*(0:0:2:0) 8086:0116:17aa:21e3 rev 9, Mem @ 0xe0000000/4194304, 0xd0000000/268435456, I/O @ 0x00007000/64
[    47.499] (--) PCI: (0:1:0:0) 1002:6760:17aa:21e3 rev 0, Mem @ 0xc0000000/268435456, 0xe2600000/131072, I/O @ 0x00006000/256, BIOS @ 0x????????/131072
[    47.499] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    47.499] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[    47.499] (II) "dbe" will be loaded by default.
[    47.499] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    47.499] (II) "record" will be loaded by default.
[    47.499] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[    47.499] (II) "dri2" will be loaded by default.
[    47.499] (II) LoadModule: "extmod"
[    47.499] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    47.499] (II) Module extmod: vendor="X.Org Foundation"
[    47.499]    compiled for 1.12.4, module version = 1.0.0
[    47.499]    Module class: X.Org Server Extension
[    47.499]    ABI class: X.Org Server Extension, version 6.0
[    47.499] (II) Loading extension MIT-SCREEN-SAVER
[    47.499] (II) Loading extension XFree86-VidModeExtension
[    47.499] (II) Loading extension DPMS
[    47.499] (II) Loading extension XVideo
[    47.499] (II) Loading extension XVideo-MotionCompensation
[    47.499] (II) Loading extension X-Resource
[    47.499] (II) LoadModule: "i2c"
[    47.499] (II) Module "i2c" already built-in
[    47.499] (II) LoadModule: "ddc"
[    47.499] (II) Module "ddc" already built-in
[    47.499] (II) LoadModule: "vbe"
[    47.499] (II) Loading /usr/lib/xorg/modules/libvbe.so
[    47.499] (II) Module vbe: vendor="X.Org Foundation"
[    47.499]    compiled for 1.12.4, module version = 1.1.0
[    47.499]    ABI class: X.Org Video Driver, version 12.1
[    47.499] (II) LoadModule: "dri"
[    47.500] (WW) Warning, couldn't open module dri
[    47.500] (II) UnloadModule: "dri"
[    47.500] (II) Unloading dri
[    47.500] (EE) Failed to load module "dri" (module does not exist, 0)
[    47.500] (II) LoadModule: "glx"
[    47.500] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    47.500] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    47.500]    compiled for 6.9.0, module version = 1.0.0
[    47.500] (II) Loading extension GLX
[    47.500] (II) LoadModule: "synaptics"
[    47.500] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    47.500] (II) Module synaptics: vendor="X.Org Foundation"
[    47.500]    compiled for 1.12.4, module version = 1.6.2
[    47.500]    Module class: X.Org XInput Driver
[    47.500]    ABI class: X.Org XInput driver, version 16.0
[    47.500] (II) LoadModule: "dbe"
[    47.501] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    47.501] (II) Module dbe: vendor="X.Org Foundation"
[    47.501]    compiled for 1.12.4, module version = 1.0.0
[    47.501]    Module class: X.Org Server Extension
[    47.501]    ABI class: X.Org Server Extension, version 6.0
[    47.501] (II) Loading extension DOUBLE-BUFFER
[    47.501] (II) LoadModule: "record"
[    47.501] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    47.501] (II) Module record: vendor="X.Org Foundation"
[    47.501]    compiled for 1.12.4, module version = 1.13.0
[    47.501]    Module class: X.Org Server Extension
[    47.501]    ABI class: X.Org Server Extension, version 6.0
[    47.501] (II) Loading extension RECORD
[    47.501] (II) LoadModule: "dri2"
[    47.501] (WW) Warning, couldn't open module dri2
[    47.501] (II) UnloadModule: "dri2"
[    47.501] (II) Unloading dri2
[    47.501] (EE) Failed to load module "dri2" (module does not exist, 0)
[    47.501] (II) LoadModule: "intel"
[    47.502] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    47.502] (II) Module intel: vendor="X.Org Foundation"
[    47.502]    compiled for 1.12.4, module version = 2.20.6
[    47.502]    Module class: X.Org Video Driver
[    47.502]    ABI class: X.Org Video Driver, version 12.1
[    47.502] (II) LoadModule: "fglrx"
[    47.502] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    47.515] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    47.515]    compiled for 1.4.99.906, module version = 9.0.2
[    47.515]    Module class: X.Org Video Driver
[    47.515] (II) Loading sub module "fglrxdrm"
[    47.515] (II) LoadModule: "fglrxdrm"
[    47.515] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    47.516] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    47.516]    compiled for 1.4.99.906, module version = 9.0.2
[    47.516] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
   Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
   Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
   Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
   Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
   Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
   Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
   Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
   Haswell Server (GT2+), Haswell SDV Desktop (GT1),
   Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
   Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
   Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
   Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
   Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
   Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
   Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
   Haswell ULT Server (GT1), Haswell ULT Server (GT2),
   Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
   Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
   Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
   Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
   Haswell CRW Server (GT2), Haswell CRW Server (GT2+)
[    47.517] (II) AMD Proprietary Linux Driver Version Identifier:9.00.2
[    47.517] (II) AMD Proprietary Linux Driver Release Identifier: 9.002                               
[    47.517] (II) AMD Proprietary Linux Driver Build Date: Sep 28 2012 15:32:32
[    47.517] (++) using VT number 7

[    47.523] (WW) Falling back to old probe method for fglrx
[    47.531] (II) intel(0): Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    47.533] ukiDynamicMajor: found major device number 242
[    47.533] ukiDynamicMajor: found major device number 242
[    47.533] ukiOpenByBusid: Searching for BusID PCI:01:00
[    47.533] ukiOpenDevice: node name is /dev/ati/card0
[    47.533] ukiOpenDevice: open result is 7, (OK)
[    47.533] ukiOpenByBusid: ukiOpenMinor returns 7
[    47.533] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    47.533] ukiOpenDevice: node name is /dev/ati/card1
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: Open failed
[    47.533] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.533] ukiOpenDevice: node name is /dev/ati/card2
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: Open failed
[    47.533] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.533] ukiOpenDevice: node name is /dev/ati/card3
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: open result is -1, (No such device)
[    47.533] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card4
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card5
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card6
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card7
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card8
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card9
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card10
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card11
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card12
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card13
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card14
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.534] ukiOpenDevice: node name is /dev/ati/card15
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: open result is -1, (No such device)
[    47.534] ukiOpenDevice: Open failed
[    47.534] ukiOpenByBusid: ukiOpenMinor returns -19
[    47.535] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[    47.535] (II) intel(0): fglrx: intel VGA device detected, load intel driver.
[    47.535] (II) LoadModule: "intel"
[    47.536] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    47.536] (II) Module intel: vendor="X.Org Foundation"
[    47.536]    compiled for 1.12.4, module version = 2.20.6
[    47.536]    Module class: X.Org Video Driver
[    47.536]    ABI class: X.Org Video Driver, version 12.1
[    47.536] (II) UnloadModule: "intel"
[    47.536] (II) Unloading intel
[    47.536] (II) Failed to load module "intel" (already loaded, 135039504)
[    47.536] (WW) intel(0): fglrx: Fail to load intel driver!
[    47.536] (II) intel(0): AMD Video driver is running on a device belonging to a group targeted for this release
[    47.536] (II) intel(0): AMD Video driver is signed
[    47.537] (II) intel(0): pEnt->device->identifier=0x94ac8e0
[    47.537] (**) intel(0): Depth 24, (--) framebuffer bpp 32
[    47.537] (==) intel(0): RGB weight 888
[    47.537] (==) intel(0): Default visual is TrueColor
[    47.537] (--) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT2)
[    47.537] (**) intel(0): Relaxed fencing enabled
[    47.537] (**) intel(0): Wait on SwapBuffers? enabled
[    47.537] (**) intel(0): Triple buffering? enabled
[    47.537] (**) intel(0): Framebuffer tiled
[    47.537] (**) intel(0): Pixmaps tiled
[    47.537] (**) intel(0): 3D buffers tiled
[    47.537] (**) intel(0): SwapBuffers wait enabled
[    47.537] (==) intel(0): video overlay key set to 0x101fe
[    47.537] (II) intel(0): Output LVDS1 using monitor section Generic Monitor
[    47.537] (EE) intel(0): unrecognised backlight control interface (null)
[    47.537] (--) intel(0): found backlight control interface /sys/class/backlight/acpi_video1
[    47.538] (II) intel(0): Output VGA1 has no monitor section
[    47.560] (II) intel(0): Output HDMI1 has no monitor section
[    47.573] (II) intel(0): Output DP1 has no monitor section
[    47.573] (II) intel(0): EDID for output LVDS1
[    47.573] (II) intel(0): Manufacturer: AUO  Model: 303c  Serial#: 0
[    47.573] (II) intel(0): Year: 2010  Week: 0
[    47.573] (II) intel(0): EDID Version: 1.3
[    47.573] (II) intel(0): Digital Display Input
[    47.573] (II) intel(0): Max Image Size [cm]: horiz.: 31  vert.: 17
[    47.573] (II) intel(0): Gamma: 2.20
[    47.573] (II) intel(0): No DPMS capabilities specified
[    47.573] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    47.573] (II) intel(0): First detailed timing is preferred mode
[    47.573] (II) intel(0): redX: 0.590 redY: 0.345   greenX: 0.340 greenY: 0.570
[    47.573] (II) intel(0): blueX: 0.150 blueY: 0.120   whiteX: 0.313 whiteY: 0.329
[    47.573] (II) intel(0): Manufacturer's mask: 0
[    47.573] (II) intel(0): Supported detailed timing:
[    47.573] (II) intel(0): clock: 69.3 MHz   Image Size:  309 x 173 mm
[    47.573] (II) intel(0): h_active: 1366  h_sync: 1404  h_sync_end 1426 h_blank_end 1436 h_border: 0
[    47.573] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 803 v_border: 0
[    47.573] (II) intel(0): Unknown vendor-specific block f
[    47.573] (II) intel(0):  AUO
[    47.573] (II) intel(0):  B140XW03 V0
[    47.573] (II) intel(0): EDID (in hex):
[    47.573] (II) intel(0):    00ffffffffffff0006af3c3000000000
[    47.573] (II) intel(0):    00140103801f11780a10b59758579226
[    47.573] (II) intel(0):    1e505400000001010101010101010101
[    47.573] (II) intel(0):    010101010101121b5646500023302616
[    47.573] (II) intel(0):    360035ad100000180000000f00000000
[    47.573] (II) intel(0):    00000000000000000020000000fe0041
[    47.573] (II) intel(0):    554f0a202020202020202020000000fe
[    47.573] (II) intel(0):    004231343058573033205630200a002b
[    47.573] (II) intel(0): EDID vendor "AUO", prod id 12348
[    47.573] (II) intel(0): Printing DDC gathered Modelines:
[    47.573] (II) intel(0): Modeline "1366x768"x0.0   69.30  1366 1404 1426 1436  768 771 777 803 -hsync -vsync (48.3 kHz eP)
[    47.573] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[    47.573] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[    47.574] (II) intel(0): Printing probed modes for output LVDS1
[    47.574] (II) intel(0): Modeline "1366x768"x60.1   69.30  1366 1404 1426 1436  768 771 777 803 -hsync -vsync (48.3 kHz eP)
[    47.574] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[    47.574] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[    47.574] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    47.574] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[    47.574] (II) intel(0): EDID for output VGA1
[    47.596] (II) intel(0): EDID for output HDMI1
[    47.609] (II) intel(0): EDID for output DP1
[    47.609] (II) intel(0): Output LVDS1 connected
[    47.609] (II) intel(0): Output VGA1 disconnected
[    47.609] (II) intel(0): Output HDMI1 disconnected
[    47.609] (II) intel(0): Output DP1 disconnected
[    47.609] (II) intel(0): Using exact sizes for initial modes
[    47.609] (II) intel(0): Output LVDS1 using initial mode 1366x768
[    47.609] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    47.609] (II) intel(0): Kernel page flipping support detected, enabling
[    47.609] (**) intel(0): Display dimensions: (310, 170) mm
[    47.609] (**) intel(0): DPI set to (111, 114)
[    47.609] (II) Loading sub module "fb"
[    47.609] (II) LoadModule: "fb"
[    47.609] (II) Loading /usr/lib/xorg/modules/libfb.so
[    47.609] (II) Module fb: vendor="X.Org Foundation"
[    47.609]    compiled for 1.12.4, module version = 1.0.0
[    47.609]    ABI class: X.Org ANSI C Emulation, version 0.4
[    47.609] (II) Loading sub module "dri2"
[    47.609] (II) LoadModule: "dri2"
[    47.610] (WW) Warning, couldn't open module dri2
[    47.610] (II) UnloadModule: "dri2"
[    47.610] (II) Unloading dri2
[    47.610] (EE) intel: Failed to load module "dri2" (module does not exist, 0)
[    47.610] (II) fglrx(1): === [xdl_xs112_atiddxPreInit] === begin
[    47.610] (**) fglrx(1): Depth 24, (--) framebuffer bpp 32
[    47.610] (II) fglrx(1): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    47.610] (==) fglrx(1): Default visual is TrueColor
[    47.610] (==) fglrx(1): RGB weight 888
[    47.610] (II) fglrx(1): Using 8 bits per RGB
[    47.610] (==) fglrx(1): Buffer Tiling is ON
[    47.610] (II) Loading sub module "fglrxdrm"
[    47.610] (II) LoadModule: "fglrxdrm"
[    47.610] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    47.610] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    47.610]    compiled for 1.4.99.906, module version = 9.0.2
[    47.612] ukiDynamicMajor: found major device number 242
[    47.612] ukiDynamicMajor: found major device number 242
[    47.612] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    47.612] ukiOpenDevice: node name is /dev/ati/card0
[    47.612] ukiOpenDevice: open result is 11, (OK)
[    47.612] ukiOpenByBusid: ukiOpenMinor returns 11
[    47.612] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    47.612] (**) fglrx(1): NoAccel = NO
[    47.612] (**) fglrx(1): AMD 2D Acceleration Architecture enabled
[    47.612] (--) fglrx(1): Chipset: "AMD Radeon HD 6400M Series" (Chipset = 0x6760)
[    47.612] (--) fglrx(1): (PciSubVendor = 0x17aa, PciSubDevice = 0x21e3)
[    47.612] (==) fglrx(1): board vendor info: third party graphics adapter - NOT original AMD
[    47.612] (--) fglrx(1): Linear framebuffer (phys) at 0xc0000000
[    47.612] (--) fglrx(1): MMIO registers at 0xe2600000
[    47.612] (--) fglrx(1): I/O port at 0x00006000
[    47.612] (==) fglrx(1): ROM-BIOS at 0x000c0000
[    47.612] (II) intel(0): AC Adapter is used
[    47.612] (II) intel(0): AMD Video BIOS revision 9 or later detected
[    47.612] (--) fglrx(1): Video RAM: 1048576 kByte, Type: DDR3
[    47.612] (II) fglrx(1): PCIE card detected
[    47.612] (--) fglrx(1): Using per-process page tables (PPPT) as GART.
[    47.612] (WW) fglrx(1): board is an unknown third party board, chipset is supported
[    47.651] (II) intel(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x40000000)
[    47.651] (II) fglrx(1): RandR 1.2 support is enabled!
[    47.651] (II) fglrx(1): RandR 1.2 rotation support is enabled!
[    47.651] (==) fglrx(1): Center Mode is disabled
[    47.651] (II) Loading sub module "fb"
[    47.651] (II) LoadModule: "fb"
[    47.652] (II) Loading /usr/lib/xorg/modules/libfb.so
[    47.652] (II) Module fb: vendor="X.Org Foundation"
[    47.652]    compiled for 1.12.4, module version = 1.0.0
[    47.652]    ABI class: X.Org ANSI C Emulation, version 0.4
[    47.652] (II) Loading sub module "ddc"
[    47.652] (II) LoadModule: "ddc"
[    47.652] (II) Module "ddc" already built-in
[    47.671]
[    47.671] Backtrace:
[    47.671] 0: /usr/X11R6/bin/X (xorg_backtrace+0x49) [0x81c4609]
[    47.671] 1: /usr/X11R6/bin/X (0x8048000+0x1802da) [0x81c82da]
[    47.671] 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xffffe410]
[    47.672] 3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPxDisplayPreInit+0xe4) [0xb6884264]
[    47.672] 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs112_atiddxPreInit+0xa37) [0xb685be97]
[    47.672] 5: /usr/X11R6/bin/X (InitOutput+0x85b) [0x80beadb]
[    47.672]
[    47.672] Segmentation fault at address 0x4c
[    47.672]
Fatal server error:
[    47.672] Caught signal 11 (Segmentation fault). Server aborting
[    47.672]
[    47.672]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    47.672] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    47.672]
[    47.680] Server terminated with error (1). Closing log file.
liyuyao001
Baby Hen
 
Posts: 3
Joined: Wed Dec 05, 2012 16:03

Re: Cannot start X window after update

Postby Fitzcarraldo » Wed Dec 05, 2012 16:41

Press Ctrl-Alt-F1 to get to a VT (TTY1).
Log-in as root user.
Enter the following commands:

Code: Select all
equo update
equo upgrade
equo conf update
kernel-switcher switch linux-sabayon-3.6-r3
equo libtest
equo deptest

Then, if you wish to use the AMD Catalyst (FGLRX) legacy driver which still supports your GPU, follow the procedure given in the post http://forum.sabayon.org/viewtopic.php? ... 72#p154472. If you wanted to switch to the open-source Radeon driver then the procedure is different, but try the aforementioned procedure to see if you can get the legacy closed-source driver to work.

Once you have done all the above, reboot.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cannot start X window after update

Postby liyuyao001 » Thu Dec 06, 2012 2:30

Thank you a lot! i will try this later, should i have internet access before running these commands?
liyuyao001
Baby Hen
 
Posts: 3
Joined: Wed Dec 05, 2012 16:03

Re: Cannot start X window after update

Postby Fitzcarraldo » Thu Dec 06, 2012 3:00

Yes. If you previously had a working installation but now X Windows won't load, the chances are that a wired Ethernet connection will still work even when you are using the console.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Cannot start X window after update

Postby anomaly65 » Fri Dec 21, 2012 22:10

If the fault took place after a big update in the first week of december, Sabayon is by default loading the open source radeonhd driver, which causes major (failures) problems trying to use ati-drivers. Looks like your card might support them ok.

to blacklist them add radeonhd in /etc/modprobe.d/blacklist
Code: Select all
blacklist radeon


and get the latest ati-drivers (matching your kernel version).

my post might help. solved a big mess that started at the same time on very new hardware.

[url]
viewtopic.php?f=56&t=28585
[/url]
--
Use handrails on stairs. A nasty fall face first changes your point of view quickly, and mine permanently :-)
anomaly65
Technological Hen
 
Posts: 300
Joined: Sat Nov 17, 2007 15:37


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest