Sandy bridge graphics / switcheroo

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
thecata
Simple Hen
Posts: 77
Joined: Sun Nov 12, 2006 11:40
Location: Romania, Cluj

Sandy bridge graphics / switcheroo

Post by thecata » Sat Nov 17, 2012 20:40

First, the problem I have a Dell laptop, with an Intel 2430M processor and a ATI 6490HD graphics card.

Until recently, I used a 3.5 sabayon kernel, with xorg-X11 as option for "eselect opengl", and everything seemed to work fine (including kde effects). The "ati" option didn't seem to work as well (it's been a while since I tried it last, but I remember it was working, but with no effects).

I noticed that a 3.6 kernel was available in sabayon, and I tried to switch to that (used kernel-switcher of course). I kept the xorg-X11 option, but that now that doesn't work... instead of the login screen, I get a blank screen (well, not exactly blank, it's like a tty (Ctrl+Alt+F<1..6>), framebuffer picture included and a blinking cursor in the top left corner).
Fortunately, I was able to change the opengl setting to ati and I was able to start kde and resume using my computer. The weird part is that now KDE effects no longer work (with an error that effects are not available if I try to enable them).


On a probably related note, what is the status for the VGA switcheroo in sabayon? I was googling and this term kept showing up, but on gentoo wikis I read that I need to compile the kernel with certain options (I'm not really looking forward to that, I'd rather stick to the kernels provided in entropy).
Catalin Pol
Location: Romania
Linux user since 2004; Sabayon user since 2006

Post Reply