X-Server fails to start after latest updates [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators


Re: X-Server fails to start after latest updates [Solved]

Postby phd7 » Tue Jul 31, 2012 22:25

Yep, got it working myself now.
unfortunalelt tat's the end of Amneria:dark descent.. Bummer

"Open Source Drivers do not work
Currently the open source drivers to not provide a complete GLSL 1.20 implementation.. So at this time you MUST use the proprietary NVIDIA or ATI drivers. If you want the open source drivers to support the game I would suggest supporting the Mesa3D and the driver projects to improve the OpenGL support."

http://frictionalgames.com/forum/thread-3760.html

also a few isues with supertuxkart,but I'll survive
phd7
Young Hen
 
Posts: 22
Joined: Sun Apr 01, 2012 23:30

Re: X-Server fails to start after latest updates [Solved]

Postby jcoles » Sat Aug 04, 2012 11:52

For me, the solution was the exact opposite. I already had the /etc/modprobe.d/radeon.conf file with "options radeon modeset=1" in my X-challenged system. I changed the "1" to "0" and now I have graphics.

So, I'm back to the original problem of windows that corrupt if you move them. Perhaps a future update will fix that.
jcoles
Baby Hen
 
Posts: 5
Joined: Sat Aug 04, 2012 3:36

Re: X-Server fails to start after latest updates [Solved]

Postby phd7 » Sun Aug 05, 2012 19:21

After reading a few threads , and the Catalyst article, I pulled the info together and followed the following steps. It workd for me and I have no problems with the windows.

-----------------------------
1. Get Rid of ATI drivers

equo remove --configfiles ati-drivers ati-userspace
---------------
2a. to check if xf86-video-ati is installed:

equo query installed xf86-video-ati --quiet –verbose

if not installed ...
2b. Install xf86-video-ati

equo install xf86-video-ati

The first time I tried, I just ran the install command before checking which also pulled in a load of other stuff, and I didnt get the logi-in screen so the next time, I relaoded my backup and checked first if it was already installed.

2c. Remove the file /etc/gpu-detector.conf


---------------
3. let kernel load radeon module.

Edit /etc/conf.d/modules add “radeon” to modules line

Create the line modules=”radeon” at the end of the file or add the word radeon if this line already exists with other module mentioned

---------------

4. Remove some kernel modules from the grub menu

Edit /etc/default/sabayon-grub remove console=tty1, quiet splash=**** and vga=****
---------------

5. Add a custom parameter that enables KMS (kernel Mode Setting)

Edit /etc/default/grub in the line GRUB_CMDLINE_LINUX_DEFAULT add “radeon.modeset=1”

5a. Create the following file /etc/modprobe.d/radeon.conf containing the line:
options radeon modeset=1

Note...there may be some duplication here. At some point, either in this process of after running the next update, there was a line about 2 files with this modeset and 3 options for what I wanted to do. I chose number 3. I forget what it said exactly
----------------

6. regenerate grub.cfg file

grub-mkconfig -o /boot/grub/grub.cfg

-----------------

7. Use ATI in xorg config file

Edit /etc/X11/xorg.conf and change “fglrx” to “ati” if not already done
phd7
Young Hen
 
Posts: 22
Joined: Sun Apr 01, 2012 23:30

Re: [Solved]

Postby 4fff618 » Mon Aug 06, 2012 4:08

thank you very much! instructions helped me a lot
**sorry for my bad english**
4fff618
Baby Hen
 
Posts: 9
Joined: Fri Jul 13, 2012 23:45

Re: X-Server fails to start after latest updates [Solved]

Postby voltan » Sun Aug 26, 2012 14:59

Hello
I have same problem. My video cart is radeon HD 4500, I use this way and setup new driver.
But the problem is : my system freeze after some mint , I have this problem since one month ago after update ati driver, I try linux mint too whit ati driver and I see this problem. now after remove ati dirver and install xf86-video-ati I have same problem too. what is your idea?
voltan
Baby Hen
 
Posts: 11
Joined: Sat Mar 13, 2010 11:39

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests