Problem with printer after upgrade

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
nonviotale
Baby Hen
Posts: 2
Joined: Sat Feb 11, 2012 12:05

Problem with printer after upgrade

Post by nonviotale » Sun Feb 19, 2012 16:58

This morning i did a system upgrade, as i had a notification from my system that i have to update. After the upgrade i cannot any longer use my epson sx205 printer.
At the beginning i thought that it was just i minnor issue, so i restared cups and try to find my printer again, but no luck

so open a terminal and

Code: Select all

 lsusb 
and the result was

Code: Select all

Protocol spec without prior Class and Subclass spec at line 4297
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 8564:1000  
Bus 001 Device 004: ID 04b8:0849 Seiko Epson Corp. Stylus SX205
Bus 003 Device 002: ID 046d:c51a Logitech, Inc. MX Revolution/G7 Cordless Mouse
so i can see my printer but i do not know how to make cups see my printer

Thanks in advance for any help provided

DontPanic
Old Dear Hen
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Problem with printer after upgrade

Post by DontPanic » Mon Feb 20, 2012 18:15

What version of cups do you have installed?
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU [email protected] 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM

krovyoll
Baby Hen
Posts: 1
Joined: Tue Feb 21, 2012 6:28

Re: Problem with printer after upgrade

Post by krovyoll » Tue Feb 21, 2012 6:30

Same problem with Samsung SCX-4300

DontPanic
Old Dear Hen
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Problem with printer after upgrade

Post by DontPanic » Tue Feb 21, 2012 16:39

This sounds like an issue with kernel USB configuration.

Could someone who is having trouble try some of these things, and report back.

Code: Select all

zcat /proc/config.gz | grep CONFIG_USB_PRINTER

lsmod | grep usblp

You may want to try loading the usblp module to see if that helps:

Code: Select all

modprobe usblp
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU [email protected] 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM

Post Reply