Installing a second Canon printer [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Installing a second Canon printer [Solved]

Postby Austlig » Sun Jun 05, 2011 22:25

I successfully installed an iP4850 (cnijfilter-3.40.ebuild) using the method described by Fitzcarraldo (Canon PIXMA 500 (and similar printers) 17 Oct 2007). Works perfectly. I have just tried to install an MX320 Canon printer (cnijfilter-3.10.ebuild) , using the same method. It did not generate a separate manifest, instead it combined the two. And when I tried to set the USE flag it did not recognise the command. Is there another way to do this?

[email protected] ~ $ su
Password:
sabayon rob # cd /usr/local/portage/net-print/cnijfilter
sabayon cnijfilter # ebuild /usr/local/portage/net-print/cnijfilter/cnijfilter-3.10.ebuild manifest
>>> Creating Manifest for /usr/local/portage/net-print/cnijfilter
sabayon cnijfilter # USE-"mx320" emerge -v cnijfilter
bash: USE-mx320: command not found
sabayon cnijfilter #

DIST cnijfilter-source-3.10-1.tar.gz 3135290 RMD160 087e53ff658116a81f1de4ce09b194777396377a SHA1 bd34ca06c20018b72614a2134c7cef4437e32e5d SHA256 857c459c88e266e0a96627685daf195d1290cde56e5cab891a1ae6be799319f6
DIST cnijfilter-source-3.40-1.tar.gz 9586720 RMD160 f596be6061e4c0987b22ee08c452bd9a5214adcc SHA1 610a888484a51885186e5aa833852acd6172e9fe SHA256 a95dd4ca491a9e8acc3e4ee35cc84904680e82d89ff04a23dda1b0ccffbb8a7a
EBUILD cnijfilter-3.10.ebuild 7191 RMD160 ba338a6ec3087991f6a56fb7b8809573a6ab0573 SHA1 a755b1100130d533d0a60291dea3b9db87ddfb83 SHA256 6b90fbcb5f9224882504f807c9d9fd94c7c039544993a71efb1845e8627c503e
EBUILD cnijfilter-3.40-r3.ebuild 7644 RMD160 c355fc76762ff5906e6ace5cfb306d186e82cba0 SHA1 5813ea4a0f91b65206f558d9364bbc6003630f9a SHA256 46aedfb9980ba397766f185fa88f2b38c477c9b1090736c830dc85edbc2e02b0
Last edited by Austlig on Thu Jun 09, 2011 17:19, edited 1 time in total.
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: Installing a second Canon printer

Postby Fitzcarraldo » Sun Jun 05, 2011 22:41

a) You have incorrectly used a hyphen instead of an equals sign. USE="<flag>", not USE-"<flag>".

b) If you want to install two different versions of the same package (cnijfilter, in this case) then slot them. Edit the latest ebuild and change the line:

Code: Select all
SLOT="0"

to:
Code: Select all
SLOT="1"
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Installing a second Canon printer

Postby Austlig » Mon Jun 06, 2011 1:13

When I got the "=" and not the "-", I re-installed the 3.10 ebuild and did the ebuild. When I tried to set the USE flag, it reinstalled the 3.40 ebuild and told me I had not set a USE flag. So - I removed the manifest and the 3.40 ebuild and re-installed the 3.10 ebuild, ebuild it and got:

sabayon cnijfilter # rm /usr/local/portage/net-print/cnijfilter/cnijfilter-3.40-r3.ebuild
sabayon cnijfilter # rm /usr/local/portage/net-print/cnijfilter/Manifest
sabayon cnijfilter # cp /home/rob/cnijfilter-3.10.ebuild /usr/local/portage/net-print/cnijfilter
sabayon cnijfilter # ebuild /usr/local/portage/net-print/cnijfilter/cnijfilter-3.10.ebuild manifest
>>> Creating Manifest for /usr/local/portage/net-print/cnijfilter
sabayon cnijfilter # USE="mx320" emerge -v cnijfilter

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "virtual/ghostscript".
(dependency required by "net-print/cnijfilter-3.10" [ebuild])
(dependency required by "cnijfilter" [argument])
sabayon cnijfilter #



Is the 3.10 ebuild redundant??
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51

Re: Installing a second Canon printer

Postby Fitzcarraldo » Mon Jun 06, 2011 1:26

You need to edit the ebuild and, in the list of dependencies, replace "virtual/ghostscript" with "app-text/ghostscript-gpl". Then you need to generate a new manifest, and then merge (install) the package.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Installing a second Canon printer

Postby Austlig » Thu Jun 09, 2011 17:18

Got it, works perfectly, thanks for your help.
Austlig
Young Hen
 
Posts: 38
Joined: Sun Oct 17, 2010 0:51


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests