sound issue after updating kernel

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

sound issue after updating kernel

Postby amitvn » Sat Jun 04, 2011 17:48

last month installed kernel 2.6.38 and saw one problem with sound that whenever i use headphone mode in sound preferences
it doesn't mute the main speakers..
i thought might be problem of that kernel and now when i updated to lates 2.6.39 same problem persists........anybody having same issue??
For informatin when i boot back using default kernel i.e 2.6.37 all works fine
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: sound issue after updating kernel

Postby Fitzcarraldo » Sat Jun 04, 2011 17:51

Have you tried running alsaconf (as root user) after you upgraded the kernel? See if that helps.

See also the blog post Nostalgia for those ALSA mixer channels that KMix and GNOME Volume Control used to have? for some tips that might be of interest.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: sound issue after updating kernel

Postby amitvn » Sat Jun 04, 2011 18:57

after running alsaconf as root i get that no suupported PnP or PCI card found??
probe legacy ISA and cards?? This may make system unstable
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: sound issue after updating kernel

Postby Fitzcarraldo » Sat Jun 04, 2011 21:30

What is your audio hardware? Run the commands lspci and lsusb as root user and post the results.

The other thing you can do is to stop the ALSA daemon before running alsaconf, then start it again afterwards:

Code: Select all
# /etc/init.d/alsasound stop
# alsaconf
# /etc/init.d/alsasound restart
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: sound issue after updating kernel

Postby amitvn » Sun Jun 05, 2011 8:20

no stoping the deamon didnt worked...shows the same message

running lspci :
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)


and runnning lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub




and lsusb showing 1.1 root hub and only one 2.0 root hub
wht does that means?
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: sound issue after updating kernel

Postby amitvn » Sun Jun 05, 2011 8:25

looking at the only some working solutions at http://ubuntuforums.org/showthread.php?t=798945
if it would really works how should i determine which option i should include in configuration and basically there is no alsa-base.conf in my sytem but i have alsa.conf
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India

Re: sound issue after updating kernel

Postby Fitzcarraldo » Sun Jun 05, 2011 21:39

Your audio hardware is reported as "Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)". I'm surprised alsaconf doesn't see it; that would appear to indicate something is wrong, somewhere.

See the SL wiki article HOWTO: Resolve Problems with HDA-Intel Sound Cards.

If you enter the command lsmod as root user, which sound modules are listed?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: sound issue after updating kernel

Postby amitvn » Sun Jun 05, 2011 21:56

lsmod :


Module Size Used by
snd_seq_dummy 804 0
snd_seq_oss 18915 0
snd_seq_midi_event 3267 1 snd_seq_oss
snd_seq 30759 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 3429 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 25417 0
snd_mixer_oss 8969 1 snd_pcm_oss
pppoe 5932 2
pppox 1122 1 pppoe
ipv6 199341 54
ppp_generic 15258 6 pppoe,pppox
slhc 3275 1 ppp_generic
snd_hda_codec_realtek 192472 1
i915 242997 3
snd_hda_intel 15016 2
snd_hda_codec 46972 2 snd_hda_codec_realtek,snd_hda_intel
drm_kms_helper 18564 1 i915
snd_hwdep 3274 1 snd_hda_codec
snd_pcm 44061 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
r8169 24020 0
drm 110803 4 i915,drm_kms_helper
snd_timer 11510 2 snd_seq,snd_pcm
snd 31285 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
i2c_algo_bit 3218 1 i915
shpchp 16939 0
snd_page_alloc 4777 2 snd_hda_intel,snd_pcm
pci_hotplug 16126 1 shpchp
intel_agp 7112 1 i915
video 8914 1 i915
i2c_i801 5672 0
iTCO_wdt 7900 0
tpm_tis 4756 0
tpm 7328 1 tpm_tis
intel_gtt 8090 3 i915,intel_agp
pcspkr 1036 0
i2c_core 11199 5 i915,drm_kms_helper,drm,i2c_algo_bit,i2c_i801
iTCO_vendor_support 1245 1 iTCO_wdt
output 1002 1 video
tpm_bios 2998 1 tpm
xts 1709 0
gf128mul 5162 1 xts
iscsi_tcp 6373 0
tg3 98161 0
e1000 75797 0
scsi_wait_scan 463 0
sl811_hcd 7207 0
ohci_hcd 16243 0
uhci_hcd 15660 0
ehci_hcd 28540 0
sx8 9703 0
imm 7144 0
parport 20883 1 imm
pata_pcmcia 6641 0
pcmcia 25237 1 pata_pcmcia
Love Sabayon <3
amitvn
Simple Hen
 
Posts: 58
Joined: Wed May 04, 2011 10:50
Location: Mumbai,India


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest