Nvidia: can't use the console tty1

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: Nvidia: can't use the console tty1

Postby Fitzcarraldo » Sat Jun 04, 2011 16:41

Yes, try the native frame buffer mode for your laptop.

Also, according to your post in the Chakra Linux Forums you are using the NVIDIA 330M GPU in your laptop. Which NVIDIA driver are you currently using? Is it x11-drivers/nvidia-drivers-270.41.06#2.6.39-sabayon? Have you tried the latest version (x11-drivers/nvidia-drivers-270.41.19), which is in Portage?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Nvidia: can't use the console tty1

Postby speedyx » Sat Jun 04, 2011 18:34

Yes, I have that GPU, you are a great googler!
No, I haven't the portage driver modules, but only the sabayon standard latest driver and kernel.
Code: Select all
equo query installed nvidia
>>  @@ Cercando...
>>      @@ Pacchetto: media-video/nvidia-settings-270.41.06 branch: 5, [__system__]
>>         Installato:    versione: 270.41.06 ~ tag: NoTag ~ revisione: 1
>>         Slot:          0
>>         Homepage:      http://www.nvidia.com/
>>         Descrizione:   NVIDIA Linux X11 Settings Utility
>>         Licenza:       GPL-2
>>      @@ Pacchetto: x11-drivers/nvidia-drivers-270.41.06#2.6.39-sabayon branch: 5, [__system__]
>>         Installato:    versione: 270.41.06 ~ tag: 2.6.39-sabayon ~ revisione: 2
>>         Slot:          0,2.6.39-sabayon
>>         Homepage:      http://www.nvidia.com/
>>         Descrizione:   NVIDIA GPUs kernel drivers
>>         Licenza:       NVIDIA
>>      @@ Pacchetto: x11-drivers/nvidia-userspace-270.41.06 branch: 5, [__system__]
>>         Installato:    versione: 270.41.06 ~ tag: NoTag ~ revisione: 1
>>         Slot:          0
>>         Homepage:      http://www.nvidia.com/
>>         Descrizione:   NVIDIA X11 userspace libraries
>>                        and applications
>>         Licenza:       NVIDIA
>>  Keyword:  nvidia
>>  Trovati:  3 voci
The Freedom Technologies Are Available!
I love KDE rolling release distributions that just works!
speedyx
Growing Hen
 
Posts: 101
Joined: Sun Mar 28, 2010 6:05
Location: Italy

Re: Nvidia: can't use the console tty1

Postby Fitzcarraldo » Sun Jun 05, 2011 22:48

Well, you can either wait until joost builds the latest version of the package and puts the binary in the Entropy repository, or you can install it via Portage if you are confident in using Portage:

Code: Select all
# emerge --sync
# equo install git # In case you have not already installed it.
# layman -a sabayon # Do not worry if it is already added.
# layman -S
# emerge -1v =nvidia-drivers-270.41.19
# etc-update
# eselect opengl set nvidia # Ebuild should do this, but does no harm to do it just in case.
# equo rescue spmsync # Tell Entropy what you did via Portage.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

cron