What the Beep?! [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

aecius
Baby Hen
Posts: 3
Joined: Tue Mar 08, 2011 22:04

Re: What the BEEP?! [Solved]

Post by aecius » Mon May 23, 2011 12:20

I did it in this way:

Menu -> System -> Administration -> Login Window, go to "Accessibility":
In "Sounds" make sure you did not mark any of the boxes below.

P.S. When you will mark the first box below ("Login screen ready") and set the option "None" system will still play beep sound, so don't mark any of these boxes. :-)

GrantStoner
Baby Hen
Posts: 16
Joined: Tue May 17, 2011 17:21

Re: What the BEEP?! [Solved]

Post by GrantStoner » Wed May 25, 2011 3:37

Thanks! I un-blacklisted the modules, tried your method, and it worked just fine! This would have been like 1000x easier if I knew about this way earlier. It's weird that the "none" option still plays a sound. Un-checking that box worked like a charm.

urlwolf
Simple Hen
Posts: 47
Joined: Sat Dec 26, 2009 11:34

Re: What the BEEP?! [Solved]

Post by urlwolf » Thu Jun 02, 2011 19:22

$ xset b off
^^ this works too.

svantoviit
Old Dear Hen
Posts: 756
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: What the BEEP?! [Solved]

Post by svantoviit » Sun Mar 11, 2012 14:15

I partially solved "the beep issue" with putting the line 'xset -b' (equivalent of 'xset b off') into my .xsession file.
But when the machine resumed from hibernation or suspend, the beep has been back… how annoying.

I finally managed to solve it with the following a wake-up script.

Code: Select all

#!/bin/bash
case $1 in
        hibernate)
                ;;
        suspend)
                ;;
        thaw|resume)
                export DISPLAY=:0.0
                /bin/su USER -c "sleep 3; /usr/bin/xset -b"
                ;;
        *)  echo "ERROR: Couldn't run my_wakeup_script."
                ;;
esac
You need to name it 00-something, replace USER with your username and put it into /etc/pm/sleep.d/.
The 00 at the beginning are important - it means the script should be executed at the and of the queue (see /usr/lib/pm-utils/sleep.d) after modules has been loaded and services started.
The script should probably be "smarter", as stated in the pm-utils mailinglist, but it works for me well as it is.
By all means, consider it to be just a dirty workaround.

Post Reply