h/t Install working nvidia driver ? [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

h/t Install working nvidia driver ? [Solved]

Postby lunix » Mon May 09, 2011 21:26

Nvidia driver for 5500 card is weird. I can not find screen refresh rate and its curently too low.
How to install nvidia driver that gives gui about nvidia settings writable to xorg.conf in the system tools?
I want to play games in this os it needs graphic driver.
Last edited by lunix on Tue May 10, 2011 17:31, edited 1 time in total.
lunix
Baby Hen
 
Posts: 5
Joined: Mon May 09, 2011 21:13

Re: h/t Install working nvidia driver ?

Postby albfneto » Tue May 10, 2011 5:53

IMPORTANT:

For all the NVIDIA cards series 5, as the 5500, the only driver that works is the 173 series. The newer not works with this kind of antique nvidia.
you can choose the driver series 173, with the new kernel. Using Sulfur or commands, remove the NEW installed NVIDIA DRIVERS and install these packages:
x11-drivers/nvidia-drivers-173.14.28#2.6.38-sabayon and the 38 kernel, the newer (ex. 260, not works)

using commands:

Code: Select all
sudo equo remove --relaxed nvidia-drivers
sudo equo update
sudo equo install entropy equo sulfur
sudo equo install linux-sabayon
eselect kernel list                                                                                   (see the number of 2.6.38 kernel)
sudo eselect kernel set number                                                               (number is the num of kernel 2.6.38)
sudo equo install nvidia-drivers-173.14.28#2.6.38-sabayon nvidia-settings
sudo eselect opengl set nvidia


then, close the session and begin a new session, or better, reboot to the new kernel
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: h/t Install working nvidia driver ?

Postby lunix » Tue May 10, 2011 8:23

albfneto wrote:IMPORTANT:....

Am I suppose to modify syntax ?
Add my version of kernel ?
It is showing
linux-2.6.37-sabayon
linux-2.6.38-sabayon
How to see which is mine ?
lunix
Baby Hen
 
Posts: 5
Joined: Mon May 09, 2011 21:13

Re: h/t Install working nvidia driver ?

Postby lunix » Tue May 10, 2011 15:32

/edit: 1
It needs to add
Code: Select all
equo mask nvidia-drivers-260.19.36#2.6.38-sabayon
equo mask nvidia-settings-260.19.36


Ive solved my before question
lunix
Baby Hen
 
Posts: 5
Joined: Mon May 09, 2011 21:13

Re: h/t Install working nvidia driver ?

Postby lunix » Tue May 10, 2011 16:51

And it looks it automaticly sets opengl
I am thankful :)

The things I missed was
equo mask nvidia-drivers-260.19.36#2.6.38-sabayon (so it hides this version and installs one for my card nv5500)
equo mask nvidia-userspace-260.19.36

and then run
nvidia-xconfig
and for 19inch monitor run this after nvidia-xconfig
nvidia-xconfig --mode=1280x1024

[SOLVED]
lunix
Baby Hen
 
Posts: 5
Joined: Mon May 09, 2011 21:13

Re: h/t Install working nvidia driver ? [Solved]

Postby sojourner » Tue May 10, 2011 20:04

I have a similar situation , my card is an FX5200 , I followed the steps , including masking the 260 driver but still cannot get my display to go past 720x480 . my driver shows as the correct one (173.14.28 ) and my xorg.conf is set to the proper 1440x900 res for my ws lcd , I know the monitor has a bad edid but in other distros have been able to set the correct res by hand editing my xorg.conf , How do I get this to work in sabayon , it seems to ignore the xorg.conf settings .
sojourner
Young Hen
 
Posts: 38
Joined: Sun Jan 07, 2007 3:27
Location: orlando ,fl,usa

Re: h/t Install working nvidia driver ? [Solved]

Postby lunix » Tue May 10, 2011 20:19

sojourner wrote:I have a >>

command:
nvidia-xconfig --mode=1440x900
Shout set it

And it looks in xorg.conf like this
Code: Select all
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1440x900"
    EndSubSection


Xfce will allow you to choose all lower resolutions including this one
But I have not tryed it for 1440x900, I dont know , but it should work.

If you want clean xorg.conf, rename it to backup and run
nvidia-xconfig --mode=1440x900

//EDIT::
Try change deph to 16
lunix
Baby Hen
 
Posts: 5
Joined: Mon May 09, 2011 21:13

Re: h/t Install working nvidia driver ? [Solved]

Postby sojourner » Wed May 11, 2011 3:59

thanks for the attempt to help , tried your suggestions but no help trying a full reinstall now .
sojourner
Young Hen
 
Posts: 38
Joined: Sun Jan 07, 2007 3:27
Location: orlando ,fl,usa


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron