Page 2 of 2

Re: Nvidia-Driver 270.41.06 - A little revolution?

Posted: Fri Jun 10, 2011 23:40
by Fitzcarraldo
Which version of nvidia-drivers is "the 9300M driver", gabvil? I can find the "9300M G" listed on the driver download page on the NVIDIA site. Is that the one? According to the NVIDIA site, the driver for the 9300M G is the same as the driver for the G105M, namely version 270.41.19, which is not currently in the Entropy repository. I therefore got my relative to try version 270.41.06 from the Entropy repository and it didn't work (blank screen and blinking cursor in top left corner). I also talked him through installing nvidia-drivers-270.41.06 from the main Portage tree (as opposed to nvidia-drivers-270.41.06 in the Sabayon overlay) via Portage, which he did, but that didn't work either. I also talked him through installing 270.41.19 via Portage but the merge failed. I also talked him through installing via Portage various earlier versions of nvidia-drivers, but, although they merged, there was no change to the blank screen with blinking cursor in the top corner. I of course made sure that the kernel symlink was set up correctly and the correct OpenGL libraries were linked. I also got him to generate a new xorg.conf by using nvidia-xconfig. In all these cases /var/log/messages showed kernel error messages regarding what looked like a problem with the framebuffer, and /var/log/Xorg.0.log showed various error messages. I also got him to try the VESA driver, nv driver and nouveau driver, but all exhibited the same problem. I think this is a bug either with the kernels he tried (2.6.37-sabayon and 2.6.39-r1-sabayon) or with X.Org. He returned to his home town yesterday with his laptop, so I have asked him to e-mail me log files and the output of various commands, for diagnosis. If he sends me those, I think I will start a new thread with the output.

Do you have SL working with the G105M? If so, what version of nvidia-drivers and what version of the SL kernel are you using? Is the change to xorg.conf that you mentioned the only change you made to your laptop with the G105M to get it working?

Google returns relatively little for the G105M. Mostly forum and blog posts from previous years with older kernels, and not necessarily relevant to the current situation. There are a couple of Debian xorg.conf files from posts on the G105M in previous years that I will ask him to try, but it's rather difficult to experiment without being able to get my hands on the machine itself, especially if the owner is not an experienced Linux user.

Re: Nvidia-Driver 270.41.06 - A little revolution?

Posted: Sat Jun 11, 2011 14:31
by gabvil
My bad, 9300M G is the driver, this model is the 105M without steroids. :mrgreen:

Currently this revision gave me a loooooot of problems with some Geforce 8 series. The G105M was pretty difficult to me being working in my cousin's lappy. The kernel used was 2.6.36 and 260.19.36 driver. I put the mentioned above line in xorg.conf, and after a lot of workarounds get it working (not perfectly but usable). Did you check something related to the libdrm? The errors with the framebuffer and Xorg.0.log?

A new thread could help someone else with the same experience with this :pig: driver...

Re: Nvidia-Driver 270.41.06 - A little revolution?

Posted: Thu Jun 16, 2011 6:46
by Fitzcarraldo
Well, gabvil, with my help my relative has now got his Acer Aspire 5738 with G105M GPU working with 64-bit SL 5.5 KDE upgraded to Entropy repository contents on 13 June.

He had tried various things, including installing via Portage xorg-server-1.10.2 and nvidia-drivers-270.41.19. He then e-mailed me the output from lsmod and dmesg and I noticed that the nouveau module was loaded and the nvidia module was not. This is because the kernel config for linux-sabayon-2.6.39-r1 has CONFIG_DRM_NOUVEAU=m. So I told him to blacklist the nouveau module and reboot. Then X Windows loaded correctly and he got to the KDE login screen but could not use the keyboard or mouse. This was due to two factors: 1) when one installs a new version of the X.Org Server one must recompile and re-install the X.Org drivers, so he would need to recompile xf86-input-keyboard, xf86-input-mouse and/or xf86-input-evdev; 2) xf86-input-mouse and xf86-input-keyboard are not used by xorg-server-1.10.* (see as it uses xf86-input-evdev. So I told him to merge xf86-input-keyboard, xf86-input-mouse and xf86-input-evdev so that it is built against the latest X.Org Server that he had installed via Portage. He did that and now has a working installation. What a palava.

I wonder if X Windows would have worked had he just blacklisted the nouveau module and stayed with the Entropy packages nvidia-drivers-270.41.06#2.6.39 [which was compiled to match linux-sabayon-2.6.39-r1] and xorg-server from the Entropy repository. Or perhaps the 270.41.19 NVIDIA driver is also essential in order for the NVIDIA G105M to work. Without access to his laptop I cannot experiment to answer that.

Anyway, my next exercise is to get him in a position where he can revert to using only Entropy. To do that I will tell him not to update and upgrade anything until the packages in the Entropy repository reach the same versions as the ones he installed via Portage. But that is a different topic entirely.