SL 5.5 alsamixer settings for mic.

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

SL 5.5 alsamixer settings for mic.

Postby Richlion » Sat Feb 26, 2011 19:23

Hello,

every since I've saddled onto SL5.5 I am having one problem with my microphones, so I have a few questions, some of them may not belong here, forgive me if I don't put it into the newbie area.

I read the older threads about alsamix and pulseaudio:
viewtopic.php?f=56&t=18789&p=122661&hilit=alsactl+store#p122661

I managed to find out why my mic would stop working after a reboot.
I have to save my alsamix with the command "alsactl store". I was trying to use the following blog:
http://linux.dsplabs.com.au/alsamixer-a ... tings-p29/
My questions is about using ROOT to store my alsamixer settings, I don't quite understand the sequence, can someone help me?

When I am logged in as a regular user (that was my first thought) I launch alsamixer and change my Input Source from MIC to FRONT MIC.
So next I press EXIT, correct?
Then I have to sudo :
Code: Select all

[email protected] ~ $ sudo alsactl store

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Password: ..................=> here I try my ROOT password
Sorry, try again.
Password:
No protocol specified
xcb_connection_has_error() returned true


Did I do something wrong starting alsamixer as myself?

Next question, when I login as ROOT and run alsamixer as suggested in the first thread:
by Fitzcarraldo » Thu Oct 29, 2009 2:43

Firstly, I made sure that the ALSA side of things was configured correctly by using the alsaconf command followed by the alsamixer command, both done as the root user in a Konsole/Terminal window.


then why don't those settings override my private session settings? Which take precedence?

Also when I use "su -" and "alsactl store", which settings are saved, ROOT and All Users settings, or just ROOT?

In the end, how to properly save the alsamixer settings?

Thanks in advance.
RIchard
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester

Re: SL 5.5 alsamixer settings for mic.

Postby Fitzcarraldo » Sat Feb 26, 2011 20:17

Moving to Hardware shed (forum).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SL 5.5 alsamixer settings for mic.

Postby Fitzcarraldo » Sat Feb 26, 2011 20:46

The Arch Linux Wiki article on ALSA is quite helpful: Restore ALSA Mixer settings at startup. Below I've modified the relevant section from it to take into account the differences between Gentoo and Arch:

--------------------------------------------------------------------------------------------------------------------------------
Restore ALSA Mixer settings at startup

* Run /usr/sbin/alsactl -f /var/lib/alsa/asound.state store once to create /var/lib/alsa/asound.state.

Code: Select all
# /usr/sbin/alsactl -f /var/lib/alsa/asound.state store


* If not already done, add the alsasound initscript to the default runlevel. This will store the mixer settings on every shutdown and restore them when you boot.

Code: Select all
# rc-update add alsasound default


* If the mixer settings are not loaded on boot-up, add the following line to /etc/conf.d/local:

Code: Select all
# /usr/sbin/alsactl -f /var/lib/alsa/asound.state restore


* These methods still may not work, or you may prefer to have audio settings for individual users. In this case, run /usr/sbin/alsactl store -f ~/.asoundrc as a normal user. This will save and restore volume settings on a per-user basis. To automate this process, add the respective commands to ~/.bash_profile and ~/.bash_logout, or the correct locations for the shell of your choice.
--------------------------------------------------------------------------------------------------------------------------------

If you configure audio settings for an individual user, they will override the system-wide settings, as the user's preferences are executed later and take precedence. Which makes sense.

You'll have to play around with the above and do some research yourself, as I haven't played around with audio settings and the .bash* files for a while.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SL 5.5 alsamixer settings for mic.

Postby Richlion » Sat Feb 26, 2011 20:56

Ok, so I understand I can have my own settings, that suits me.
Thanks for the hint.
I guess when things get messed up it's when one has to learn a couple of tricks :wink:
RIchard
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester

Re: SL 5.5 alsamixer settings for mic.

Postby Richlion » Sun Feb 27, 2011 19:02

Well, I tried everything you suggested. I also thought maybe I have a problem with my local .asoundrc file, so I removed it and used :
/usr/sbin/alsactl store -f ~/.asoundrc - after setting my desired FRONT MIC.
Nothing. I also logged in as root, changed my source from MIC to FRONT MIC and saved with "alsactl store". Nothing, whatever I do under ROOT or my user alsamixer still resets source to MIC after rebooting.
The odd thing is on my PC so far I don't have the same problem.
I will have to live for a while with the fact that I will have to reset the source every time I boot my laptop. Pitty :(
Unless there are other options to explore?

Thanks for helping.
Richard.
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester

Re: SL 5.5 alsamixer settings for mic.

Postby Fitzcarraldo » Sun Feb 27, 2011 19:17

It could be that KDE is interfering with your settings. Have you tried unticking the KMix setting "restore volumes on login"? See Re: Kmix lost channels [Solved].
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: SL 5.5 alsamixer settings for mic.

Postby Richlion » Sun Feb 27, 2011 20:00

:roll: Oooops, I didn't know there was such an option there, I will try.
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester

Re: SL 5.5 alsamixer settings for mic.

Postby Richlion » Sun Feb 27, 2011 21:10

Ok, just tried it and many other things. For example, I killed kmix, reset the Alsamix setting. Rebooted.
No luck. I quit Kmix and for some reason it still comes up, when it shouldn't, because if I logout, KDE should remember Kmix should not launch, but it does.
If Kmix is interfering with Alsamixer, how do I disable Kmix? Anyone tried it?

For today I must drop the subject, I already spent 3 days rebooting my laptop 100 times getting this simple thing done. KDE sometimes is a waste of time, they tweak, they change, they tweak, reorganize, change, tweak, it really can make me tired. I may ask for help with Kmix on their forum tomorrow.

Have a nice evening,
Richard.
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests