audio skipping [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

audio skipping [Solved]

Postby ankitsingh » Fri Jan 28, 2011 18:26

i have creative soundblaster live EMU10k1x sound card which is not working in 5.4,(Perfect Sound in 5.2 :/).Audio plays very fast and suddenly BOOM.Any help :(
ankitsingh
Baby Hen
 
Posts: 15
Joined: Tue Nov 24, 2009 18:19

Re: audio skipping

Postby k4ph » Fri Jan 28, 2011 22:05

Do you have now 2 sound systems installed, maybe phonon and pulse audio - or alsa and pulse audio?
Just a shoot into the blue. It's not much information you're presenting at the moment.
[email protected] | [email protected] | http://c4ph.tumblr.com
k4ph
Simple Hen
 
Posts: 55
Joined: Mon Nov 01, 2010 0:52
Location: Germany

Re: audio skipping

Postby Fitzcarraldo » Sun Jan 30, 2011 1:39

^There's nothing wrong with ALSA and PulseAudio being installed simultaneously; that's what's supposed to happen:

http://upload.wikimedia.org/wikipedia/c ... iagram.svg

ankitsingh, have you run ALSAConf to set up your card yet? Open a Konsole/Terminal window, log in as root user and enter the following command:

Code: Select all
alsaconf

Select your card when prompted to select a card, and let ALSAConf do its stuff. Once it has finished, enter the following command to run ALSAMixer:

Code: Select all
alsamixer

Press F6 to select your card, and make sure none of the channels are muted and the volumes are at sensible levels.

Then try to play some music using a media player. As k4ph wrote, you have not given much information on your problem. Are you experiencing the problem in a Web browser playing Flash videos, or are you experiencing the problem when playing music using a media player (if so, which one)? If the problem is with a media player, have you tried launching it from the command line in a Konsole/Terminal window to see if there are any error messages?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: audio skipping

Postby ankitsingh » Sat Feb 05, 2011 12:31

I mean there is audio skipping (suppose a music is of 5mins but it finishes off in about 1min and in videos the sounds moves faster than images :!: ) and this is associated with all applications (games,browser,music,video everything no matter what application used).I ran alsaconf but still its same.My audio system is completely useless.googling out i found that its a bug and all linux OS are affected.

https://bugs.launchpad.net/ubuntu/+sour ... bug/659732
https://bugzilla.redhat.com/show_bug.cgi?id=633032

I don't even have windows now on my hd that means i cannot listen any audio :/ Please help
ankitsingh
Baby Hen
 
Posts: 15
Joined: Tue Nov 24, 2009 18:19

Re: audio skipping

Postby ankitsingh » Mon Feb 07, 2011 6:51

a workaround people did https://bugs.launchpad.net/ubuntu/+sour ... bug/659732
Installing the ALSA driver module for kernel 2.6.35-22 via

sudo apt-get install linux-alsa-driver-modules-$(uname -r)

has restored sound when booting with kernel 2.6.35-22 and I can now play
music files.

The opening drums and music are not played despite being enabled in
"Startup Applications" and "Login screen".

The latter occurs regardless of which kernel is used.


how to do this in sabayon?
ankitsingh
Baby Hen
 
Posts: 15
Joined: Tue Nov 24, 2009 18:19

Re: audio skipping

Postby Fitzcarraldo » Sat Feb 12, 2011 10:51

You would have to rebuild the kernel to make ALSA a module instead of in-kernel, then install the alsa-driver module package. However I'm not convinced that is the solution to your problem...

1. Which desktop environment are you using? KDE? GNOME?

2. Please post the output of the following commands that you run as root user in a Konsole/Terminal window:

Code: Select all
aplay -l

Code: Select all
lspci | grep -i audio

Code: Select all
cat /proc/asound/cards

Code: Select all
cat /proc/asound/modules

Code: Select all
cat /proc/asound/card0/codec#* | grep -i codec

It may be that changing the slave.rate in .asoundrc, as shown in e.g. http://alsa.opensrc.org/Via8233#Poor_sound_quality, might solve the problem.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: audio skipping

Postby ankitsingh » Sat Feb 19, 2011 15:02

Solved :D
I have GNOME desktop environment
http://wiki.sabayon.org/index.php?title ... _genkernel I followed all instruction over there and now there is no audio skipping .

Thanks
ankitsingh
Baby Hen
 
Posts: 15
Joined: Tue Nov 24, 2009 18:19


Re: audio skipping [Solved]

Postby ankitsingh » Sat Feb 19, 2011 16:54

aah ,actually i was searching for solved button but did not find it. Thanks
ankitsingh
Baby Hen
 
Posts: 15
Joined: Tue Nov 24, 2009 18:19


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests