video issue after update

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

smb96
Simple Hen
Posts: 70
Joined: Mon Nov 23, 2009 11:44

Re: video issue after update

Post by smb96 » Wed Jan 26, 2011 14:10

I also have a Intel video problem since last upgrade. I went back to the previous driver. It didn't solve the problem but made it much better. If you want to try it you need to use portage to do it.

as root

Code: Select all

emerge --sync && emerge -v =x11-drivers/xf86-video-intel-2.12.0 && equo rescue spmsync
if you want too keep that version put =x11-drivers/xf86-video-intel-2.12.0 into /etc/entropy/packages/package.mask.

wotan
Baby Hen
Posts: 13
Joined: Tue May 25, 2010 14:32

Re: video issue after update

Post by wotan » Fri Jan 28, 2011 5:27

I have an nvidia GeForce 7000M and right after switching from proprietary to nouveau I started having the same issue (2.6.37 kernel). So perhaps this is not entirely an intel problem. I quite literally made this switch just half an hour ago so I haven't had much chance to work on it.

gabvil
Growing Hen
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: video issue after update

Post by gabvil » Sat Mar 05, 2011 12:07

I have the same chipset on my laptop, intel is a problem everytime i try on every sys this touch.
My chipset is a X3100, Mobile GM965/GL960 <---- same generation family.
You could try this (perhaps i've passed this issues several times before).

Use one of this and try if you success... :wink:
·On boot replace or add the cheatcode, removing the "vga=xxx"

Code: Select all

xdriver=vesa
or

·Disable KMS for intel on Grub

Code: Select all

Change the i915.modeset option to 0 in GRUB's /boot/grub/menu.lst
Intel is a crappy chipset on this gen of graphics.-

Hope this helps you !!! (or someone else, this is the goal of a forum)

Maybe if this doesn't work you could try this: http://forum.sabayon.org/viewtopic.php?f=56&t=22845

Kindest regards.

PS: Bad english, i know... :|
·Intel [email protected]/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel [email protected]/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel [email protected]/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC

Post Reply