BCM57780 Broadcom ethernet card module failing to load

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 1
Joined: Sat Jan 05, 2008 18:30

BCM57780 Broadcom ethernet card module failing to load

Post by gridge » Fri Jul 16, 2010 21:10

Hi guys,
I've a failure in loading the kernel driver for the BCM57780 ethernet card. I just installed a fresh Sabayon 5.3, so it's not already patched with all the latest packages (but before doing, unless you tell me this bug is fixed with those patches, I would prefer to connect with the wired network instead of the wireless).
Few info:

spaganpc modprobe.d # cat /etc/sabayon-edition
Sabayon Linux 5.3 amd64 K
spaganpc modprobe.d # uname -a
Linux spaganpc 2.6.34-sabayon #1 SMP Mon May 31 16:00:15 UTC 2010 x86_64 Intel(R) Core(TM) i7 CPU Q 720 @ 1.60GHz GenuineIntel GNU/Linux

spaganpc spagan # lspci | grep -i eth
03:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)

spaganpc spagan # dmesg | grep tg3
[ 9.964037] tg3.c:v3.108 (February 17, 2010)
[ 9.964108] tg3 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 9.964128] tg3 0000:03:00.0: setting latency timer to 64
[ 9.968767] tg3 mdio bus: probed
[ 9.968772] tg3 0000:03:00.0: (unregistered net_device): No PHY devices
[ 9.969585] tg3 0000:03:00.0: (unregistered net_device): Problem fetching invariants of chip, aborting
[ 9.969663] tg3 0000:03:00.0: PCI INT A disabled

Following existing discussions (see https://bugzilla.redhat.com/show_bug.cgi?id=525966) I tried to add few lines to the modprobe configuration at the startup (I added a file: /etc/modprobe.d/local.conf with the following lines):
spaganpc spagan # modprobe -c | grep install
install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3
install skfp /sbin/modprobe marvell; /sbin/modprobe --ignore-install skfp

but it did not work. Still exactly the same problem.

Do you have any idea? I tried to look inside the Sabayon forum but I found no threads on this.
Let me know if you need more info!!

Growing Hen
Posts: 168
Joined: Mon Feb 23, 2009 7:23

Re: BCM57780 Broadcom ethernet card module failing to load

Post by deusr » Wed Aug 25, 2010 7:18

Hello, I have the same board and am having the same problem, I know how he does for work but can not fix.

do the following ...

Code: Select all

rmmod tg3; broadcom modprobe, modprobe tg3
this will work, ie the broadcom module must be loaded before the tg3, if you know how to do it at boot, let me know!

Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: BCM57780 Broadcom ethernet card module failing to load

Post by Fitzcarraldo » Fri Aug 27, 2010 13:27

^You could try to automate the entry of those commands at start-up. You can do that by adding them to the file /etc/conf.d/local as follows:

Code: Select all

# Here is where you can put anything you need to start
# that there is not an init script for.

local_start() {
        # This is a good place to load any misc programs
        # on startup (use &>/dev/null to hide output)

        # deusr's commands to get BCM57780 Ethernet card module to work:
        rmmod tg3 && modprobe broadcom && modprobe tg3

        # We should always return 0
        return 0

local_stop() {
        # This is a good place to unload any misc.
        # programs you started above.

        # We should always return 0
        return 0
Give that a try to see if it does what you want. Another approach would be to do what jordanwb did in the following post: [Solved] Netgear GA302T - driver issues

Post Reply