epson perfection v30 scanner ain detected

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
musicaniac
Baby Hen
Posts: 1
Joined: Sun Apr 19, 2009 11:15

epson perfection v30 scanner ain detected

Post by musicaniac » Tue Apr 20, 2010 17:20

hi erverybody!

As You can see, I'm new to Sabayon (but not to Linux!)

That's the problem: My scanner (epson perfection v30) needs the iscan-software, wich can be installed via equo whithout any problems, but when i try to start iscan i get an error-message, that "no orders can be sent to the scanner; check scanner status" or something like that (translated from German ;) )

lsusb shows, that the scanner is connected properly.

do i need the "esci-interpreter-gt-f720"-package like they say oin this page : http://www.gentoolinuxhcl.org/browse/pr ... 30?id=6859

and if its so, why isn't it to the repo, while iscan is?!? And how shoud i get it to work anyway?

I hope my desciptopn is complete enough and you will help me!

best wishes and thanks,

musicaniac

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: epson perfection v30 scanner ain detected

Post by Fitzcarraldo » Tue May 04, 2010 14:28

musicaniac wrote:do i need the "esci-interpreter-gt-f720"-package like they say oin this page : http://www.gentoolinuxhcl.org/browse/pr ... 30?id=6859

and if its so, why isn't it to the repo, while iscan is?!?
Because it's supposedly already built in to the iscan package, perhaps?:
media-gfx/iscan-2.21.0
EPSON Image Scan! for Linux (including sane-epkowa backend)
I don't have your hardware, but searching the Gentoo Bugzilla throws up an ebuild for the package you apparently need: Gentoo Bug 274625 - esci-interpreter-gt-f720 binary driver-plugin for iscan/SANE epkowa backend.

You can use Portage to install it:

1. Surf over to Gentoo Bugzilla Bug Report No. 274625 and download the file sane-esci-interpreter-gt-f720-0.0.1.ebuild to /home/musicaniac/Desktop/

2. Open a Konsole/Terminal window and log-in as the root user.

3. Make sure your installation is synchronised (up-to-date) with the main Portage tree and Sabayon overlay:

Code: Select all

emerge --sync
layman -S
(If you're an Entropy user then do not emerge portage if emerge --sync tells you there is a new version of portage.)

4. Use the nano editor:

Code: Select all

nano /etc/make.conf
to edit the file /etc/make.conf and add the following line at the end (if it's not there already):

Code: Select all

PORTDIR_OVERLAY="${PORTDIR_OVERLAY} /usr/local/portage/"
While you're at it, check that you have the following line in /etc/make.conf too, so that any packages requiring licence acknowledgement get that acknowledgement automatically:

Code: Select all

ACCEPT_LICENSE="*"
5. Stop Portage nagging about a missing name for your local overlay:

Code: Select all

mkdir /usr/local/portage/profiles
echo "local_overlay" > /usr/local/portage/profiles/repo_name
6. Create a directory for sane-esci-interpreter-gt-f720 in a local overlay on your HDD, copy the ebuild to it and create a manifest for the ebuild:

Code: Select all

mkdir -p /usr/local/portage/media-gfx/sane-esci-interpreter-gt-f720/files
cd /usr/local/portage/media-gfx/sane-esci-interpreter-gt-f720
cp /home/musicaniac/Desktop/sane-esci-interpreter-gt-f720-0.0.1.ebuild .
ebuild sane-esci-interpreter-gt-f720-0.0.1.ebuild manifest
(Don't miss the dot in the copy command above.)

7. Finally, merge (install) the package:

Code: Select all

emerge -1v sane-esci-interpreter-gt-f720
8. If you're an Entropy user then don't forget to let Entropy know what you did via Portage:

Code: Select all

equo database spmsync
9. Log out of the root user's account:

Code: Select all

exit
I have no idea whether or not this will solve your problem as I don't have your hardware, but, if I did, this would be the first thing I would try.

Pollo_Loco
Baby Hen
Posts: 14
Joined: Sat Dec 15, 2007 1:35
Location: Orlando, FL
Contact:

Re: epson perfection v30 scanner ain detected

Post by Pollo_Loco » Wed Dec 22, 2010 6:13

I followed the guidelines above, except with a diff ebuild that I need for the V500:

Code: Select all

precision files # ebuild iscan-plugin-gt-x770-2.1.1.ebuild manifest
Appending /usr/local/portage/media-gfx to PORTDIR_OVERLAY...
!!! /usr/local/portage/media-gfx/iscan-plugin-gt-x770-2.1.1/files/iscan-plugin-gt-x770-2.1.1.ebuild does not seem to have a valid PORTDIR structure.
precision files #


Not sure what I've done wrong per the above guidelines? My ebuild is here: http://bugs.gentoo.org/277117

Help getting my scanner working is GREATLY appreciated !!
Cheers, Big Ears!

DΞLL Precision M6500 "Big Dog": i7-820QM w/USB 3.0, 8.0GB DDR3-1333, Intel x-25M 160 G2 + 500GB 7200.3, nVidia Quadro FX 3800M 1.0GB DDR3, RGBLED, Intel 6300 //Win7Pro x64/Sabayon KDE 4.5.4 x64

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: epson perfection v30 scanner ain detected

Post by Fitzcarraldo » Wed Dec 22, 2010 11:39

Looking at that error message, did you create the directory tree for the ebuild as:

Code: Select all

/usr/local/portage/media-gfx/iscan-plugin-gt-x770-2.1.1/files/
or as:

Code: Select all

/usr/local/portage/media-gfx/iscan-plugin-gt-x770/files/
It needs to be the latter.

Code: Select all

mkdir -p /usr/local/portage/media-gfx/iscan-plugin-gt-x770/files
cd /usr/local/portage/media-gfx/iscan-plugin-gt-x770
cp /home/precision/Desktop/iscan-plugin-gt-x770-2.1.1.ebuild .
ebuild iscan-plugin-gt-x770-2.1.1.ebuild manifest

Pollo_Loco
Baby Hen
Posts: 14
Joined: Sat Dec 15, 2007 1:35
Location: Orlando, FL
Contact:

Re: epson perfection v30 scanner ain detected

Post by Pollo_Loco » Wed Dec 22, 2010 20:49

everything went fine thru the manifest, finally to emerge I get:

Code: Select all

precision iscan-plugin-gt-x770 # emerge -1v iscan-plugin-gt-x770-2.1.1
!!! 'iscan-plugin-gt-x770-2.1.1' is not a valid package atom.
!!! Please check ebuild(5) for full details.
precision iscan-plugin-gt-x770 # 
EDIT: I left off the version numbers and it installed...now to try it !!

It's WORKING !! At long last!! thanks Fitz!! Is this in the wiki anywhere? It would be nice to get those various ebuilds into the repo!
Last edited by Pollo_Loco on Sun Dec 26, 2010 1:56, edited 1 time in total.
Cheers, Big Ears!

DΞLL Precision M6500 "Big Dog": i7-820QM w/USB 3.0, 8.0GB DDR3-1333, Intel x-25M 160 G2 + 500GB 7200.3, nVidia Quadro FX 3800M 1.0GB DDR3, RGBLED, Intel 6300 //Win7Pro x64/Sabayon KDE 4.5.4 x64

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: epson perfection v30 scanner ain detected

Post by Fitzcarraldo » Wed Dec 22, 2010 21:07

The reason you got that error message is because you were not using the correct Portage syntax. You need to have an equals sign in front of the package name if you include the version:

Code: Select all

emerge -1v =iscan-plugin-gt-x770-2.1.1
The above command will install that specific version, whereas the following command will install the latest version that your installation knows about:

Code: Select all

emerge -1v iscan-plugin-gt-x770

Post Reply