Page 3 of 3

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Mon Mar 15, 2010 16:24
by ReemZ
np mate, didn't mean to snap at you at all :)

I just plugged the WB Book into the hub, playing a choon in Amarok ánd a movie with Dragon Player as I type this...so it's définitely the combination webcam-hub that is a no-go, webcam straight in pc works and WD Book via hub works...

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Tue Mar 16, 2010 8:02
by sjieke
I was just skimming through this thread, but I was thinking the 'not enough bandwidth' error is probably exactly the problem. I don't know the exact working of an usb hub, but if you think about it logically it makes sense.

1) Let's assume the usb hub contains 4 sockets.
2) You connect the usb hub directly to your pc's usb socket
3) The usb hub is connected to 1 usb socket, thus get's the power and bandwidth of 1 usb socket
4) Since the usb hub has 4 sockets available to plug devices in, each socket has only 1/4 of the power and bandwidth of the usb socket on the pc.

Could be completly wrong here, this is just how I see it...

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Tue Mar 16, 2010 12:25
by ReemZ
sjieke wrote:I was just skimming through this thread, but I was thinking the 'not enough bandwidth' error is probably exactly the problem. I don't know the exact working of an usb hub, but if you think about it logically it makes sense.

1) Let's assume the usb hub contains 4 sockets.
2) You connect the usb hub directly to your pc's usb socket
3) The usb hub is connected to 1 usb socket, thus get's the power and bandwidth of 1 usb socket
4) Since the usb hub has 4 sockets available to plug devices in, each socket has only 1/4 of the power and bandwidth of the usb socket on the pc.

Could be completly wrong here, this is just how I see it...

It's a 7 socket hub even...that would render it completely unusable...and why don't I notice any difference in the performance of the external HD, whether I plug it into the puter directly or through hub?

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Tue Mar 16, 2010 12:58
by sjieke
I guess the external HD has it's own power adapter, so having less power from the usb socket isn't a problem as the external HD doesn't use it.
As for the bandwidth. The theoritical speed for USB2.0 is 480 Mbit/s. Theoritical this would mean that you can get 60MB/s from it, but I read somewhere (can't remember where) that in practice it is more like 40MB/s. So if you could measure (human perception of speed isn't a good indicator) your external HD's datarate when connected directly to the pc and through the hub we would know for certain if the bandwidth is reduced.
You can use hdparm to measure read speeds.
For example
Code: Select all
hdparm -T /dev/sda


As I said before, I'm not certain if my theorie is correct, but I'm interested to find out :eye:

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Tue Mar 16, 2010 13:04
by ReemZ
Interesting! Gonna try that later today when I've more time to play around :D

Re: Can't load module usbcore(?) for webcam 0c45:6009

PostPosted: Fri Jan 27, 2012 22:00
by ReemZ
Very old thread about hardware of which I'm not even sure if I still have it (most likely @attic), so closing this case by marking as solved.