Getting PulseAudio to cooperate

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: Getting PulseAudio to cooperate

Postby Fitzcarraldo » Tue Sep 07, 2010 20:10

What output do you get when you run the following command as root user?:

Code: Select all
# lspci | grep Audio
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Getting PulseAudio to cooperate

Postby consolation » Tue Sep 07, 2010 23:48

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
02:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]


I might do a re-install in the weekend, thinking about a switch to xfce based spin anyway. It's probably some silly little glitch that we could spend days trying to track down, whereas a reinstall will just "fix" it. I'm pretty sure it was fine right after install and only got messed up during update. If I replicate it, I will file a bug report.
Sabayon amd64/Win 7/OSX via Chameleon on GUID HD
Acer Aspire 5740G
- it maybe be a cheaply made ghetto pos, but $/bang is all win.
- Intel Core i3, 4GB DDR3, ATI HD5650, 1 GB GDDR3, 500 GB, Atheros AR 5B93 wifi, Intel 272 audio + ATI HDMI
consolation
Baby Hen
 
Posts: 5
Joined: Thu Sep 02, 2010 5:51

Re: Getting PulseAudio to cooperate

Postby Fitzcarraldo » Wed Sep 08, 2010 0:25

Man, you also have the same on-board audio controller as my Mesh Edge DX laptop:

Code: Select all
meshedgedx rules.d # lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]
meshedgedx rules.d #

ALSA and PulseAudio should work. Works great on my laptop.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Getting PulseAudio to cooperate

Postby Fitzcarraldo » Thu Sep 16, 2010 20:06

Before folk start posting in this thread about KMix 4.5.1 showing only one channel, see the thread: KMix lost channels. :)

And as for the 'one channel', fire up Amarok or Clementine or whatever and get some sounds going, then run VLC or SMPlayer or whatever with a speaking video, then run a game with audio... and see how many channels you get now. :wink:

Just like Windows 7. :D

I can adjust the underlying ALSA channels using ALSAMixer and it does affect the microphone and master volume (100% master volume if I want it). It's very easy to use:



And use KMix with the overlying PulseAudio channels for normal use, or to adjust individual applications' audio when you have more than one audio application running, just like the example KMix image below from my laptop running KDE 4.5.1:

Image

and just like you can in Windows 7:

User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Getting PulseAudio to cooperate

Postby Fitzcarraldo » Fri Sep 17, 2010 10:29

Some people are reporting that their volume control setting is not being restored at start up to the level it was at before they shut down their PC.

PulseAudio and ALSA store volume separately, so it might be that the PulseAudio volume setting is overriding your ALSA setting. To see if that is the case, if you haven't already done so you can configure ALSA to store its volume settings by using the alsctl command. Have a look at the Arch Wiki article Restore ALSA Mixer settings at startup using the alsactl command. In the case of Gentoo/Sabayon Linux the file mentioned in that article would be /etc/init.d/local rather than /etc/rc.local, and, also, alsa is already in the list of daemons to start on boot-up (it's called alsasound in Gentoo/Sabayon), so there is no need to touch that. Try that first.

If that doesn't do it for you, edit the file /usr/bin/start-pulseaudio-x11 and make it look like this:

Code: Select all
#!/bin/sh

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

set -e

[ -z "$PULSE_SERVER" ]

# check if pulseaudio has already been started by someone else
if /usr/bin/pulseaudio --check; then
   EXIT_WITH_X_SESSION=no
else
   EXIT_WITH_X_SESSION=yes
fi

/usr/bin/pulseaudio --start "$@"

if [ x"$DISPLAY" != x ] ; then

    /usr/bin/pactl load-module module-x11-publish "display=$DISPLAY" > /dev/null
    /usr/bin/pactl load-module module-x11-cork-request "display=$DISPLAY" > /dev/null

    if [ x"$SESSION_MANAGER" != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null
    fi
fi

# fork and wait for X-session to end, then quit pulseaudio
if [ "$EXIT_WITH_X_SESSION" = yes ]; then
   /usr/bin/xprop -root -spy > /dev/null 2>&1 || true
   /usr/bin/pulseaudio --kill
fi &

Make sure you have not changed the file permissions, i.e. make sure it is still executable:

Code: Select all
ls -la /usr/bin/start-pulseaudio-x11
-rwxr-xr-x 1 root root 1184 Aug 16 19:25 /usr/bin/start-pulseaudio-x11


Refs.
pulseaudio does not remember volume settings, always set to 0
PA doesn't stop running after X-session has ended, although it is started as a session daemon


EDIT (September 17, 23:44 BST): And if the above still doesn't solve your problem, see the following post: Re: Where is the alsa configuration file?.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Getting PulseAudio to cooperate

Postby archwndas » Fri Sep 17, 2010 16:28

Hi guys,
I also have problems with pulse audio. Could you please show me a link or help me uninstall it and use the simple old trustworthy ALSA? Not to mention that it has a lot of dependencies that have nothing to do with it.
archwndas
Advanced Hen
 
Posts: 207
Joined: Mon Jun 04, 2007 14:54

Re: Getting PulseAudio to cooperate

Postby Fitzcarraldo » Fri Sep 17, 2010 16:45

Read through this thread for how to configure ALSA and PulseAudio. See the fourth post in this thread if you want to inhibit PulseAudio.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest