sound issue

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Re: sound issue

Postby shantanu » Wed Feb 18, 2009 15:38

i have compaq presario 3072TU laptop.
i booted from live dvd of SL4 and
su -
rmmod snd_hda_intel
modprobe snd_hda_intel
alsaconf
selected my sound card.
alsamixer

http://pastebin.ca/1341074 lsmod o/p
http://pastebin.ca/1341077 lspci -v

thanks a lot for the time and patience.

regards,
Shantanu
shantanu
Baby Hen
 
Posts: 8
Joined: Mon Feb 16, 2009 14:58

Re: sound issue

Postby Fitzcarraldo » Wed Feb 18, 2009 16:03

Well, your latest lspci looks more promising, as it now shows the HDA Intel driver and kernel module:

Code: Select all
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Hewlett-Packard Company Device 30b2
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at d4340000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel


If you look at K Menu > Control Centre > Sound & Multimedia > Sound System | Hardware, try changing 'Select the audio device' from 'Autodetect' to 'Advanced Linux Sound Architecture'. Also, on the General tab, try both enabling and disabling 'Enable the sound system' (you'll have to logout and in again, or enter the command /etc/init.d/alsasound restart for these to take effect). I'm no expert on Linux sound, but in some past releases of SL I've had to un-tick 'Enable the sound system' to get sound working, odd as that may seem. I think this may have been because KDE's sound system (aRts) was clashing somehow with the ALSA drivers.

Also, in case it's relevant, here is what is installed on my laptop, ALSA-wise:

Code: Select all
# eix -I alsa
[U] media-libs/alsa-lib
     Available versions:  1.0.14a-r1 (~)1.0.15 1.0.16 (~)1.0.16-r1 (~)1.0.17-r1 1.0.17a (~)1.0.18 (~)1.0.19 {alisp alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol debug doc midi python}
     Installed versions:  1.0.18(19:29:30 31/01/09)(alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol debug midi python -alisp -doc)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Library

[U] media-plugins/alsa-plugins
     Available versions:  (~)1.0.15 1.0.16 1.0.17-r1 (~)1.0.18 (~)1.0.19 {debug ffmpeg jack libsamplerate pulseaudio speex}
     Installed versions:  1.0.18(17:29:44 31/01/09)(ffmpeg jack libsamplerate pulseaudio speex -debug)
     Homepage:            http://www.alsa-project.org/
     Description:         ALSA extra plugins

[U] media-plugins/gst-plugins-alsa
     Available versions:  (0.10)  0.10.14 0.10.20 (~)0.10.21
     Installed versions:  0.10.20(0.10)(17:29:44 31/01/09)
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         plugin for gstreamer

[U] media-sound/alsa-firmware
     Available versions:  (~)1.0.15 1.0.16 (~)1.0.17 (~)1.0.19 {alsa_cards_aica alsa_cards_asihpi alsa_cards_darla20 alsa_cards_darla24 alsa_cards_echo3g alsa_cards_emi26 alsa_cards_emu1212 alsa_cards_emu1616 alsa_cards_emu1820 alsa_cards_gina20 alsa_cards_gina24 alsa_cards_hdsp alsa_cards_hdspm alsa_cards_indigo alsa_cards_indigoio alsa_cards_korg1212 alsa_cards_layla20 alsa_cards_layla24 alsa_cards_maestro3 alsa_cards_mia alsa_cards_mixart alsa_cards_mona alsa_cards_msnd-pinnacle alsa_cards_pcxhr alsa_cards_sb16 alsa_cards_usb-usx2y alsa_cards_vx222 alsa_cards_wavefront alsa_cards_ymfpci}
     Installed versions:  1.0.17(17:29:45 31/01/09)(alsa_cards_darla20 alsa_cards_darla24 alsa_cards_gina20 alsa_cards_gina24 alsa_cards_hdsp alsa_cards_hdspm alsa_cards_indigo alsa_cards_indigoio alsa_cards_layla20 alsa_cards_layla24 alsa_cards_mia alsa_cards_mixart alsa_cards_mona alsa_cards_pcxhr alsa_cards_sb16 alsa_cards_usb-usx2y alsa_cards_vx222 -alsa_cards_aica -alsa_cards_asihpi -alsa_cards_echo3g -alsa_cards_emi26 -alsa_cards_emu1212 -alsa_cards_emu1616 -alsa_cards_emu1820 -alsa_cards_korg1212 -alsa_cards_maestro3 -alsa_cards_msnd-pinnacle -alsa_cards_wavefront -alsa_cards_ymfpci)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture firmware

[U] media-sound/alsa-headers
     Available versions:  1.0.14!b!s (~)1.0.15!b!s 1.0.16!b!s 1.0.17!b!s (~)1.0.18!b!s (~)1.0.19!b!s [M]**9999!b!s
     Installed versions:  1.0.18!b!s(17:29:45 31/01/09)
     Homepage:            http://www.alsa-project.org/
     Description:         Header files for Advanced Linux Sound Architecture kernel modules

[U] media-sound/alsa-tools
     Available versions:  (0.9)  (~)1.0.15 1.0.16 (~)1.0.17 (~)1.0.18 (~)1.0.19
        {alsa_cards_darla20 alsa_cards_darla24 alsa_cards_echo3g alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_gina20 alsa_cards_gina24 alsa_cards_hdsp alsa_cards_hdspm alsa_cards_ice1712 alsa_cards_indigo alsa_cards_indigoio alsa_cards_layla20 alsa_cards_layla24 alsa_cards_mia alsa_cards_mixart alsa_cards_mona alsa_cards_pcxhr alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sb16 alsa_cards_sbawe alsa_cards_sscape alsa_cards_usb-usx2y alsa_cards_vx222 fltk gtk midi}
     Installed versions:  1.0.18(0.9)(17:29:45 31/01/09)(alsa_cards_darla20 alsa_cards_darla24 alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_gina20 alsa_cards_gina24 alsa_cards_hdsp alsa_cards_hdspm alsa_cards_ice1712 alsa_cards_indigo alsa_cards_indigoio alsa_cards_layla20 alsa_cards_layla24 alsa_cards_mia alsa_cards_mixart alsa_cards_mona alsa_cards_pcxhr alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sb16 alsa_cards_sbawe alsa_cards_sscape alsa_cards_usb-usx2y alsa_cards_vx222 midi -alsa_cards_echo3g -fltk -gtk)
     Homepage:            http://www.alsa-project.org
     Description:         Advanced Linux Sound Architecture tools

[U] media-sound/alsa-utils
     Available versions:  (0.9)  *1.0.14 (~)1.0.15 1.0.16 (~)1.0.16-r2 1.0.17 (~)1.0.18 (~)1.0.19
        {midi minimal nls}
     Installed versions:  1.0.18(0.9)(17:29:45 31/01/09)(midi nls -minimal)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)

Found 7 matches.


Also, copied below are the contents of the configuration file /etc/conf.d/alsasound on my laptop, in case it is of help.

Code: Select all
# ENABLE_OSS_EMUL:
# Do you want to enable in-kernel oss emulation?
# no - Do not load oss emul drivers
# yes - Load oss emul drivers if they're found

ENABLE_OSS_EMUL="yes"

# RESTORE_ON_START:
# Do you want to restore your mixer settings?  If not, your cards will be
# muted.
# no - Do not restore state
# yes - Restore state

RESTORE_ON_START="yes"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="yes"

# LOAD_ON_START:
# Do you want to load sound modules when alsasound starts?
# no - Do not load modules
# yes - Load modules
LOAD_ON_START="yes"

# UNLOAD_ON_STOP:
# Do you want to unload sound modules when alsasound stops?
# no - Do not unload modules
# yes - Unload modules
UNLOAD_ON_STOP="yes"

# KILLPROC_ON_STOP
# Do you want to kill any processes using ALSA when alsasound stops?
# If you are using ALSA modules, leave as yes.
# no - Do not terminate ALSA processes
# yes - Kill running processes using ALSA
KILLPROC_ON_STOP="yes"


The Gentoo Linux ALSA Guide might also be of help, as might be the Gentoo thread [gentoo-user] ALSA config problem in the Soft32 Forum.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: sound issue

Postby shantanu » Thu Feb 19, 2009 10:49

thanks for the time, i have already done the kmenu part you suggested, no luck.
i guess i will stick with ubuntu or mandriva till a new SL release which really works out of box for my h/w. this part has left a bit bitter taste about SL in my mind.
thanks again.
shantanu
shantanu
Baby Hen
 
Posts: 8
Joined: Mon Feb 16, 2009 14:58

Re: sound issue

Postby Fitzcarraldo » Fri Feb 20, 2009 19:49

"bitter taste in my mind"? I think you've got your cliché wrong there, shantanu.

Did you try the things listed in the Issues? section of the Gentoo Linux ALSA Guide? If not, why not give them a try before throwing in the towel?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: sound issue

Postby Gh0stRid3r » Thu Apr 23, 2009 12:55

I am a newbie, so please bear with me. I am using an AMD Opteron 1.8 64bit with Soundblaster Fata1ity card. I am a Windows tech head so directions I can follow, though you may be laughing at the windows and tech combo.

I tried the alsaconf under Root and it still didn't help. I can not get the alsamixer to run. I see the code select all on the scripts and I am not sure what you do to get those.

I appreciate whatever help you may give.

Thanks.
Gh0stRid3r
Baby Hen
 
Posts: 1
Joined: Thu Apr 23, 2009 12:31

Re: sound issue

Postby kodiakmax » Thu Apr 23, 2009 19:19

Some people have luck changing the switches in kmix.
If you check the wiki, use the search function and google you can find the answer to most of your questions.

Remember to mark your thread [Solved] if your issue is fixed.
kodiakmax
Advanced Hen
 
Posts: 278
Joined: Thu Oct 16, 2008 23:46

Re: sound issue

Postby Storm Rider » Sat May 02, 2009 0:31

Thank you.....

alsaconf and alsamixer did the trick for me. :)
Storm Rider
Simple Hen
 
Posts: 74
Joined: Thu Dec 14, 2006 10:24

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron