3.5 broke madwifi

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
acfreema
Young Hen
Posts: 25
Joined: Sun Nov 18, 2007 15:33
Location: west fargo, nd
Contact:

3.5 broke madwifi

Post by acfreema » Wed Aug 06, 2008 11:33

i had been using 3.5 loop2 because my atheros wireless adapter worked right away. i had to do some tinkering to get the gpu to work... and eventually got stuff functioning. now, 3.5 doesn't have atheros functionality from the start and i'm having some issues getting things up and running.

i have an asus f3ka-x2 with an atheros something (is it 5006? 5007? lspci reports ar242x). does anyone have any experience with this adapter in 3.5?

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: 3.5 broke madwifi

Post by wolfden » Wed Aug 06, 2008 11:50

from what I hear, the kernel 2.6.26 and madwifi-ng are suppose to have madwifi working

fred123
Baby Hen
Posts: 1
Joined: Mon Aug 11, 2008 3:08

Re: 3.5 broke madwifi

Post by fred123 » Mon Aug 11, 2008 6:22

Yeah, sabayon sucks in this fact. It loads ath5k so there is almost no way to stop it from loading so if you try to load madwifi it will tell give you HAL error 3. Which means it requires a reboot.

My only solution so far is to use debug in isolinux boot. Debug will only load a few drivers and then give you a shell. So it gives me a shell. Then I mount my ntfs partition and load madwifi from there and then exit the shell and sabayon loads. However, I can not mount the same partition under ntfs-3g later for some reason. So since my drive is split into two partitions, I use the first partition which around 1.3GB to load madwifi.

I hope this helps.

trout
Baby Hen
Posts: 4
Joined: Thu Sep 11, 2008 23:12

Re: 3.5 broke madwifi

Post by trout » Thu Sep 11, 2008 23:18

I had petty much the same experience. I also had a lot of circular dependancies and a general mishmash of a setup. It was a livecd install off the face of a magazine.

I downloaded the full 3.5 from a mirror site and installed to get 2.6.25-sabayon-r1 and followed the wiki pages from http://wiki.sabayonlinux.org/index.php? ... Madwifi-ng (which previously gave me all the errors) after doing a --sync.

Rebooted and everything works as expected. Very pleased.

Hope this helps someone !? :)

Post Reply