HP mouse problems

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: HP mouse problems

Post by xlnagla » Mon May 19, 2008 1:57

at any point - what you see is X, vt1 is another interface entirely. It doesn't matter what point you're at, as long as your computer is on and done booting.

~xlnagla

evilnone
Young Hen
Posts: 29
Joined: Fri Feb 15, 2008 4:05

Re: HP mouse problems

Post by evilnone » Mon May 19, 2008 1:58

but u mean after i emerge?

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: HP mouse problems

Post by xlnagla » Mon May 19, 2008 2:03

I had thought you already emerged the drivers.

~xlnagla

evilnone
Young Hen
Posts: 29
Joined: Fri Feb 15, 2008 4:05

Re: HP mouse problems

Post by evilnone » Mon May 19, 2008 2:17

i do emerge them... then i restart and i cant log in (keyboard mouse does nothing) but when i reboot everything is fine... (i use power button on front of pc to turn off) so... i just reemerged them (im in sabayon now) and i can do the ctrl alt f1 and log in... not sure what u need me to do though

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: HP mouse problems

Post by xlnagla » Mon May 19, 2008 2:34

I was going to tell you to remove them, but if a reboot fixes stuff then I guess don't bother. Did your double-click problem go away?

~xlnagla

evilnone
Young Hen
Posts: 29
Joined: Fri Feb 15, 2008 4:05

Re: HP mouse problems

Post by evilnone » Mon May 19, 2008 2:39

nope still here

xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: HP mouse problems

Post by xlnagla » Mon May 19, 2008 3:16

can you post your /etc/X11/xorg.conf please?

~xlnagla

evilnone
Young Hen
Posts: 29
Joined: Fri Feb 15, 2008 4:05

Re: HP mouse problems

Post by evilnone » Mon May 19, 2008 4:12

yeah here it is....

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  ([email protected])  gio gen 31 19:46:52 UTC 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
    FontPath        "/usr/lib/X11/fonts/local/"
    FontPath        "/usr/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/misc/"
    FontPath        "/usr/lib/X11/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/CID/"
    FontPath        "/usr/lib/X11/fonts/Speedo/"
    FontPath        "/usr/lib/X11/fonts/100dpi/"
    FontPath        "/usr/lib/X11/fonts/75dpi/"
    FontPath        "/usr/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/lib/X11/fonts/TTF/"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP w2207"
    HorizSync       24.0 - 82.0
    VertRefresh     48.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7350 LE"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1680x1050 +0+0; 800x600 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


xlnagla
Sagely Hen
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: HP mouse problems

Post by xlnagla » Mon May 19, 2008 5:02

try switching the mouse driver under the input device section to "evdev"

~xlnagla

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: HP mouse problems

Post by wolfden » Mon May 19, 2008 5:24

btw - to restart X
as root type:

Code: Select all

/etc/init.d/xdm restart
it does no good to install evdev but than not change the driver to it.

Post Reply