how to turn ACPI off? [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

how to turn ACPI off? [Solved]

Postby schmitt » Tue Mar 25, 2008 15:43

Where do I turn the acpi off, i found lots of topics saying that i have to turn acpi off to solve my freezing probblem but how do i exactly turn it off?
thx
Last edited by schmitt on Sat Mar 29, 2008 2:19, edited 1 time in total.
Image
schmitt
Baby Hen
 
Posts: 15
Joined: Tue Oct 30, 2007 3:09

Re: how to turn ACPI off?

Postby WarraWarra » Tue Mar 25, 2008 16:46

If you have a live cd /dvd check the readme file on the iso / cd /dvd .

noacpi or noapic one of them or something similar should be correct.

On cd / dvd boot menu press F5 only once you see the penguine / chicken foot logo / options to boot from the cd /dvd.
This opens some text at the bottom of the screen and you can enter the cheat codes
vga=791 something something -- "

Add to what is ther already the " noacpi " or " noapic " or both but noacpi should work.

First try this on the live cd /dvd and see how or if it works.

Or

If installed already it can be either the compiz fusion type acceleration that needs to be killed under start settings acceleration manager or there abouts and disable it / stop it from loading during boot.
WarraWarra
Sagely Hen
 
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: how to turn ACPI off?

Postby schmitt » Tue Mar 25, 2008 17:43

I have the system already installed
here is a copy of /boot/grub/grub.conf

Code: Select all
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,5)
#          kernel /boot/kernel-genkernel real_root=UUID=1f620502-004a-49b6-9a3a-90de5b2f01c9
#          initrd /boot/initramfs-genkernel
#boot=sda
default=1
timeout=6
splashimage=(hd0,5)/boot/grub/splash.xpm.gz
title Sabayon Linux x86 3.4 Standard Edition
   root (hd0,5)
   kernel /boot/kernel-genkernel-x86-2.6.22-sabayon  root=/dev/ram0 ramdisk=8192 real_root=UUID=1f620502-004a-49b6-9a3a-90de5b2f01c9  quiet  init=/linuxrc splash=silent,theme:sabayon vga=791 CONSOLE=/dev/tty1 pci=nomsi
   initrd /boot/initramfs-genkernel-x86-2.6.22-sabayon
title Windows
   rootnoverify (hd0,0)
   chainloader +1


where exactly should I add the noacpi or noapic?
Image
schmitt
Baby Hen
 
Posts: 15
Joined: Tue Oct 30, 2007 3:09

Re: how to turn ACPI off?

Postby schmitt » Tue Mar 25, 2008 17:51

I can start the system whit out problems but every time when I try to do something that needs a high processing level like open a movie or just browse some huge folders my mouse and keyboard freeze(but the system is still working, move still playing, still receiving msn messages....) .

Reading the forums I found that turning off ACPI might solve this
Image
schmitt
Baby Hen
 
Posts: 15
Joined: Tue Oct 30, 2007 3:09

Re: how to turn ACPI off?

Postby joost » Tue Mar 25, 2008 20:47

On newer kernels .23 .24 the flag acpi=offshould be used. Put this at the end of the kernel line.
joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: how to turn ACPI off?

Postby schmitt » Sat Mar 29, 2008 2:18

ok I guess I turned it off now thx!
Image
schmitt
Baby Hen
 
Posts: 15
Joined: Tue Oct 30, 2007 3:09


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests