8800 GTS 512 acceleration

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
Baby Hen
Posts: 3
Joined: Thu Jan 10, 2008 8:43

8800 GTS 512 acceleration

Post by Foose » Sun Mar 23, 2008 17:52

My graphics card is an XFX Alphadog 8800 GTS 512 the second generation 8800.
I have managed to install the Nvidia driver by doing the following.
Loged in as root
Then /etc/init.d/xdm stop. to stop the graphics server

su NVIDIA.run ( I shortened the name of the driver for ease ) the actual driver I downloaded was NVIDIA-Linux-x86-169.12.pkg1.run

The install did its usual and I forced it to compile its own kernal rather than downloading a recompiled one.

I now have the ability to use the proper resolution for my screen 1920x1400 things look good but im not getting any desktop acceleration which is stoping me from being able to use compizfusion.

I am also confused as to how im supposed to install apps as im trying to find a way of moving away from M$ and totally onto Linux. I am an eve player but that is for another problem in a diffrent part of the forum.

Main problem how to I get the desktop acceleration to start as it does not seem to want to. Every time I try to start it nothing seems to happen , Where the logs are so i can take a look I dont know otherwise I would have looked and googled the error.
the nvidia controll pannel seems correct but I can not be sure.

Any help on this appreciated.

Sagely Hen
Posts: 1651
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: 8800 GTS 512 acceleration

Post by Stupot » Sun Mar 23, 2008 22:13

First, what version of Sabayon are you using?

Second, for installing, Sabayon and gentoo use the portage system. Any general reading about portage should help you understand how to install applications. (I recommend Portato as a GUI to use for installing applications).

Third, you probably didn't need to do all you did to get graphics acceleration going, but I don't think you've made the problem worse, so that's good news. Trying running compiz from the terminal and see what output error it says. Also try running the Acceleration Manager and select AIGLX or Enhanced Desktop Experience (depending on the version), then try to start compiz again.

Baby Hen
Posts: 3
Joined: Thu Jan 10, 2008 8:43

Re: 8800 GTS 512 acceleration

Post by Foose » Sun Mar 23, 2008 23:39

Thanks stupot for the reply,
To answer your question's the version of sabion im using is 3.4 burnt from this iso SabayonLinux-x86-3.4f.iso
I have also tried the acceleration manager but after choosing either AIGLX or Enhanced Desktop Experience and hiting the enble / configure nothing happens.

Must admit I did not know about portato and am now looking into it. But I had to install the Graphics driver as the card is very new and the only driver it would use was the vesa one , Just getting linux any flavor to install on this machine with the current card is a pain in the butt.

Baby Hen
Posts: 1
Joined: Tue Mar 25, 2008 4:41
Location: Ontario, Canada

Re: 8800 GTS 512 acceleration

Post by OVERKILL » Tue Mar 25, 2008 5:12

I'm running an ASUS EN8800 GTS 512MB on my install (Gentoo, what Sabayon is based on) and it runs Compiz-Fusion without issue with full acceleration.

You need to familiarize yourself with the Portage system, as this is how things are (properly) installed in Gentoo/Sabayon.

1. Go to http://www.gentoo-portage.com
2. In the search query enter the search term Nvidia
3. You will see that the correct package that corresponds to what you are looking for is called "nvidia-drivers"
4. Go to a command prompt
5. Become Super User
6. Synchronize your portage tree, emerge --sync
7. Type the following: emerge -uvaD nvidia-drivers

******Side note: If I remember correctly (sorry, I run Gentoo, I use Sabayon on client's systems because it's MUCH faster and easier to install and it's pre-configuration is far superior to any other distro I've come across), Sabayon uses the unstable tree by default; ~x86, so on a Gentoo system, you'd have to echo the package name into package.keywords; you shouldn't have to on Sabayon.*******

8. The package will tell you after it installs to run eselect to change your OpenGL config to the Nvidia one.
9. Type modprobe nvidia and then lsmod and you should see that the nvidia module loaded. If this is the case, then the module is installed correctly.
10. Assuming you are doing this from a command prompt, type nano /etc/X11/xorg.conf
11. Modify the the device section of your config file to look SOMETHING like mine:

Code: Select all

Section "Device"

## === disable PnP Monitor  ===
    Identifier     "NVIDIA GeForce"
    Driver         "nvidia"
    Option         "AddARGBGLXVisuals" "true"
    Option         "UseEdidFreqs" "true"
    Option 	   "UseEdidDpi"	  "DFP-0"
    Option         "TripleBuffer" "true"
    Option         "NvAGP" "3"
    Option         "RenderAccel" "true"
    Option         "HWCursor" "true"
Note that your config file may differ substantially from mine, since mine has kind of "evolved" over the course of about 5 years :D

I can post additional sections of my config file if the above excerpt does not make yours function. Please note that the config file I am expecting that you are using is the default one from your Sabayon install, and NOT one generated by the NVidia driver installer from your previous efforts.

Please let me know if the above works for you.

Gentoo User, ASUS whore extraordinaire
ASUS Formula Maximus
ASUS 8800GTS 512MB
And lots of other irrelevant junk.

Baby Hen
Posts: 19
Joined: Tue Sep 25, 2007 14:42

Re: 8800 GTS 512 acceleration

Post by crusader » Tue Jun 10, 2008 17:46

I tried this configuration, but now every time I start my x my system restarts completly any idea what could causing that problem?

Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: 8800 GTS 512 acceleration

Post by WarraWarra » Wed Jun 11, 2008 15:40

# glxgears
This should throw out some pritty impressive numbers on the 8800nvidia at the 1920x1440 res you have.
Next lets presume that the video driver part is happy then might have to check the version of compiz /fusion you have and probably update it.

Best is to use portato or equo not sure what you have updated to latest version and or synced yet.
If unsure try
# emerge -s compiz

This should list compiz related installable files
# emerge -p compiz-something

Next install / update compiz if no red angry ones shows.

# emerge compiz-warrawarr-something
Everytime inserting correct name for compiz

This should fix any problem that compiz might have if it is compiz.

You can also just if you have the time / internet connection
# emerge --sync ; emerge portato ; emerge layman ; layman -s sabayon

# emerge --system

NB: The latet 17X.XX drivers is good and stable if using gentoo / portage / equo or nvidia unix one all is good.

Either way likely nvidia would be updated if not already or a missing deps replaced.

Someone else might post about error logs and seeing what happens in there but basically your dvd 3.4f needs to be updated with several fixes for compiz to work correctly see some of the other compiz post about 3.4F

Hope this helps.

Post Reply