8169 Ethernet missing

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

8169 Ethernet missing

Postby snekiepete » Thu Jan 17, 2008 5:24

I need some help with this, my ethernet adapter, Realtek r8169 works under windows and with the Sabayon 3.5 LiveDVD, however when I boot into the installed Sabayon (3.4f) sabayon kernel 2.6.22 or 2.6.24-rc1-kamikaze1, I have no ethernet. ifconfig shows the adapter is there, but it will not connect. If I rebooot, the device is gone completely. Then I go back into Windows and it is also missing there. I have to update the bios to get it back for windows, but it is not working well in Sabayon. Any thoughts?
Baby Hen
Posts: 1
Joined: Thu Jan 17, 2008 5:07

Re: 8169 Ethernet missing

Postby WarraWarra » Wed Jan 23, 2008 8:29

Some of our kernel has moded / experimental drivers for testing and this might be the reason why it works in say 3.5 beta and why it is not once rebooting.

Might have to recompile the kernel or say using one of the possible generic linux drivers in portage tree to get it going in 3.4f . This is not just realtek related had something similar with other drivers in the past for broadcom as well.

Might also try some of the drivers I posted here

http://www.google.co.za/search?q=8169+l ... =firefox-a

http://www.google.co.za/search?hl=en&cl ... arch&meta=

Something here might help and possibly try to use the old default gentoo from scratch methid for networking in the handbook / manual on gentoo website.

Hope this helps.
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest