Help My Epson CX3900 Printer Hates Me

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Help My Epson CX3900 Printer Hates Me

Postby copperdore » Sun Jan 06, 2008 6:38

Hi guys,

I'm running Sabayon 3.4 and for reasons best known to somebody else, I cannot get my Epson Stylus CX3900 printer (multifunction). I'm a newbie to Linux and more so to Sabayon but I have gone through distros than I care to count, none of which have been as easy to use as Sabayon, but the printing wasn't a problem on the other distros I was able to quite easily get that up and running using the cx805 driver for the printer through the KDE printer wizard. For some bizarre reason this process doesn't seem to work in Sabayon it just tells be that I don't have permission to perform this function at the point where i select the driver from the list. Anywho i've tried doing it through user, root, gnome, and through trying to get the avasys driver working and none have seemed to work. The scanner on the Epson CX3900 works fine no problems there but the printer is driving me insane.

I'm hoping some kind hearted soul with a gift for explaining how to fix this to a complete newbie can help me out with this issue. I'm completely stumped!

Thanks
copperdore
Baby Hen
 
Posts: 10
Joined: Sat Dec 29, 2007 3:23

Re: Help My Epson CX3900 Printer Hates Me

Postby Fitzcarraldo » Sun Jan 06, 2008 16:58

Have you tried doing it via the CUPS browser interface? Open Firefox or Konqueror or any other browser and type in the following URL:

http://localhost:631/

and then set it up from there.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Help My Epson CX3900 Printer Hates Me

Postby copperdore » Fri Jan 11, 2008 15:01

Thank you for that. I definitely got one step further. It worked i printed a test page and there were no problems....until i restarted and then, in true keeping with my usual computer experience, it decided it wasn't going to work. I think it might have something to do with the printer and scanner working off the same usb and how gentoo reads that. I'll keep messing with it until something works.
copperdore
Baby Hen
 
Posts: 10
Joined: Sat Dec 29, 2007 3:23

Re: Help My Epson CX3900 Printer Hates Me

Postby Fitzcarraldo » Fri Jan 11, 2008 17:44

Have you tried Googling? The following thread in the Gentoo forums looks like a possible solution:

http://forums.gentoo.org/viewtopic-t-55 ... x3900.html

(Scroll down and you'll notice the thread mentions your model of printer too.)
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest