Page 1 of 1

Intel GMA problem! [Solved]

Posted: Sat Nov 17, 2007 23:53
by ioannidis007
Hello there! I have a problem with my intel GMA graphics controller. I can't see anything in 3D! Compiz which is installed by default is not working. When I tried to rotate the cube, the cursor stuck and my computer too! Same with all 3D games including warsow, nexuiz, savage etc. I tried to install the drivers from and did everything the READMEs indicated. I changed my xorg.conf in order to load the new drivers but still no sign of improvement!

PS: I chose AIGLX when prompted because it worked fine with my Nvidia 5200s.

Re: Intel GMA problem!

Posted: Sun Nov 18, 2007 7:11
by WarraWarra
See one of the compiz fusion fixes posted recently as this should fix it for you. "kicker"

As for the driver =
as root in terminal or konsole:
# su
# lsmod
you need to see a i915 there and usually a number next to it say 204856 3 or similar = good module loaded.
# lspci
then see if it list the video card there 945 or similar should be okay.

if the above = not there then driver problem if all is listed then compiz problem.

run as root:
# glxgears
this should open a spinning thingy and list FPS or frame rates per second . If not / failed to show this then a error will appear and opengl or something is unhappy.

Post what you find if not working by that time and we can try to help.

Re: Intel GMA problem!

Posted: Sun Nov 18, 2007 18:02
by ioannidis007
The lsmod looks problematic. Have a look at this:

i915 41288 2
drm 136920 3 i915

Does this mean that i915 doesn't load properly and drm tries to fix it?

lspci seems ok to me:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Re: Intel GMA problem!

Posted: Sun Nov 18, 2007 21:28
by WarraWarra
This is fine like it is.
i915 is using DRM as well.
direct rendering manager -> DRM if not mistaken.

This should likely fix it.
As root in terminal / konsole.
# su
# layman -s sabayon && euse -E kickoff && emerge kicker desktop-acceleration-helpers

Both i915 and i810 is the working bits for the intel 950 video cards.
Yours could be the 960 or something one as 945gpm has 950 intel video card not sure what is on the 965pm intel motherboards might be the same 950 video chip.

More than this is beyond me maybe someone else or gentoo forums / wiki will have more on this.
Someone else posted here about dual display on intel 950 and the links in there is generric / can be applied ot yours likely to get it working correctly.

As last resort the acceleration manager is somewhere in the start menu and if you run this again = no glx / aiglx / glx and then select no glx + possibly kill cpmpiz but compiz might be able to work without aiglx / glx enabled not sure / no idea here.

Hope this helps.

PS> the web chat top right of this page has clued up persons using it maybe they have a quick answer for you or the irc live help chat thingy on the desktop ?

Re: Intel GMA problem!

Posted: Mon Nov 19, 2007 18:57
by ioannidis007
Cool! Thanks a bunch! I disabled glx and now all 3d games work just fine!